
Web Enablement Solutions
Suite

Read this manual carefully and keep it handy for future reference.

AFP Visual Environment:
Installing, Configuring,
and Using

Version 6.6

Overview 1

Installing AFP Visual Environment 2

Working with sample AFP files 3

Indexing AFP files 4

Editing AFP files 5

Adding content to white space in AFP files 6

Enhancing production AFP files 7

AFP Visual Environment commands 8

Configuration files 9

Accessibility

For information not in this
manual, refer to the Help
System in your product.





1

Introduction

Important ............................................................................................................................................ 5

Cautions regarding this guide............................................................................................................. 5

Publications for the Web Enablement Solutions Suite .......................................................................... 5

Symbols.............................................................................................................................................. 6

Abbreviations ..................................................................................................................................... 7

Trademarks......................................................................................................................................... 7

1 Overview

System overview .................................................................................................................................... 9

System requirements ............................................................................................................................11

User interface ......................................................................................................................................11

Control files..........................................................................................................................................17

Commands ..........................................................................................................................................17

Document index files............................................................................................................................17

AFP Indexer .........................................................................................................................................18

Page groups .....................................................................................................................................18

Supplemental pages.........................................................................................................................19

Index tags.........................................................................................................................................19

Resource group files .........................................................................................................................20

AFP Editor ............................................................................................................................................21

Barcodes ..........................................................................................................................................21

Hidden areas ...................................................................................................................................28

Text masks ........................................................................................................................................28

Whitespace Manager..........................................................................................................................29

White space .....................................................................................................................................29

Content.............................................................................................................................................31

Pipeline Manager ................................................................................................................................32

Standard filters .................................................................................................................................32

Supported Objects ...........................................................................................................................36

Supported structure fields ................................................................................................................36

2 Installing AFP Visual Environment

3 Working with sample AFP files

Converting line data to MO:DCA-P in sample AFP files ......................................................................41

Installing AFP Visual Environment .........................................................................................................41

Displaying sample AFP files .................................................................................................................42

TABLE OF CONTENTS



Creating and updating control files ......................................................................................................44

Identifying AFP resource directories .....................................................................................................45

Mapping fonts for AFP files ..................................................................................................................46

Using font-mapping files to map fonts ...............................................................................................47

Creating font mappings from text blocks...........................................................................................47

Modifying font mappings from text blocks ........................................................................................51

Changing the default code page encoding ......................................................................................52

Enabling object selection in sample AFP files .......................................................................................52

Showing page information in sample AFP files .....................................................................................53

Specifying a form definition .................................................................................................................54

Checking enhancements to sample AFP files ........................................................................................55

Configuring and running a set of filters.................................................................................................55

4 Indexing AFP files

Creating page groups..........................................................................................................................57

Creating page groups of fixed length ...............................................................................................57

Creating page groups with triggers ..................................................................................................58

Creating page groups when white space is found ............................................................................61

Defining header and trailer pages ....................................................................................................62

Defining supplemental pages...............................................................................................................63

Creating triggers for supplemental pages .........................................................................................63

Creating index tags on supplemental pages .....................................................................................65

Creating index tags..............................................................................................................................65

Creating index tags for text blocks....................................................................................................65

Creating index tags in areas.............................................................................................................67

Creating index tags in address areas................................................................................................69

Creating index tags from NOP records.............................................................................................72

Working with page-level indexes.........................................................................................................73

Creating page-level triggers .............................................................................................................74

Creating page-level indexes.............................................................................................................75

Copying or moving page-level indexes to page groups ...................................................................77

Modifying or deleting AFP Indexer definitions......................................................................................77

Modifying triggers ............................................................................................................................78

Deleting triggers ...............................................................................................................................78

Modifying index tags for text blocks .................................................................................................79

Modifying index tags in areas ..........................................................................................................80

Modifying index tags in address areas .............................................................................................82

2



Deleting index tags...........................................................................................................................83

Using existing page groups and index tags .........................................................................................84

Editing text for triggers and index tags .................................................................................................86

Managing comments ...........................................................................................................................88

5 Editing AFP files

Creating barcodes...............................................................................................................................89

Type tab ...........................................................................................................................................90

Data tab for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code
barcodes.......................................................................................................................................93

Data tab for IMBs.............................................................................................................................94

Position tab.......................................................................................................................................96

Replacing POSTNET barcodes with IMBs ............................................................................................98

Type tab for IMBs...........................................................................................................................100

Data tab for IMBs...........................................................................................................................101

Position tab for IMBs.......................................................................................................................102

Creating IMB serial number files ........................................................................................................104

Creating conditions between barcode definitions...............................................................................105

Creating hidden areas .......................................................................................................................105

Creating text with AFP Editor..............................................................................................................107

Defining text masks ............................................................................................................................109

Modifying or deleting AFP Editor definitions.......................................................................................110

Modifying barcodes .......................................................................................................................110

Deleting barcodes ..........................................................................................................................119

Modifying conditions between barcode definitions.........................................................................120

Deleting conditions between barcode definitions............................................................................120

Modifying hidden areas .................................................................................................................120

Deleting hidden areas ....................................................................................................................122

Modifying text strings .....................................................................................................................122

Deleting text strings.........................................................................................................................124

Modifying text masks......................................................................................................................124

Deleting text masks .........................................................................................................................125

Editing text for text masks................................................................................................................125

6 Adding content to white space in AFP files

Creating definitions for known white space........................................................................................127

Creating definitions by searching for white space ..............................................................................129

Modifying or deleting white space definitions ....................................................................................131

3



Modifying known white space definitions .......................................................................................131

Modifying white space defined from a search ................................................................................132

Deleting white space definitions......................................................................................................133

Assigning content to white space .......................................................................................................133

Creating rules for assigning content ................................................................................................133

Inserting content text .......................................................................................................................135

Inserting content images .................................................................................................................137

Modifying content text ....................................................................................................................138

Modifying content images ..............................................................................................................139

Creating rule conditions for content ................................................................................................140

Modifying rule conditions for content..............................................................................................141

Deleting content from white space ..................................................................................................142

7 Enhancing production AFP files

Sending AFP Visual Environment files to the production system ..........................................................143

Creating page groups and indexes in production AFP files ................................................................143

Creating hidden areas, bar codes, and text masks in production AFP files .........................................144

8 AFP Visual Environment commands

EditAFP command..............................................................................................................................147

IndexAFP command...........................................................................................................................150

PluginMgr command..........................................................................................................................153

9 Configuration files

Font mapping files..............................................................................................................................157

CharacterSets.properties file...........................................................................................................157

CodedFonts.properties file..............................................................................................................158

CodePages.properties file...............................................................................................................160

SampleCodePointMap.cp file.........................................................................................................160

IMB serial number file ........................................................................................................................161

Document index file ...........................................................................................................................162

Resource group file ............................................................................................................................163

10 Accessibility

INDEX

4



5

IInnttrroodduuccttiioonn

Important

To the maximum extent permitted by applicable laws, in no event will the manufacturer be liable for any
damages whatsoever arising out of failures of this product, losses of documents or data, or the use or
non-use of this product and operation manuals provided with it.

Make sure that you always copy or have backups of important documents or data. Documents or data
might be erased due to your operational errors or malfunctions of the software. Also, you are
responsible for taking protective measures against computer viruses, worms, and other harmful software.

In no event will the manufacturer be responsible for any documents created by you using this product or
any results from the data executed by you.

Cautions regarding this guide

• Some illustrations or explanations in this guide could differ from your product due to improvement or
change in the product.

• The contents of this document are subject to change without notice.

• No part of this document may be duplicated, replicated, reproduced in any form, modified, or
quoted without prior consent of the supplier.

Publications for the Web Enablement Solutions Suite

This section provides a list of all the publications for the Web Enablement Solutions Suite transforms.

Instruction manuals

• AFP2PDF PLUS
For information about AFP2PDF PLUS, see these documents:

– AFP2PDF Plus User Guide - 1.300

– AFP2PDF Plus Quick Start Guide

– AFP2PDF Plus Setup Guide 1.300

– AFP2PDF Plus Release Notes 1.300

– AFP2PDF Plus - Summary of Updates

• AFP Visual Environment
For information about AFP Visual Environment, see these documents:

– AFP Visual Environment User Guide 6.6

– AFP Visual Environment Release Notes 6.6

– AFP Visual Environment 6.6 Limitations List



• AFPMerge
For information about AFPMerge, see these documents:

– AFPMerge User Guide 3.3

– AFPMerge Release Notes 3.3

– AFPMerge 3.3 Limitations List

• Line2PDF Plus
For information about Line2PDF Plus, see these documents:

– Line2PDF Plus User’s Guide 1.3

– Line2PDF Release Notes 1.3

– Line2PDF Plus 1.3 Limitations List

• PCL2PDF
For information about PCL2PDF, see these documents:

– PCL2PDF 1.3 User’s Guide

– PCL2PDF 1.3 Release Notes

– PCL2PDF 1.3 Limitations List

• PS2PDF
For information about PS2PDF, see these documents:

– PS2PDF 1.3 User’s Guide

– PS2PDF 1.3 Release Notes

– PS2PDF 1.3 Limitations List

• Tiff2PDF
For information about Tiff2PDF, see these documents:

– Tiff2PDF Plus User Guide 1.3

– Tiff2PDF Plus Release Notes 1.3

– Tiff2PDF Plus 1.3 Limitations List

Symbols

The following symbols are used in this manual to help you to identify content quickly.

• This symbol indicates points to pay attention to when using the product. Be sure to read these
explanations.

• This symbol indicates helpful supplementary information that is not essential to completing a task.
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Bold Bold type indicates the names of commands and parameters.

Bold underline Underlined bold type indicates the default value.

Italic Italic type indicates variables that you must replace with your own
information.

Monospace Monospace type indicates computer input and output and file names.

[] Square brackets indicate that a value is optional.

| A vertical bar indicates a choice between values.

... An ellipsis indicates that a series can continue.

Abbreviations

AFP
Advanced Function Presentation

GIF
Graphical Interchange Format

IP
Internet Protocol

JPEG
Joint Photographic Experts Group

PCL
Printer Command Language

PDF
Portable Document Format

TIFF
Tagged Image File Format

Trademarks

These terms are trademarks or registered trademarks of Ricoh Co., Ltd., in the United States, other
countries, or both:

• RICOH InfoPrint Manager

• RICOH ProcessDirector

These terms are trademarks or registered trademarks of International Business Machines Corporation in
the United States, other countries, or both:
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• AIX

• IBM

• Print Services Facility

• z/OS

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States,
other countries, or both.

Intelligent Mail is a registered trademark of the United States Postal Service.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries,
or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, or service names may be trademarks or service marks of others.
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AFP Visual Environment lets you enhance AFP files without changing the applications that create the AFP
files. For example, you can use AFP Visual Environment to index AFP files and to add bar codes in AFP
files. The AFP files that you enhance must contain data in Mixed Object Document Content Architecture
for Presentation (MO:DCA-P) format.

You can enhance AFP files that contain MO:DCA-P data in different ways depending on which
components of AFP Visual Environment are installed:

• The AFP Indexer component lets you create AFP page groups and indexes, and define
supplemental pages.

• The AFP Editor component lets you create bar codes and text, and hide areas that contain
unwanted content, such as obsolete bar codes.

• The Whitespace Manager component lets you define available areas of white space in AFP files
and then fill the white space with content, such as images and text, during the print production
process.

• The Pipeline Manager component lets you configure and run a set of filters, in a specific order, to
process large AFP files quickly and efficiently.

AFP Visual Environment can make the same enhancements on the same pages in all page groups in the
AFP file. Page groups are AFP structures that organize AFP files into smaller, uniquely identifiable units.
For example, if an AFP file contains several bank statements that all have the same format, each
statement can be a page group.

SSyysstteemm oovveerrvviieeww
AFP Visual Environment has a preparation phase and a production phase.

• Preparation phase: During this phase, you use the AFP Visual Environment user interface to define
the enhancements you want to make using a sample AFP file. A sample AFP file is a file that is
representative of your production AFP files. The user interface can run on IBM AIX, Linux, or
Microsoft Windows systems.

• Production phase: During this phase, you run an AFP Visual Environment command to enhance
your production AFP files in the same way that you enhanced the sample AFP file. The AFP Visual
Environment commands can run on IBM AIX, IBM z/OS, or Microsoft Windows systems.

The preparation and production phases can run on the same system, or you can complete the
preparation phase on one system and then run the production phase on another system.

AFP Visual Environment system overview, p. 10 provides an overview of how AFP Visual Environment
works.
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AFP Visual Environment system overview

AFP Visual Environment system overview, p. 10 shows this process:

1. The administrator selects a sample AFP file that is representative of the production AFP files that you
want to enhance. The AFP resources that the AFP file references (fonts, page segments, and
overlays) can be inline or in resource directories accessible to the user interface.
If the sample file contains line-mode or mixed-mode data, the administrator must first use the AFP
Conversion and Indexing Facility (ACIF) program to convert data to MO:DCA-P format.

2. The AFP Visual Environment user interface displays the sample AFP file. The administrator uses the
user interface to visually enhance the sample AFP file. For example, the administrator can select the
text to use as a trigger to create page groups, select the text to index, draw a box to cover an
unwanted bar code, and create a new bar code.

3. AFP Visual Environment creates a control file that contains definitions for all the enhancements
made to the sample AFP file.
As an option, AFP Visual Environment can create an AFP file that contains the data in the sample file
and the enhancements defined in the control file. The administrator can print the enhanced sample
AFP file on the production printer to check the enhancements before applying them to production
AFP files.

4. Optional: If the production system is different from the preparation system, the administrator sends a
copy of the control file to the production system.

5. On the production system, an AFP Visual Environment command makes the same enhancements to
production AFP files using the definitions in the control file. AFP resources can be inline or in
resource directories accessible to the command.
You can run the AFP Visual Environment command from the AIX, Windows, or z/OS UNIX
command line, or you can use a script or procedure to call the command.

1 Overview
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6. An AFP Visual Environment command creates AFP files that contain the enhancements. You can print
these files using IBM Print Services Facility (PSF) for z/OS or RICOH InfoPrint Manager™ for AIX
and Windows. Or, you can archive the AFP files using IBM Content Manager OnDemand for
Multiplatforms.
As an option, AFP Visual Environment can create these files:

• Document index file: This file contains the index tags (Tag Logical Element structured fields) in
the output AFP file. This file is useful if you want to archive an AFP file and use the index file to
retrieve information from it.

• Resource group file: This file contains all the AFP resources that the output AFP file references.
This file is useful if any AFP resources are not inline and you want to view or print the file on
another system that does not contain the AFP resources, or if you want to archive the AFP file so
that you can print it later using the original resources.

SSyysstteemm rreeqquuiirreemmeennttss
The AFP Visual Environment user interface and the AFP Visual Environment commands can run on the
same system or on different systems.

The AFP Visual Environment user interface can run on any of these operating systems with a browser:

• IBM AIX

• Linux

• Microsoft Windows

The AFP Visual Environment commands can run on any of these operating systems:

• IBM AIX

• IBM z/OS with UNIX System Services

• Microsoft Windows

• Linux

The AFP Visual Environment user interface and commands require Java Runtime Environment 1.5 or later
with multi-language support.

UUsseerr iinntteerrffaaccee
You use the AFP Visual Environment user interface to display and enhance sample AFP files.

The AFP Visual Environment user interface can display one AFP file at a time–up to 1,000 pages. It can
display:

• Bar Code Object Content Architecture (BCOCA) objects: POSTNET barcodes, Intelligent Mail
barcodes (IMBs), Interleaved 2of5, Code39, and QR Code

• Graphics Object Content Architecture (GOCA) objects

• IM1 and Image Object Content Architecture (IOCA) images

• Index tags (also called Tag Logical Elements or TLEs)

• Joint Photographic Experts Group (JPEG) images

• Medium map information in a form definition, including overlay, page, and sheet information

System requirements
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• Overlays

• Page segments

• Text, including outline fonts, double-byte character set (DBCS) fonts, and text barcodes (text
barcodes use barcode fonts)

The user interface cannot display all AFP objects, and it might not display some text and AFP objects
with complete fidelity. These are the limitations:

• BCOCA objects: The user interface can only display POSTNET, IMB, Interleaved 2of5, Code39,
and QR Code BCOCA objects. For other types of BCOCA objects, it displays a box the size of the
barcode area. It cannot display any human-readable interpretation (HRI) text.

• Form definitions: The user interface does not apply any modifications in the form definition (such
as print direction, page position, constant back, and N_UP page positioning).

• Images: Images might differ from printed images because of color differences and resolution
differences between monitors and printers.

• Text: The user interface cannot display user-defined characters in DBCS fonts.

The user interface has several modes. The modes that are available depend on the components that are
installed. Each mode lets you make different enhancements. The AFP Indexer mode lets you create page
groups and index tags. The AFP Editor mode lets you create barcodes, text, and hidden areas.
Whitespace Manager lets you create definitions for white space and fill the white space with content. .

This diagram shows the major parts of the user interface. It shows the title bar, menu bar, toolbar, AFP
file, file-structure pane, index pane, and status bar.

1. Title Bar

2. Menu bar

3. Tool bar

1 Overview
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4. AFP file

5. Page pane

6. Index pane

7. Status bar

Title bar

The title bar at the top of the window identifies the mode that is active, the AFP file that is open, and any
control file that is open.

Menu bar and toolbar

The menu bar is below the title bar. Below the menu bar is the toolbar, which contains icons for the most
common functions available on the menu bar. The options on the menu bar and toolbar vary depending
on whether an AFP file is open. If an AFP file is not open, you see only the File and Help options. If an
AFP file is open and a mode is selected, you see all options.

The menu bar options, with the keyboard shortcuts and toolbar icons, are:

File
The File menu options are:

Open AFP File (Ctrl+O)
Opens the AFP file that you want to enhance. If another AFP file is already open, it is
automatically closed. If you have not saved the control file for the AFP file that is already
open, AFP Visual Environment lets you save the control file before it opens the new AFP file.

Open Control File
Opens an existing control file that you created previously.

Reset
Closes the current AFP file and clears cached resources from memory.

Save Control File (Ctrl+S)
Saves the control file for the open AFP file. A control file with the same name is overwritten.

Save Control File As
Saves the control file for the open AFP file. You can specify a name and directory for the
control file.

Save Plug-in Output
Saves the sample AFP file with any enhancements that were made. After you save the file,
you can print and verify the enhancements. You can specify a name and directory for the
output file.

Exit
Stops AFP Visual Environment. If you have not saved the control file for the AFP file that is
open, AFP Visual Environment lets you save it.

View

User interface
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The View menu options are:

File View
Displays the inline resource group and the page structure of the AFP file in the left pane. You
can double-click a page to display it.

Index View
Displays the index tags and the index tag values for the AFP file in the bottom pane. You can
double-click a page group to display the first page of the page group.

Rotate by 90o (Ctrl+R)
Rotates the AFP file clockwise in increments of 90 degrees so that you can view it more
easily.

Units
Displays measurement units in inches (USA default) or millimeters (non-USA default).

Zoom
Changes the display size of the AFP file by the percentage you select.

Resources
The Resources menu options are:

Change Form Definition Settings
Lets you specify whether form definitions and medium maps are used. If so, you can specify
that an inline form definition is used or specify a directory for a default form definition.

Enable Object Selection
Indicates which objects you can select in the AFP file for the active mode. The selectable
objects change when you select a new mode or open a new AFP file.

Modify Default Encoding
Lets you specify the default code page encoding.

Modify Font Mapping
Lets you modify defined character set, coded font, and code page font mappings.

Show Page Information
Shows the AFP resources that the page refers to and whether they were found and where.

Specify Resource Directories
Lets you specify the directories that contain AFP resources, such as fonts.

Tools
The Tools menu options vary depending on which mode is active. If no mode is active, no options
are available. Tool menu options, p. 15 shows the tools menu options that are available for each
active mode.

1 Overview
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TTooooll mmeennuu ooppttiioonnss

Mode Option Description

AFP Editor Modify Definitions
Lets you modify or delete
definitions for barcodes, text,
operators, hidden areas, and
text masks.

Import user exit Lets you work with exits.

AFP Indexer Header and Trailer Pages Lets you define the number of
header and trailer pages and
indicate whether the pages are
contained in the final output.

Index Tools Lets you create indexes from
page group NOP records – on
a page or outside a page,
relocate page indexes to page
groups, or edit existing
indexes.

Modify Definitions Lets you modify or delete
definitions for page groups and
index tags.

Other Page Groups Lets you use existing page
groups or create fixed-length
page groups.

Manage Comments

Import user exit Lets you work with exits.

Whitespace Manager Manage Campaigns Lets you assign image and text
content to defined white space
areas.

Modify Definitions Lets you modify or delete
definitions for white space
areas.

Pipeline Manager Manage Pipeline Lets you configure and run a
set of filters, in a specific order,
to quickly and efficiently
process large AFP files.

Mode
TheMode menu options vary depending on which components are installed.
You must select a mode before you can enhance an AFP file. The possible modes are:

AFP Editor
Creates definitions for barcodes, hidden areas, text strings, and text masks in the control file.

User interface
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AFP Indexer
Creates definitions for page groups and index tags in the control file.

Whitespace Manager
Creates definitions for white space in the control file and fills the white space with content.

Pipeline Manager
Orders and runs a set of filters.

Help
The Help menu options are:

AFP Editor Help
In AFP Editor mode, opens the help topics for AFP Editor.

AFP Indexer Help
In AFP Indexer mode, opens the help topics for AFP Indexer.

Whitespace Manager Help
In Whitespace Manager mode, opens the help topics for Whitespace Manager.

Pipeline Manager
In Pipeline Manager mode, opens help topics for Pipeline Manager.

Help Contents (F1)
Opens the help topics for the AFP Visual Environment user interface.

About
Displays the version number of AFP Visual Environment and the contact information for
obtaining assistance.

AFP file

The main pane displays the AFP file. You can see text (including text barcodes that use fonts), images,
overlays, page segments, GOCA objects, and some types of BCOCA barcode objects.

File-structure pane

The left pane displays the page structure of the AFP file. You can double-click a page to display it. If the
AFP file contains page groups, this pane also shows the page groups. You might also see a resource
group entry at the top of the page structure if the file contains inline AFP resources, such as overlays and
page segments.

Index pane

The Indexes tab in the bottom pane displays the index tags that exist in the AFP file and that are
defined in the control file. For each index tag, you see the value of the index tag in each page group.
You can double-click a page group to display the first page of the page group.

1 Overview



1

17

Status bar

The status bar at the bottom of the window displays the number of the current page in the AFP file. If text
is selected in the AFP file, it also displays the origin of the text block (X and Y position in inches or
millimeters).

CCoonnttrrooll ffiilleess
AFP Visual Environment control files contain information about the enhancements made to sample AFP
files. AFP Visual Environment commands use control files to make the same enhancements to production
AFP files.

When you enhance a sample AFP file, AFP Visual Environment creates a control file that contains
information about how to make the enhancements. The enhancements are not made in the sample AFP
file. To see the enhancements when you open the sample AFP file in a subsequent session, you must also
open the control file that was used to enhance the sample file.

If you enhance the same sample AFP file (or a similar AFP file) again in another session, AFP Visual
Environment can use the same control file. All enhancements for the sample AFP file must be defined in
the same control file. AFP Visual Environment can add all enhancements to the same control file
regardless of which component you use to make the enhancements.

Unless you change the name of the control file and its directory path, the control file has the same name
as the sample AFP file with a .ctl extension and is saved in the same directory as the sample file. If you
want to use a different naming scheme, use one that associates the sample AFP file with its control file.

CCoommmmaannddss
The AFP Visual Environment commands use the information in the control file to make the same
enhancements to a production AFP file that the administrator made to the sample AFP file. The
commands create new AFP files with the enhancements; they do not update the production AFP files.

The AFP Visual Environment commands are:

• EditAFP: This command applies the definitions in the control file to hide areas, create bar codes,
and mask text in a production AFP file. It is available only if AFP Editor is installed.

• IndexAFP: This command applies the definitions in the control file to create page groups and index
tags in a production AFP file. It is available only if AFP Indexer is installed. The IndexAFP command
can also create a document index file and a resource group file.

• PluginMgr: This command can run EditAFP, IndexAFP, or both. It can apply all the definitions in the
control file to a production AFP file. If you want to apply all the definitions in a control file to
production AFP files, it is more efficient to use PluginMgr than to run the EditAFP and IndexAFP
commands separately.

DDooccuummeenntt iinnddeexx ffiilleess
The IndexAFP command and the PluginMgr command can create a document index file that contains all
the index tags in a production AFP file. The index tags can be defined in the AFP file itself or in the AFP
Visual Environment control file.

The document index file lets you use an archival and retrieval application, such as IBM Content
Manager on Demand, to retrieve a page group within the AFP file based on its index values.

Control files
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For example, if the account number in an AFP file is indexed, or if the data encoded in the Intelligent
Mail™ bar codes (IMBs) is indexed, you can use an account number or IMB data to retrieve the
relevant page group.

AAFFPP IInnddeexxeerr
AFP Indexer lets you create page groups, define supplemental pages, and create indexes in AFP files.
When you view an AFP file that contains page groups and indexes, you can navigate in the file to find
pages containing specific index values.

AFP Indexer can also create a resource group file for each production AFP file. This file can help you
print the archived AFP file at a later date with the original resources.

Page groups

AFP Indexer lets you organize a large AFP file into smaller, uniquely identifiable units, called page
groups.

You can create page groups in these ways:

• You can create page groups that have a fixed number of pages. For example, each page group
can be three pages long. You can also exclude a certain number of pages at the beginning of the
AFP file from the page groups. For example, if the AFP file contains two pages of introductory
information, AFP Indexer can skip the first two pages and create the first page group on the third
page.

• You can use triggers to define the page groups. A trigger is a block of text in the AFP file that
occurs in a consistent location on the first page of all page groups and can contain the same text.
As an option, you can also use triggers to indicate the end of page groups. For example, the block
of text that indicates the start of the page group might contain the text “Page 1” and the block of
text that indicates the end of the page group might contain the text “Page 3”. If necessary, you can
use multiple triggers to uniquely identify a new page group.

For example, a bank-statement application produces a file with hundreds of individual customer
statements. Each statement has the same general format, although statements might vary in size or
number of pages. Each statement contains the page number, an account number, a date, and the
customer's address. With AFP Indexer, you create triggers that define the group boundaries in the file; in
this example, one trigger could be the text “Page 1” that occurs on the first page of every statement and
another trigger could be the text “Account Summary” that occurs on the last page of every statement.

If you create page groups using triggers or if you create page groups of fixed length, all existing page
groups and index tags that are defined in the AFP file itself are ignored.

You can define which pages are used for header and trailer pages. AFP Indexer creates the first page
group after the defined number of header pages. It creates the final page group before the defined
number of trailer pages.

To create more types of triggers than the control file allows, you can use exits. You can import a trigger
exit to override the trigger definitions in the control file if you need more options for creating page
group boundaries in the AFP file.
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Supplemental pages

AFP Indexer lets you define pages in an AFP file as supplemental pages. Supplemental pages are
those pages that you do not want included in page groups, such as header and trailer pages, separator
pages, or any page that should be excluded from a customer statement.

Pages in an AFP file that are defined as supplemental pages can be indexed.

You can define supplemental pages in these ways:

• You can use a trigger to define a block of text that occurs in a consistent location and uniquely
identifies a page. If necessary, you can use multiple triggers to identify supplemental pages. For
example, you can create a trigger for a block of text that exists on the third page in a page group.
The supplemental page is removed from each page group.

• You can use an index tag to define a block of text that occurs in a consistent location on a page that
is outside a page group. For example, you can create an index tag for a block of text that exists on
the header and trailer pages. You can edit the text value to remove unwanted text such as blanks or
special characters.

When you define a supplemental page, you give it a page definition name. You can assign multiple
index tags and triggers to the same supplemental page definition.

The term “page definition” in AFP Indexer refers to a supplemental page definition, a page-level
trigger, or a page-level index, not the AFP page definition resource.

For example, a bank-statement application produces a file with hundreds of individual customer
statements. The file contains a header page before the customer statements and a trailer page at the
end of the customer statements. Each statement ends with a page that separates it from the next
statement. With AFP Indexer, you create triggers that define the header, trailer, and separator pages as
supplemental pages with page definition names of Header, Trailer, and Separator. You can then create
index tags on the supplemental pages.

Index tags

The AFP Indexer mode of AFP Visual Environment lets you index data values that are consistently
present in the same location in each page group or on a supplemental page. Index tags define the
data values on a page. (Index tags are called Tag Logical Elements (TLEs) in the AFP architecture.)

You can create index tags in these ways:

• You can create an index tag for a block of text that occurs in a consistent location on the same
page in every page group, on a supplemental page, or on an individual page in a page group. For
example, you can create an index tag for a block of text that contains a customer name or an
account number. You can edit the text value to remove unwanted text such as blanks or special
characters.

• You can create an index area that occurs in a consistent location on the same page in every page
group or supplemental page and create index tags within the area. Within an index area, you can
create index tags that span multiple text blocks on the same line. For example, if one text block on a
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line contains the first half of an account number and the next text block on the line contains the
second half of the account number, you can concatenate the values in the text blocks and create
one index tag that spans both blocks of text.

• You can create index tags for an address area in a page group or supplemental page. An
address area is useful when you want to index mailing addresses that can contain a different
number of lines in each page group. For example, the address in one page group might contain
four lines, while the address in another page group might contain five lines. Within an address area,
you can do specialized functions that apply to addresses. For example, you can create an index
tag for a ZIP Code in the U.S. Postal Service format (nnnnn or nnnnn-nnnn) that occurs on the last line
of the address area (or on a line relative to the last line).

• You can create index tags for No Operation (NOP) records. A NOP record causes an
application to move to the next instruction for processing without taking any other action. NOP
records can be found anywhere in a page group–either on a page in the page group or outside the
logical AFP pages. NOP records in the AFP file are not viewable or printable, but you can create
index tags from the data contained in them. You can create index tags for NOP records that are in
the same position in all page groups, but outside a page, or you can create index tags for specific
NOP records that are in any location in the page groups–on a page or outside a page.

For example, a bank-statement application produces a file with hundreds of individual customer
statements. Each statement has the same general format, although statements might vary in size or
number of pages. Each statement contains the page number, an account number, a date, and the
customer's address. After you use AFP Indexer mode to create page groups and define supplemental
pages, you create an index tag for the account number and another index tag for the date so that when
you view production AFP files, you can display a particular statement based on the account number or
date. You might create additional index tags for values in the customer address, such as the ZIP Code,
so that you can sort statements (documents) according to ZIP Code before printing. You can use AFP
Editor mode to create barcodes that contain the ZIP Code.

If the AFP file is already indexed, you can add new index tags to use with the existing page groups and
supplemental pages. You can also update an existing control file for an AFP file and add new index
tags to the existing ones.

To create more types of index tags than the control file allows, you can use exits. You can import a user
exit to modify existing index tags or to add new index tags. For example, you might want to change the
index tag of the customer number to include a 3-character prefix. Or, you might need custom code to
create an index tag for information that is not at a consistent location in the page group.

Resource group files

The IndexAFP command can create a resource group file that contains all the AFP resources that a
production AFP file references.

The resource group file lets you print an AFP file on another system where the AFP resources are not
present. It also lets you reprint an archived AFP file using the original resources.

For example, suppose that a page segment contains a company officer's signature and is included in
the print data. When someone else replaces the officer, current print files must contain the new officer's
signature, but archived files must contain the former officer's signature. To print an archived file with the
original resources, you use the resource group file.
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AAFFPP EEddiittoorr
AFP Editor lets you create barcodes, text, and hidden areas in documents.

Barcodes and text are used for a variety of purposes, such as routing and tracking mail and adding
page numbers to documents. If you hide areas in documents, no one using an AFP viewer sees the data
in the area, and the data does not print. AFP Editor also lets you mask sensitive text that you do not want
anyone to view or print.

Barcodes

A barcode is a pattern of elements (such as bars, spaces, and two-dimensional modules) that represent
numeric or alphanumeric information in a machine-readable form.

The way the elements of a barcode are arranged is called the barcode type, or symbology. AFP
Editor lets you create these types of barcodes:

• Code 39 (3-of-9 Code): A low-density barcode that can encode uppercase letters, numbers, and
some special characters.

• Data Matrix: A two-dimensional (2D) barcode that consists of black and white square modules
arranged in either a square or rectangular pattern. This barcode uses the Solomon-Reed error
correction algorithm (ECC 200) to ensure data reliability.

• Intelligent Mail: A 4-state barcode that the United States Postal Service (USPS) defines to track
and direct mail. Intelligent Mail barcodes (IMBs) combine the capabilities of POSTNET and PLANET
barcodes in one barcode.

• Interleaved 2-of-5: A high-density barcode that can encode numbers.

• Portable Data File 417 (PDF417): A two-dimensional (2D) barcode that consists of several rows,
each of which is like a small linear barcode. The barcode can detect and correct errors.

• POSTal Numeric Encoding Technique (POSTNET): A barcode that the USPS defines to direct
mail.

• Quick Response Code (QR Code): A two-dimensional (2D) matrix barcode that consists of black
and white square modules arranged in a square pattern. The contents of this barcode can be
decoded at high speed. This barcode uses the Solomon-Reed error correction algorithm (ECC 200)
to ensure data reliability.

When you use the AFP Visual Environment user interface to create a barcode in a sample AFP file, you
define a barcode area. You specify the origin of the area, the size (height and width) of the area, and
the location of the area in each page group. The area can be a horizontal rectangle (for a “picket-
fence” barcode), a vertical rectangle (for a “ladder” barcode), or a square.

You can place barcodes on:

• A specified page (for example, page 1) of each page group

• All pages in each page group

• The even pages in each page group (pages 2, 4, 6,...)

• The odd pages in each page group (pages 1, 3, 5,...)

AFP Editor



1

22

The barcode that you define in a page group contains the same data on each page.

In addition, you can specify one of these orientations for the barcode symbol within the barcode area:
0 degrees, 90 degrees, 180 degrees, or 270 degrees. Orientations of Barcodes, p. 22 shows the
possible orientations for a barcode symbol with the human-readable interpretation (HRI) text placed
above the barcode symbol:

Orientations of Barcodes

Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code barcodes

AFP Editor can create Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code
barcode objects that follow the AFP Bar Code Content Object Architecture (BCOCA). AFP Editor uses
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the default values for all BCOCA properties and displays the default properties you can change. For
information about the default values, see Bar Code Object Content Architecture Reference, S544-3766.

Table 1. Bar code properties for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, and POSTNET bar codes

Barcode type Properties

Code 39 (3 of 9 Code) • Whether to generate and include a check
digit in the bar code symbol; a check digit
ensures data integrity during the bar coding
reading process;

• Whether to include human-readable
interpretation (HRI).

Data Matrix • Number of rows;
• Number of modules in each row.

QR Code • Desired Symbol Size

Interleaved 2-of-5 • Whether to generate and include a check
digit in the bar code symbol; a check digit
ensures data integrity during the bar coding
reading process;

• Whether to include human-readable
interpretation (HRI).

PDF417 • Number of data symbol characters in each
row; the printer creates the minimum number
of rows necessary for the amount of data in
the bar code symbol.

POSTNET • Length of the routing ZIP Code;
• Whether to include human-readable

interpretation (HRI).

Specifying Module Width

As an advanced feature, you can specify the module width of a barcode that is written as a BCOCA
object. By specifying this property, you can better control the size of the resulting barcode. The module
width specifies the width in mils of the smallest defined barcode element (bar, space, or 2D module).
For more information, see Bar Code Object Content Architecture Reference.

The default value is applied if you leave this option unchanged. The default values for each barcode
are as follows:

Barcode type Recommended module width default values
(in mils)

Code 39 (3 of 9 Code) 13

Data Matrix 21

QR Code 12

Interleaved 2-of-5 13

PDF417 14
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• Valid module width values range between 7 and 254. Values outside this range are ignored.

• AFP Visual Environment does not verify whether the resulting barcode fits the defined object area.

• As specified in the BCOCA reference, the barcode types: POSTNET and Intelligent Mail Barcode
have a fixed module width. You cannot specify a module width for them.

Specifying Barcode Data

You can specify this data to encode in the barcode symbol, in any combination, if the data is allowed in
the barcode type:

• The value of one or more index tags. (For example, if the routing ZIP Code in an AFP file is an index
tag, you can include the ZIP Code in the barcode data.) If the index tag value is different in every
page group, the barcode data for the index tag is different in every page group.

• The value of one or more job properties (such as job number). The barcode data for a job property
is the same in every page group.

• Text strings. The barcode data for a text string is the same in every page group.

• Human-readable interpretation (HRI).

• Code page encoding.

If you want to include the value of document properties in barcode data, contact the Professional
Services department of Ricoh Production Print.

You can also adjust position values for the barcode, including changing the origin and size of the
barcode area, selecting the orientation of the barcode symbol, and selecting which pages to place the
barcode on.

Intelligent Mail bar codes

AFP Editor can create Intelligent Mail bar codes (IMBs) in one of these representations:

• BCOCA objects: Bar code objects follow the Bar Code Content Object Architecture (BCOCA). AFP
Editor can create standard height IMB symbols.

• Text barcodes: AFP Editor uses the 300 dpi AFP IMB font (US23) that the USPS provides. This
barcode font creates standard height IMB symbols.

In general, BCOCA objects are preferred to text barcodes. However, some older printers, such as IBM
3900 printers, cannot process BCOCA IMBs. To print on these printers, you must create text IMBs.

IMBs have two basic formats, depending on the length of the mailer ID assigned by the USPS. Fields in
IMBs with a 9-digit mailer ID and a 6-digit serial number, p. 25 and Fields in IMBs with a 6-digit mailer
ID and a 9-digit serial number, p. 25 show the formats of IMBs:

• In Fields in IMBs with a 9-digit mailer ID and a 6-digit serial number, p. 25, the mailer ID contains 9
digits and the serial number contains 6 digits.

• In Fields in IMBs with a 6-digit mailer ID and a 9-digit serial number, p. 25, the mailer ID contains 6
digits and the serial number contains 9 digits.

The Mailer ID and the Serial number fields together contain 15 digits.
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Fields in IMBs with a 9-digit mailer ID and a 6-digit serial number

Fields in IMBs with a 6-digit mailer ID and a 9-digit serial number

AFP Editor lets you specify these fields:

Barcode ID
A 2-digit number that identifies Optional Endorsement Line (OEL) information. The USPS defines the
barcode IDs. This field is required.

Service type ID
A 3-digit number that identifies the mail class and the postal services. For example, “080” is first-
class mail with Address Service requested. The USPS defines the service types and service type IDs.
This field is required.

Mailer ID
A 6- or 9-digit number that identifies the mailer. The USPS assigns the mailer ID.

You can use the Mailer ID field for other purposes in an IMB that is used for reply mail.

Serial number
A 6- or 9-digit number that the mailer assigns to identify the mailpiece. If the mailer ID contains 6
digits, the serial number contains 9 digits. If the mailer ID contains 9 digits, the serial number
contains 6 digits. This field is required; however, if you use only USPS “Basic Services”, the serial
number can be zeroes.

Routing ZIP Code
The 5-, 9-, or 11-digit routing ZIP Code of the mail recipient, also called the “Delivery Point Code”.
This field is not required.

IMB serial numbers

The serial number in an Intelligent Mail barcode (IMB) identifies the mailpiece. If you use the USPS “Full
service” option, the serial number must not repeat in another barcode for a 45-day period.

A serial number can consist of 6 or 9 digits, depending on the length of the mailer ID. Because 6 or 9
digits might not be long enough to completely identify a mailpiece (for example: the recipient, the type
of mailing, the date of mailing), you can use a sequential number as the serial number and save the
serial number in an index tag in the mailpiece or in a separate index file. If the USPS returns electronic
Address Change Service (ACS) information, you can then use the serial number to retrieve the actual
mailpiece or information about the mailpiece.
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AFP Editor lets you specify the serial number in these ways:

• Index tag: You can specify an index tag that contains the value to encode as the serial number.
The index tag can contain a different value in each page group (mailpiece). For example, if the
customer ID is indexed, the serial number can be the customer ID. If the customer ID is shorter than
the 6 or 9 digits required for a serial number, AFP Editor automatically adds zeroes to the beginning
of the customer ID. Keep in mind that if you use the USPS “Full service” option, the serial number
must not repeat in another barcode for a 45-day period.

• Serial number file: For each barcode, you can specify a file that contains the number to use as the
serial number in the first IMB in the AFP file. AFP Editor automatically increments the number in the
file by 1 in each subsequent barcode that it creates to make the serial number unique. For example,
if the serial number file contains a starting serial number of 000000, the serial numbers in the
barcodes are 000000, 000001, 0000002, 0000003, and so on.

When AFP Editor creates IMBs in production AFP files:

1. In the first IMB in the AFP file, it encodes the serial number that is in the serial number file.

2. In each subsequent IMB created, it increments the serial number by 1. This ensures that the serial
number is unique in each barcode.

3. When the serial number reaches the maximum number of digits specified in the serial number file (6
or 9 digits), the number wraps to 000001 or 000000001.

4. When it finishes creating IMBs in the AFP file, it updates the serial number file so that the file
contains the starting serial number for the first IMB in the next AFP file that AFP Editor processes.

For example, if the serial number file contains the 6-digit serial number 000001, and AFP Editor creates
four IMBs in two AFP files (each AFP file uses the same serial number file), the barcodes contain these
serial numbers:

• First AFP file: 000001, 000002, 000003, and 000004

• Second AFP file: 000005, 000006, 000007, and 000008

AFP Editor can save the actual barcode data that it encoded in each IMB in an index tag. This is
especially useful when you use a serial number file because each index tag in the AFP file contains the
actual serial number that was encoded in the barcode.

You specify the name of the serial number file when you create an IMB in the sample AFP file. However,
you can use a different serial number file for production AFP files. You can specify the name of the serial
number file to use in the EditAFP and PluginMgr commands.

The EditAFP command starts multiple threads so that it can process multiple page groups concurrently.
Therefore, the serial numbers in the IMBs are not always in sequential order by page group. For
example, EditAFP might create the IMB in the third page group (using serial number 000002) before it
creates the IMB in the second page group (using serial number 000003). Even though the serial
numbers might not be in sequential order by page group, the serial number in each IMB is unique. If it is
important for the IMB serial numbers to be in sequential order by page group, request that EditAFP start
only one thread (-threads 1 option), or use the PluginMgr command to run EditAFP. PluginMgr is
single-threaded, so IMB serial numbers are always in sequential order by page group.
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POSTNET to IMB replacement

Intelligent Mail barcodes (IMBs) can replace both POSTNET and PLANET barcodes, as well as the
alphanumeric characters that contain the participant code and keyline information for the USPS Address
Change Service (ACS).

AFP Editor provides a replace function that can delete POSTNET barcodes and create IMBs that
contain the same routing code as in the replaced POSTNET barcodes (minus the check digit). POSTNET
barcodes and IMBs can be text barcodes or BCOCA objects.

The replace function automatically places IMBs in the same position as the POSTNET barcodes they
replace. However, you can change the position of the IMBs. For example, if the POSTNET barcode is
below the name and address, you can put the IMB above the name and address.

The replace function does not delete any PLANET barcodes or the Address Change Service (ACS)
information that typically prints above the name and address. However, you can first use AFP Editor to
hide the area that contains the PLANET barcode and any ACS information.

PLANET and POSTNET barcodes, p. 27 shows an address with ACS data, a PLANET barcode, and a
POSTNET barcode. POSTNET barcode, p. 27 shows the same address after you create a hidden area
to cover the ACS data and the PLANET barcode.

PLANETand POSTNET barcodes POSTNET barcode

POSTNET barcode, p. 27 shows the address with the POSTNET barcode. IMB replacement, p. 27
shows the address after you replace the POSTNET barcode with an IMB.

POSTNET barcode IMB replacement
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Hidden areas

A hidden area is an area in each page group that no one using an AFP viewer can see and that does
not print.

You can hide areas that contain text, barcodes, or other types of optical mark recognition (OMR) data
that you want to replace or that are no longer needed. For example, if you want to replace POSTNET
and PLANET barcodes with Intelligent Mail barcodes (IMBs), you can hide the PLANET barcodes. (AFP
Editor can automatically replace PLANET barcodes with IMBs, but you must hide the PLANET barcodes
and any ACS data.)

AFP Editor creates a hidden area by creating an AFP graphics object that contains no data and that
prints in the color of the medium or another color. Although you cannot use an AFP viewer to see the
existing data in the hidden area, the data still exists in the AFP file.

You can specify the location and size of the hidden area. You can place a hidden area on:

• A specified page (for example, page 1) of each page group

• All pages in each page group

• The even pages in each page group (pages 2, 4, 6,...)

• The odd pages in each page group (pages 1, 3, 5,...)

Text masks

A text mask replaces text in an AFP file with another character, for example the “x” character. Text
masks are useful if you do not want anyone to view or print sensitive information, such as customer
names and social security numbers.

You can block out, or mask, text that is consistently present in the same location in each page group.
You define a text mask by selecting a block of text that occurs in a consistent location on every page
group in the file; for example, a customer's social security number. You can define multiple text masks so
you can mask different information in a page group, such as a customer name, an address, and an
account number.

You can use the default character “x” for the mask value or select a different character. The selected
text is replaced in the AFP file. For example, when you use an AFP viewer, instead of displaying social
security number “213-87-2967”, the text mask “xxxxxxxxxxx” is displayed. When you print the AFP
file, instead of printing the social security number, the text mask prints.

Tip: To make sensitive data completely inaccessible, mask the text instead of hiding the area that
contains the data. When you mask text data, the original data is no longer in the AFP file. However,
when you hide an area, the original data remains in the AFP file. In both cases, an AFP viewer does not
display the data and the data does not print.
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WWhhiitteessppaaccee MMaannaaggeerr
With Whitespace Manager, you can add marketing or educational messages to documents without
recomposing them. Whitespace Manager lets you define available areas of white space in AFP files
and then fill the white space with content, such as images and text, during the print production process.

The content that is placed in a white space area is based on rules you define to target the content for
specific customers or for the best use of available space.

White space

White space is the area on a page that does not contain any text. You can define white space in AFP
files by choosing known white space on a page or by searching for the first available white space in a
page group.

When Whitespace Manager searches for white space on a page, it looks on the logical page for areas
without text blocks. Areas with overlays, page segments, barcodes, and images are considered
available white space.

When you create a white space definition, you use these options to select the pages in the page group
where you want the white space defined:

• This page

• This and following pages

• Last page

For known white space definitions, you can create one area of known white space for each page in a
page group using This page or Last page. This equates to a total of n definitions, where n is the
number of pages in a page group. For white space definitions from a search, you can create one area
of white space for each page in a page group using This page, one area of white space using This
and following pages, and one area of white space using Last page. This equates to a total of n + 2
definitions. Therefore, the maximum number of white space definitions that Whitespace Manager lets
you create is:

2n + 2

For example, if a page group has three pages, you can create 3 definitions for known white space and
3 + 2 definitions for white space definitions from a search. Therefore, the maximum number of white
space definitions allowed is:

(2 x 3) + 2 = 8

If you try to create more than the allowed number of white space definitions on a page, you see the
message "No more white space definitions are allowed for this page."

When you create a white space definition, you also choose the origin and size of the area for the white
space. If you are searching for available white space on a page, you decide on a minimum width and
height for the white space area that you want Whitespace Manager to look for (at least 0.5 inches or
12.7 millimeters). Whitespace Manager searches for the largest white space area on a page that meets
the minimum dimensions specified. When Whitespace Manager finds white space that meets the
specifications on that page, it stops the search.
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White space definition results, p. 30 shows how Whitespace Manager creates white space definitions
based on the page options that you select.

WWhhiittee ssppaaccee ddeeffiinniittiioonn rreessuullttss

White space definition
Page
option Result

Known white space This page Whitespace Manager creates a white space definition
on the current page of the page group and displays the
white space as a colored box. If a white space definition
was previously found on the page from a search, the
known white space definition takes precedence and is
displayed in the user interface. This option is only
available if a known white space area has not been
defined on the current page.

Last page Whitespace Manager creates a white space definition
on the last page of the page group and displays the
white space as a colored box. If a white space definition
was previously found on the page from a search, the
known white space definition takes precedence and is
displayed in the user interface.

You might want to create a Last page definition instead
of This page when the page groups contain a variable
number of pages and you want the white space to
always be on the last page.

This option is only available if the current page is the last
page in the page group and a known white space area
has not been defined on the page.

White space from a search This page Whitespace Manager creates a white space definition
on the current page of the page group and displays the
white space as a colored box unless:
• A known white space area is already defined on the

page.
• No white space area meets the specified dimensions.

This option is only available if white space from a search
has not already been defined using This page.

1 Overview



1

31

White space definition
Page
option Result

This and
following
pages

Whitespace Manager searches the current page and all
pages that follow in the page group, creates a definition
on the first page where it finds white space, and then
displays the white space as a colored box. It does not
display a white space box if:
• A known white space area is already defined on a

page.
• No white space area meets the specified dimensions.

Notes:

1. This option is only available if white space from a
search has not already been defined using This and
following pages.

2. You must display each page in the page group to
see if a white space box is created on a page.

Last page Whitespace Manager creates a white space definition
on the last page of the page group and then displays the
white space as a colored box unless:
• A known white space area is already defined on the

page.
• No white space area meets the specified dimensions.

You might want to create a Last page definition instead
of This page when the page groups contain a variable
number of pages and you want the white space to
always be on the last page.

This option is only available if the current page is the last
page in the page group and if white space from a
search has not already been defined using Last page.

Keep in mind that not all the white space definitions that you create are displayed in the user interface
because Whitespace Manager follows these rules for determining which white space definition is
displayed on a page:

• Only one white space definition is displayed per page.

• A known white space definition is displayed before white space that was defined from a search.

If you delete a known white space definition, white space defined from a search can be displayed on a
page.

Content

Content, such as images or text, is assigned to a white space area based on rules you define to place
the content for specific customers, marketing campaigns, or the best use of available space.
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The Manage Campaigns window lets you determine what content is placed in defined white space by
defining rules with conditions. Conditions are expressions that are used to evaluate whether index tags
in a page group are true or false. You can use AFP Indexer to create index tags. In addition to text,
these types of images can be displayed as content:

• GIF

• JPEG

• Page segment (PSEG)

Images must use an RGB colorspace; they cannot use a CMYK colorspace. You cannot include other
image types, such as TIFF or PNG.

You decide what content is placed in a defined white space (text, image, or both) and then decide
whether the content is always placed or placed according to rules that you create. The rules are a string
of conditions separated by "and" or "or" operators. If the condition is "true", you can specify that one
type of content is assigned to the white space. If the condition is "false", you can specify that another
type of content is assigned or no content is assigned.

You can also change the font and position of text and the position of images. When you define an
image, you can enter the location of the file where the image resides. Then, if you need to periodically
change the image placed in the white space, you can change the image in the file instead of changing
the content definition.
For example, you have defined white space across the top of the first page of a statement. You want the
text "Vacation Time!" always displayed in the white space, a sunny beach scene displayed to all
customers in Colorado and Kansas, and an image of a snow-capped mountain scene displayed to all
other customers. If an index tag named "Address" contains the state where the customer lives, the
conditions you create would look like this:

PPiippeelliinnee MMaannaaggeerr
Pipeline Manager mode of AFP Visual Environment lets you configure and run a set of filters, in a
specific order, to process large AFP files quickly and efficiently.

The AFP Indexer, AFP Editor, and Whitespace Manager components have filters. By using the filters for
components, you can pre-process your AFP files. For example, you can generate page groups and
indexes, add bar codes, and write the resulting AFP file, all in 1 process. The input AFP is read once,
and the output AFP is written once.

Standard filters

AFP Visual Environment contains these standard filters:

1. Count Objects

Counts the number of AFP Objects in the file. Select Object Identifier from the list. The value is returned
to the console output.

1 Overview
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Parameters:

Object Identifier
Mandatory parameter. You must select one object type from the Supported Objects, p. 36 table.

2. Count Structure fields

Counts the number of AFP structure fields in the file. Select Structure field Identifier from the list. The value
is returned to the console output.

Parameters:

Structure field Identifier
Mandatory parameter. You must select one structure field type from the Supported structure fields ,
p. 36 table.

3. Create Document Index File

Creates an AFP Document Index File. The output file is offset based. This filter should go at the end of the
filter chain list.

Parameters:

Document Index file name
Mandatory parameter. Save location of the output document index.

Form Definition file name
Optional parameter. Path to an input form definition.

4. Create External Resource Group

Creates and External Resource Group from the in-line resource group and external resource directories.
It requires a fully qualified Resource Group file name. It also allows you to specify an optional external
resource directory and form definition file name.

Parameters:

Resource group file name
Mandatory parameter. Path to the output resource group.

External resource directory
Optional parameter. Path to an external resource directory.

Form Definition file name
Optional parameter. Path to an input form definition.

Additional External resource directory
Optional parameter. Can be added using the Create another instance of this parameter button.

It extracts only form definitions, code-pages character sets, and coded fonts. Other resource types (for
example: overlay, page segments) are not included.

Pipeline Manager
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5. Create Page Sheet Map

Creates an ACIF style Page or Sheet map. It requires a Page or Sheet Map file name. It also allows you
to specify an optional form definition file name. An error message is displayed if the specified form
definition is not found.

Parameters:

Page sheet map file name
Mandatory parameter. Path to the output.

Form Definition file name
Optional parameter. Path to an input form definition.

6. Cut AFP Objects

Removes AFP Objects from the file. Select the Object Identifier from the list. It allows you to specify an
optional Object name with matching parameters.

Parameters:

Object Identifier
Mandatory parameter. You must select one object type from the Supported Objects, p. 36 table.

Object Name
Optional parameter. If we want to delete only with the specified object name.

• An asterisk (*) in front specifies “ends with”.

• An asterisk (*) in at the end specifies “starts with”.

• An asterisk (*) on both sides specifies “contains”.

Range
Optional parameter. You can use it to specify how many elements we should cut. This parameter is
in the form of “first:last” where the first value starts at zero (0). An ‘e’ stands for “end”. For example,
0:7 means the first eight objects. 0:e means from the beginning to the end of the file.

7. Cut AFP Structured Fields

Removes AFP Structure fields from the file. Select a type structure field from the list that should be
removed. You can specify how many using the Range option.

Parameters:

Structure field Identifier
Mandatory parameter. You must select one structure field type from the Supported structure fields ,
p. 36 table.

Range

1 Overview
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Optional parameter. You can use it to specify how many elements should be cut. This parameter is
in the form of “first:last” where the first value starts at zero (0). An ‘e’ stands for “end”. For example,
0:7 means the first eight objects. 0:e means from the beginning to the end of the file.

8. Ensure Even Number Pages in Page Group

Adds a blank page to groups with odd number of pages. Does not require any parameters.

9. In-Line Resource

Adds resources to the in-line resource group. You must supply the fully qualified resource file name and
the actual resource name itself.

Parameters:

Resource file name
Mandatory parameter. Name and path of the resource on the disk.

Resource name
Mandatory parameter. Name of the resource that should be written in AFP.

10. Remove Incomplete Pages

Removes incomplete pages, where a new page begins before the previous one is ended.

11. Remove Page Groups

Removes all Page Groups and Page Group TLEs, but not any other data within the Page Group. There is
also an optional Range parameter.

Parameters:

Range
Optional parameter. You can use it to specify how many elements should be cut. This parameter is
in the form of “first:last” where the first value starts at zero (0). An ‘e’ stands for “end”. For example,
0:7 means the first eight objects. 0:e means from the beginning to the end of the file.

12. Validate AFP Structured Fields

Validates the order and context of structured fields. Missing Begin Document (BDT) and End Document
(EDT) Structured Fields are allowed.

Parameters:

Exit on Error
Optional parameter. The customer can specify with a Boolean input parameter whether the
validation should stop after the first error occurs or continue until the end.

13. Write AFP Structured Fields

Dumps AFP Structured Field information. Information can be written to an external file. You can also
write the output in Hexadecimal format with the optional Show Hex selection.

Parameters:
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Output file name
Optional parameter. The name and path of the output file.

Show Hex values
Optional parameter. Use the Boolean values to show or hide the hexadecimal values of the AFP
structure fields.

Supported Objects

This table contains the list of all supported objects when using the filters.

AFP Object ActiveEnvironmentGroup

BarCode CharacterSet

CodePage CodePage

Document DocumentEnvironmentGroup

DocumentIndex FormEnvironmentGroup

FormMap Graphics

Image IOCA

MediumMap MediumOverlay

ObjectContainer ObjectEnvirmentGroup

Page PageGroup

PageSegment Resource

ResourceEnvirmentGroup ResourceGroup

Text

Supported structure fields

This table contains the list of all supported structure fields.

BAG BBC BCF BCP

BDA BDD BDG BDI

BDM BDT BFG BFM

BFN BGR BII BIM

BMG BMM BMO BNG

BOC BOG BPF BPG

BPM BPS BPT BR

BRG BSG BTS CDD

1 Overview
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CFC CFI CPC CPD

CPI CTC CTD EAG

EBC ECF ECP EDG

EDI EDM EDT EFG

EFM EFN EGR EII

EIM EMG EMM EMO

ENG EOC EOF EOG

EPF EPG EPM EPS

EPT ER ERG ESG

ETS FGD FNC FND

FNG FNI FNM FNN

FNO FNP GAD GDD

ICP IDD IEL IID

IMM IOB IOC IPD

IPG IPO IPS IRD

LLE MBC MCC MCD

MCF1 MCF2 MDD MDR

MFC MGO MIO MMC

MMO MMT MPG MPO

MPS MSU NOP OBD

OBP OCD PEC PFC

PGD PGP1 PGP2 PMC

PPO PTD PTX TLE

Pipeline Manager
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2. Installing AFP Visual Environment

You must install AFP Visual Environment on the system where you plan to run the AFP Visual Environment
user interface to enhance sample AFP files, and on the production system.

To install AFP Visual Environment:

1. Use the File Transfer Program (ftp) to get the AVE-n.n.n-YYYY_MM_DD.zip file on the system
where you want to install it.

• n.n.n is the AFP Visual Environment version and YYYY_MM_DD stands for 4-digit year, 2-digit
month and 2-digit day.

Use the ftp binary option.

2. Extract all files to a directory on the system.

Preserve the directory structure.
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33.. Working with sample AFP files

•Converting line data to MO:DCA-P in sample AFP files
•Installing AFP Visual Environment
•Displaying sample AFP files
•Creating and updating control files
•Identifying AFP resource directories
•Mapping fonts for AFP files
•Enabling object selection in sample AFP files
•Showing page information in sample AFP files
•Specifying a form definition
•Checking enhancements to sample AFP files
•Configuring and running a set of filters

You can use AFP Visual Environment to enhance a sample AFP file.

The sample AFP file should be representative of production AFP files. You can then run an AFP Visual
Environment command to make the same enhancements to production AFP files.

To enhance a sample AFP file, first you convert any line data to Mixed Object Document Content
Architecture for Presentation (MO:DCA-P) format. Then you start the user interface and open the sample
AFP file. You can choose to create a new AFP Visual Environment control file or update an existing
control file. If necessary, you must specify the AFP resource directories to AFP Visual Environment, and
create custom font-mapping files.

CCoonnvveerrttiinngg lliinnee ddaattaa ttoo MMOO::DDCCAA--PP iinn ssaammppllee AAFFPP ffiilleess
If the sample AFP file contains line data, you must convert the data stream to Mixed Object Document
Content Architecture for Presentation (MO:DCA-P) format.

If the sample AFP file is on a z/OS system, you must then send the AFP file and any AFP resources that
are not inline to the preparation system.

To convert line data to MO:DCA-P data in a sample AFP file:

1. Use the AFP Conversion and Indexing Facility (ACIF) program to convert the data stream to MO:
DCA-P format. As an option, request that ACIF create a resource group file that contains the AFP
resources that the file references.

2. If the sample AFP file is on another system, use the File Transfer Program (ftp) on the preparation
system to get the AFP file and the ACIF resource group file. Use the ftp binary option.

3. Concatenate the resource group file and the AFP file that ACIF created.

IInnssttaalllliinngg AAFFPP VViissuuaall EEnnvviirroonnmmeenntt
Install AFP Visual Environment to display and define enhancements for sample AFP files that represent
your production AFP files.

Examples of enhancements include creating page groups, indexes, barcodes, and text; assigning
values to document properties; and adding content to white-space areas.

RICOH ProcessDirector applies those enhancements to print jobs during processing.

You can install AFP Visual Environment on systems running Java 1.8 or higher and any of these
operating systems:

• Windows 10 Pro or Enterprise 64-bit
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• Windows 11 Pro

• Windows Server 2016 64-bit

• Windows Server 2019 64-bit

• Windows Server 2022 64-bit

• CentOS Linux 7.7 through latest 7.X for x86_64

• Red Hat 7.6 through latest 7.X

• Red Hat 8.1 through latest 8.X

• SUSE Linux Enterprise Server (SLES) 12.0 with Service Pack 4 or above for x86_64

• SUSE Linux Enterprise Server (SLES) 15.0 with Service Pack 1 or above for x86_64

To install AFP Visual Environment:

1. Log in to RICOH ProcessDirector.

2. Open Administration→ Utilities→ Visual Workbench

3. Click AFP Visual Environment to download the VisualWorkbench.zip file.

4. Find the ZIP file on your system and unzip it into the location where you want to install AFP Visual
Environment.
A collection of folders and files are stored in the location you specify. The installation is complete.

5. To start AFP Visual Environment:

• On a Windows system, double-click AVE.bat.

• On a Linux system, double-click AVE.jar.

• If you add features or extensions to your system, delete the VisualWorkbench.zip file and all of the
unzipped files, then download the VisualWorkbench.zip file again.

DDiissppllaayyiinngg ssaammppllee AAFFPP ffiilleess
You can open a sample AFP file in AFP Visual Environment. The sample AFP file must be representative
of production AFP files that you want to enhance in the same way as the sample file.

For example, if the AFP file contains text that you want to use in an index tag or in barcode data,
choose a sample file that contains that text in the same position on the page as the production AFP files.

You can open one AFP file in AFP Visual Environment at a time. If an AFP file is already open, AFP
Visual Environment automatically closes it and prompts you to save its control file if you have not
already done so. After you open an AFP file, you can rotate the view, display selected pages, display
different views, and increase the display size.

You can display the properties of page groups, pages, text, and AFP objects (such as page segments
and overlays) in the AFP file. Page-group properties include the index tag values. Page properties
include the type of AFP objects that are on the page, including page-level indexes. Text properties
include font information and the location (in inches or millimeters) of the text.

3 Working with sample AFP files



3

43

• If some text does not display correctly, you might need to identify the directory that contains the font
resources to AFP Visual Environment, or you might need to modify AFP Visual Environment font
mapping.

To display a sample AFP file:

1. Click File→ Open AFP file. You see the Open window.

2. Select the AFP file that you want to open and click Open.
You see the AFP file in the right pane of the user interface. You also see the Open Control File
window with the message: Do you want to use an existing control file for this AFP
file?

3. Do one of these:

• To create a control file, click No. If the AFP file contains index tags, you see the index tags in
the bottom pane; otherwise, the bottom pane is blank.

• To display the file using an existing control file, click Yes. This is recommended if you have
previously created a control file for this sample AFP file. You see the Open window:

1. Select the control file that you want to use.

2. Click Open. If the control file contains definitions for index tags, or if the AFP file contains
index tags, you see the index tags in the bottom pane; otherwise, the bottom pane is
blank.

To the left of the AFP file, you see the page structure of the file, which can contain page groups
and pages. You might also see a resource group entry at the top of the page structure if the file
contains inline AFP resources, such as overlays and page segments.

4. To rotate the AFP file clockwise by 90 degrees, click View→ Rotate by 90o. Click again to
rotate another 90 degrees.

5. To navigate in the AFP file, do one of these:

• Click anywhere in the AFP file and press the Page Up or Page Down key on your keyboard.

• Double-click to select a page from the left pane.

• Double-click to select a page group from the bottom pane.

6. To hide or display the page structure in the left pane, click View→ File View.

7. To hide or display the indexes in the bottom pane, click View→ Index View.

8. To increase or decrease the display size of the AFP file, click View→ Zoom→ nnnnnn (nnn is one
of these percentages: 200, 175, 150, 125, 100, 75, 50.)
The display size of the AFP file is increased or decreased by the percentage you select.

9. To change units of measurement, do one of these:

• For inches, click View→ Units→ Inches.

• For millimeters, click View→ Units→Millimeters.

10. To display properties:

1. Do one of these:

• In the left pane, click a resource, page group, or page. Right-click and click Properties.

Displaying sample AFP files
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• ClickMode and a feature. Then:

1) Click text or an object in the AFP file. You see a red box around the text or object you
selected.

– If you cannot select an object, it is not enabled for selection. See Enabling object
selection in sample AFP files, p. 52.

2) Right-click and then click Properties.

A green box around a property value indicates that there is more text than what is displayed.

2. To see the complete text for a value:

1) Double-click the green box.

2) Click OK.

3. To close the Properties window, click X in the upper right corner.

11. If text does not display correctly:

• If the AFP file contains data that displays incorrectly, change the default code page to
another code page (Resources→Modify Default Encoding). For example, an ASCII
code page is IBM850(GID=850) and an EBCDIC code page is IBM500(GID=500).

• If the AFP file refers to AFP fonts that are not inline, identify the directories that contain font
resources to AFP Visual Environment (Resources→ Specify Resource Directories).

• If the AFP file refers to custom AFP fonts, create custom font-mappings in AFP Visual
Environment.

12. If an error occurs when opening or working with a file, click File→ Reset, which closes the file
and clears the cached resources from memory. Open the file again.

CCrreeaattiinngg aanndd uuppddaattiinngg ccoonnttrrooll ffiilleess
When you open a sample AFP file to enhance it, AFP Visual Environment can either create a control file
or update a control file that you created previously. The control file contains definitions that tell how to
enhance production AFP files that are similar to the sample AFP file.

If a control file already exists for a sample AFP file and you need to enhance the AFP file again, update
the existing control file instead of creating a new control file. All the definitions that apply to the sample
AFP file must be in the same control file.

To create or update a AFP Visual Environment control file:

1. In AFP Visual Environment, open a sample AFP file.
You see the Open Control File window with the message “Do you want to use an existing control
file for this AFP file?”

2. Do one of these:

• To create a control file, click No.

• To update a control file, click Yes. You see the Open window:

1. Select the control file.

2. Click Open.

3 Working with sample AFP files



3

45

3. If you opened the wrong control file, click File→ Open Control File and select the correct
control file.

If you see message “Your unsaved changes will be lost if you open a new control file. Do you
want to continue? ”, it means that you have already enhanced the AFP file in this session and you
will lose those changes. Do one of these:

• To open another control file, click Yes.

• To save the open control file first so that you do not lose the definitions you created in this
session, click No. Then save the control file.

4. Enhance the sample AFP file.

For example, create page groups, index tags, bar codes, text, and white space.

5. Do one of these:

• To save a new control file or to rename an updated control file:

1. Click File→ Save control file as.

2. Type the full path name of the control file in the File name field.

3. Click Save.

Use a name for the control file that helps you associate the AFP file with its control file. The
default extension for control files is .ctl.

• To save an updated control file with the same name, click File→ Save control file.

IIddeennttiiffyyiinngg AAFFPP rreessoouurrccee ddiirreeccttoorriieess
If the sample AFP file refers to AFP resources (fonts, page segments, and overlays) that are not located
inline, identify the resource directories that contain the resources so that AFP Visual Environment can
display the sample AFP file correctly.

You can specify as many resource directories to AFP Visual Environment as necessary.

• If you plan to create text Intelligent Mail bar codes (IMBs), which refer to an IMB font, identify the
resource directory that contains the AFP IMB font to AFP Visual Environment so that AFP Visual
Environment can display the bar code symbol. The AFP IMB font (character set C0XMUS23) is
installed in the resources directory. If you plan to create BCOCA IMBs, this is not necessary.

AFP Visual Environment looks for AFP fonts, page segments, and overlays in these resource directories,
in the order shown:

1. Inline in the AFP file

2. Resource directories specified to AFP Visual Environment, in the order the directories are specified

If you have mapped an AFP font to a Java font in a customized font-mapping file, AFP Visual
Environment does not look for the AFP font inline or in the resource directories. It uses the Java font.

The resource directories that you specify are used until you specify different resource directories.
However, when you open an AFP file again using an existing control file, AFP Visual Environment uses
the resource directories that you had specified, if any, the last time you worked with that AFP file using
the same control file.

Identifying AFP resource directories
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To identify AFP resource directories:

1. In AFP Visual Environment, open a sample AFP file. Then click Resources→ Specify Resource
Directories.

2. Click Add.

3. Type a directory name in the Directory name field, or click Browse to select a directory.

4. Click OK.

5. To specify another resource directory, click Add again.

6. To change the order of a directory in the list, select the directory and click Up or Down.
The directories are searched in the order they are listed.

7. Click OK.

MMaappppiinngg ffoonnttss ffoorr AAFFPP ffiilleess
If AFP Visual Environment does not display a custom AFP font correctly in the sample AFP file, you can
map the font to a comparable Java font of the same point size and style, and you can change how
particular code points map to Unicode code points.

You can also change the default code page that AFP Visual Environment uses to another encoding.

When you are creating or editing index tags and you cannot read the text, you can change the code
page mapping so the index value is readable. When you want to change the way the text is displayed
in AFP Visual Environment, you can change the character set mapping.

AFP font mappings can be located in multiple places. AFP Visual Environment looks for font mappings in
this order:

1. Job font mappings in the AFP Visual Environment control file

2. Installation font mappings in font-mapping files

3. System font mappings

You cannot change system font mappings, but you can create job font mappings for an AFP file that are
saved in the control file, and you can edit installation font mappings in one or more of these font-
mapping files that are shipped with AFP Visual Environment:

• CharacterSets.properties:Maps an AFP character set to corresponding font attributes or a AFP
font global identifier (FGID) to a corresponding Java font name and style.

• CodedFonts.properties:Maps an AFP coded font to an AFP character set and AFP code page.

• CodePages.properties:Maps an AFP code page or a Java charset encoding to an AFP code
page global identifier (CPGID).

• SampleCodePointMap.cp:Maps a code point to a Unicode code point. Use this file to create a
code point map file for each AFP code page that does not use standard Unicode code-point
mapping. The name of the file must contain the name of the AFP code page.

You can change the default Java font that AFP Visual Environment uses by defining the font in the control
file or in the font-mapping files. The default Java font, unless you change it, is an 11-point font with an
EBCDIC code page.

3 Working with sample AFP files



3

47

Using font-mapping files to map fonts

To map a custom AFP font to a Java font, edit one or more of the sample font-mapping files that AFP
Visual Environment provides.

The mappings in the font-mapping files are used to display all AFP files in AFP Visual Environment unless
an AFP font is mapped to a Java font in the AFP Visual Environment control file.

The font-mapping files must exist on both the preparation system and the production system.

To use font-mapping files to map an AFP font to a Java font:

1. Navigate to the directory where you installed AFP Visual Environment.

2. Open the sample font-mapping files in a file editor, edit them, and save them.

All font-mapping files that you want to use must be in the same directory.

3. If you edited sample file SampleCodePointMap.cp, rename it to the name of the AFP code
page.

For example, if the name of the code page is T1000259, name the file T1000259.cp.

Creating font mappings from text blocks

When AFP Visual Environment cannot display text in an AFP file correctly, you can use text blocks in the
file to create font mappings.

The font mapping can be for a character set, code page, or coded font. You can map an AFP character
set to a Java font, an AFP code page to a Java character set, or an AFP coded font to an AFP character
set and AFP code page.

Code page mappings make text readable, while character set mappings change how text is displayed
in AFP Visual Environment.

To create a font mapping from a text block:

1. In AFP Visual Environment, open a sample AFP file.

2. ClickMode and a feature.

3. Click a text block.
You see a red box around the text you selected.

The text blocks you can select are defined in the AFP file, from one character to the entire line of
text. For example, the text “Account Summary” might be defined as two text blocks. You can click
either the “Account” or “Summary” text block.

4. Right-click anywhere on the page and click Create Font Mapping.
You see the Create Font Mapping window.

5. Click one of these for the font mapping type:

Mapping fonts for AFP files
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• Character Set (default)

• Coded Font (only available if the text block references a coded font)

• Code Page

The fields and buttons on the window change depending on which font mapping type you select.
Font mapping fields and buttons, p. 48 describes the fields and buttons that are displayed for font
mapping.

FFoonntt mmaappppiinngg ffiieellddss aanndd bbuuttttoonnss

Field or button Font Mapping Type Description

Add Character Set The action for adding a new
global identifier to the drop-
down list for the character set.

Character Set Name Character Set
Code Page
Coded Font

Identifies one of these:
• The name of a defined set

of characters for AFP. The
name usually begins with
"C". The second character
in standard AFP character
set names indicates the
character rotation. A
question mark (?) is used
as a wildcard character
for the second character
of the character set name
and means that the
identifier applies to all
rotations.

DEFAULT is used for the
identifier of the AFP
character set when AFP
Visual Environment cannot
locate the resource for a
coded font.

• The name of a defined
Java character set
encoding.

Coded Font Name Coded Font The name of the AFP coded
font that associates an AFP
code page and an AFP
character set. For double-byte
fonts, a coded font associates
multiple pairs of code pages
and font character sets.

Code Page Name Code Page
Coded Font

The name of the AFP code
page that assigns code points

3 Working with sample AFP files
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Field or button Font Mapping Type Description

to graphic characters. The
name usually begins with
“T1”.

DEFAULT is used for the
identifier of the AFP code
page when AFP Visual
Environment cannot locate the
resource for a coded font.

DBCS Code Page The code page is a double-
byte character set in which
each character is represented
by two bytes. You cannot
change this field.

Text Example Character Set
Code Page

The text block you selected in
the AFP file.

Family Name Character Set The name of the Java font
family.

Global Identifier Character Set
Code Page

A 1- to 5-digit decimal global
character set graphic
identifier (GCSGID) or code
page global identifier
(CPGID). The values are
00001 to 65534.

Point Size Character Set The height of the characters in
a font. One tenth of the value
is the point size. For example,
a value of 90 represents a 9-
point font. Valid values are
whole numbers from 1 to
990.

SBCS Code Page The code page is a single-
byte character set in which
each character is represented
by a 1-byte code point. You
cannot change this field.

Show CharSets Character Set The action for viewing which
character sets currently use
the global identifier displayed
in the Global Identifier field.

Mapping fonts for AFP files



3

50

Field or button Font Mapping Type Description

Show Common Character Set
Code Page

The action for viewing which
character sets or code pages
currently use the global
identifier displayed in the
Global Identifier field.

Style Character Set The style of the Java font.
Valid values are: BOLD,
BOLD|ITALIC, ITALIC, and
PLAIN.

6. Do one of these, depending on which font mapping type you selected:

• For Character Set, do one of these:

– Select a different global identifier from the drop-down list. You can click Show Common
to view which character sets currently use the selected global identifier and then click X in
the upper right corner to close the window.

– Click Add to create a new global identifier:

1. Type a 1- to 5- digit identifer in the Global Identifier field.

2. Click Show CharSets to view which character sets currently use the selected global
identifier. Click X in the upper right corner to close the window.

3. Type a point size.

4. Select a family name and style for the Java font from the drop-down lists.

5. Click OK.

The family name and style for the Java font are updated. The example of the text block you
selected in the AFP file is also updated.

• For Coded Font:

1. Type an AFP character set name. The name usually begins with "C".

2. Type an AFP code page name. The name usually begins with "T1".

• For Code Page:

1. Select a different global identifier from the drop-down list.

2. Click Show Common to view which code pages currently use the selected global
identifier. Click X in the upper right corner to close the window.

The Java character set name is updated. The example of the text block you selected in the
AFP file is also updated.

7. Click OK.
The font mapping is created in the control file. To keep the font mappings, be sure to save the
control file before exiting the AFP file.
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Modifying font mappings from text blocks

After you create character set, coded font, or code page mappings from text blocks in an AFP file, you
can modify or delete the font mappings.

To modify or delete a font mapping:

1. In AFP Visual Environment, open a sample AFP file.

2. Click Resources→Modify Font Mapping.

3. Select the name of a font mapping.

4. Do one of these:

• ClickModify or double-click. You see the Modify Font Mapping window. Do one of these,
depending on which font mapping type you selected:

– For Character Set, do one of these:

♦ Select a different global identifier from the drop-down list. You can click Show
Common to view which character sets currently use the selected global identifier and
then click X in the upper right corner to close the window.

♦ Click Add to create a new global identifier:

1. Type a 1- to 5- digit identifer in the Global Identifier field.

2. Click Show CharSets to view which character sets currently use the selected
global identifier. Click X in the upper right corner to close the window.

3. Modify the point size.

4. Select a family name and style for the Java font from the drop-down lists.

5. Click OK.

The family name and style for the Java font are updated.

– For Coded Font, edit the AFP character set name, AFP code page name, or both.

– For Code Page:

1. Select a different global identifier from the drop-down list.

2. Click Show Common to view which code pages currently use the selected global
identifier. Click X in the upper right corner to close the window.

The Java character set name is updated.

Click OK. The font mapping is modified.

• Click Delete or press the Delete key on your keyboard. The font mapping is removed.

5. To close the Modify Font Mappings window, click X in the upper right corner.
The font mapping is updated in the control file. To keep the font mapping changes, save the
control file before exiting the AFP file.
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Changing the default code page encoding

If the sample AFP file refers to AFP fonts that are based on a code page that is different from the default
code page and you have not mapped the fonts to Java fonts, the default code page can cause the text
to be unreadable.

If text is unreadable, you can change the default code page to another encoding without modifying the
font-mapping files.

The default code page that you specify is in effect until you tell AFP Visual Environment to use a different
default code page. However, when you use an existing control file, AFP Visual Environment uses the
default code page that was in effect the last time you used the same control file.

To change the default code page to another encoding:

1. In AFP Visual Environment, open a sample AFP file.

2. Click Resources→Modify Default Encoding.

3. Select a code page encoding from the drop-down list.

If you have specified a default code page in the CodePages.properties file, the code page
specified in that file overrides the code page encoding you select.

4. Click OK.

EEnnaabblliinngg oobbjjeecctt sseelleeccttiioonn iinn ssaammppllee AAFFPP ffiilleess
You can change which AFP objects (text, overlays, page segments, barcodes, images) are selectable in
the sample AFP file that is currently open.

When you click an object that is selectable in the sample AFP file, you see a red box around it. Then
you can see the properties of the object and, depending on the mode you selected, act on it.

By default, each mode lets you select only the types of objects that you can act on. For example, the
AFP Indexer mode lets you select text objects, but not overlays, page segments, barcodes, or images.
The default for each mode is suitable for most purposes. However, you might want to temporarily make
other types of AFP objects selectable so that you can see the properties of other AFP objects in the AFP
file. In that case, you should use the enabling object selection function.

1. If you change the mode or open a new sample AFP file after you change the types of object you
can select, your changes are lost and the default selections for the current mode are used.

2. You cannot select AFP objects that are defined in a form definition, even if the objects are listed as a
resource in the file-structure pane or you have enabled their selection.

To choose which objects are selectable in this AFP file:

1. In AFP Visual Environment, open a sample AFP file.

2. ClickMode and a feature.

3. Click Resources→ Enable Object Selection.
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4. Indicate which objects you want to select in this AFP file:

• Click individual objects you want to select:

– Text to select text blocks and to select barcodes that were created using fonts.

– Barcodes (BCOCA) and images (IOCA) to select barcodes that were created using
Bar Code Object Content Architecture (BCOCA) and to select images created using
Image Object Content Architecture (IOCA).

– Page segments to select page segments.

– Overlays to select overlays.

• Click All objects to select all objects.

• Click No objects to clear all objects.

5. Click OK.

6. In the AFP file, you can now select an object that you made selectable and see its properties:

1. Click an object.

If you select an area that contains overlapping selectable AFP objects (for example, an area
might contain both a BCOCA barcode and text), you see the Select an Object window so
you can indicate which object you want to select.

2. Right-click anywhere in the AFP file to see the properties of the object.

7. Optional: To revert to the default object-selection settings for the current mode, clickMode and
then click the current mode.

SShhoowwiinngg ppaaggee iinnffoorrmmaattiioonn iinn ssaammppllee AAFFPP ffiilleess
You can show the names of AFP resources (fonts, page segments, and overlays) that the current page in
the AFP file refers to and sheet information for the currently displayed AFP page. For each resource, you
can see whether AFP Visual Environment found the resource and where the resource was found.

The sheet information includes page placement and the medium map used on the page. (The medium
map specifies formatting options, such as duplex options and overlays.)

If a resource, such as a font, is missing, identify the resource directory that contains the resource to AFP
Visual Environment so that AFP Visual Environment can display the data correctly.

To see sheet information, you must specify form definition processing (Resources→ Change Form
Definition Settings).

To show page information:

1. In AFP Visual Environment, open a sample AFP file. Then click Resources→ Show Page
Information.

2. Click the Resources tab.
You see a table with these columns:

• Reference Name: Name of the resource in the AFP file.

• Type: Type of resource.

• Resource name: Name of the resource that was found. If the resource was not found, the
resource name is Unknown.

Showing page information in sample AFP files
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• Location: Location of the resource: inline in the AFP document or in a resource directory. If
the resource was not found, the resource name is Not found.

This table does not show form definitions, color management resources, and data object
resources.

3. Optional: To limit the number of resources shown in the table, do one of these:

• To see only resources that were found, click Found.

• To show only resources that were not found, clickMissing.

4. Click the Sheet tab.
If form definition processing is specified, you see:

• Active Medium Map: Name of the medium map used for the currently displayed AFP page.

• Constant Back: Whether the constant back is “Yes” or “No”.

• Constant Front: Whether the constant front is “Yes” or “No”.

• N_Up: Number of equal partitions on the side of a sheet.

• Page name: Identifier for the currently displayed AFP page.

• Page number: Number of the currently displayed AFP page.

• Partition: Number of equal-sized areas on the currently displayed AFP page.

• Plex: Whether printing is done on only one side of the sheet (Simplex) or both sides (Normal
Duplex or Tumble Duplex).

• Sheet copies: Number of copies of this sheet to be printed.

• Sheet count: Number of this sheet in the total number of sheets to be printed.

• Sheet side: Front or Back.

Otherwise, you see the message "Form definition and medium map processing is disabled."

5. Click OK.

SSppeecciiffyyiinngg aa ffoorrmm ddeeffiinniittiioonn
You can specify whether AFP Visual Environment displays the AFP file with a form definition. You can
use an inline form definition or a default form definition from a specified directory.

When a form definition is selected, the defined overlays are used to display information in the AFP file
and the medium map information is displayed on the Page Information window.

To specify whether a form definition is displayed:

1. In AFP Visual Environment, open a sample AFP file. Then click Resources→ Change Form
Definition Settings.

2. Do one of these:

• Click Use Inline Form Definition to override the default form definition.

• In the Default field, type the full path name of the directory that contains the form definition
you want to use.
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• Click Browse, select the form definition you want to use from a list in the window, and then
click OK.

If you specify a form definition other than the default, it is not saved in the control file. Therefore,
each time you open the AFP file, you must specify the form definition if you want to see the
medium map information.

3. Click OK.
If you specified a form definition, you can now view the form definition's medium map information
in the Page Information window on the Sheet tab. Otherwise, the medium map information is
not displayed.

CChheecckkiinngg eennhhaanncceemmeennttss ttoo ssaammppllee AAFFPP ffiilleess
You can save an output AFP file that contains the enhancements you made to the sample AFP file. This is
useful if you want to check that the enhancements were made properly before making the same
enhancements to production AFP files.

You can view the enhanced sample AFP file with an AFP viewer or print it on the production printer.

AFP Visual Environment saves the entire sample AFP file even if you did not open the entire file in the
user interface. The save process might take a while if the sample AFP file is large.

To check enhancements made to the sample AFP file:

1. In AFP Visual Environment, open a sample AFP file and enhance it.

2. Click File→ Save Output File.

3. Type the full path name of the file you want to create in the File name field.

4. Optional: Click View user log if you want to view the log that can contain error messages.

5. Click Save.
When the output file has been saved, you see a message that says the save has been completed.

6. To check page groups and index tags, open the AFP file in an AFP viewer. To check the hidden
areas and the bar codes, print the output AFP file on the production printer.

CCoonnffiigguurriinngg aanndd rruunnnniinngg aa sseett ooff ffiilltteerrss
You can configure and run a set of filters, in a specific order, to process large AFP files quickly and
efficiently.

To configure and run a set of filters:

1. In AFP Visual Environment, open a sample AFP file.

2. If the file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→ Pipeline Manager.

4. Click Tools→Manage Pipeline.

The Current Pipeline Definition list shows the filters currently in the pipeline.

The Available Pipeline Elements list shows all the filters. You can add some filters to the
Current Pipeline Definition list multiple times.

5. To add a filter to the pipeline definition:
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1. Select the filter on the Available Pipeline Elements list.
AFP Visual Environment displays a brief description of the filter.

2. Click Add.

3. If the filter has parameters, enter values for them.

If 2 or more parameters have a Group Parameter label, you must configure them as a
group.

4. Click OK.

5. OOppttiioonnaall:: Edit the name of the filter.

6. Click OK.
The filter appears at the bottom of the list.

7. To move the filter to another position on the list, click Up.

The order of the filters is important. Running filters such as Indexer and Remove Page Groups
in a different order can give different results.

AFP Visual Environment runs the filters in order, from top to bottom.

6. To save your changes, click Apply.
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44.. Indexing AFP files

•Creating page groups
•Defining supplemental pages
•Creating index tags
•Working with page-level indexes
•Modifying or deleting AFP Indexer definitions
•Using existing page groups and index tags
•Editing text for triggers and index tags
•Managing comments

AFP Indexer can create page groups, define supplemental pages, and create indexes in AFP files so
that the information can be used to navigate to indexed pages in the file, exclude non-customer
information from mailpieces.

CCrreeaattiinngg ppaaggee ggrroouuppss
You can create page groups in AFP files. Page groups organize AFP files into smaller, uniquely
identifiable units. When you create page groups, any existing page groups defined in the AFP file itself
are not used.

You can create page groups that are a fixed number of pages long, or you can create page groups of
variable length by defining triggers. You can also define which pages are used for header and trailer
pages. AFP Indexer creates the first page group after the defined number of header pages. It creates
the final page group before the defined number of trailer pages.

The sample AFP file must contain page groups before you can define header and trailer pages, create
index tags for a page group, or make any other enhancements. If page groups are defined in the AFP
file itself, you can use these page groups or you can create new page groups.

Creating page groups of fixed length

You can create page groups that are of fixed length. This is useful if all page groups in the AFP file
always consist of the same number of pages.

When you create fixed-length page groups, AFP Indexer can skip a certain number of pages at the
beginning of the AFP file before creating the first page group.

Notes:

1. Some AFP files are formatted so that two pages print side-by-side on the same physical sheet and
are later cut into two separate stacks. You cannot use AFP Indexer to define page groups in files
such as these because a single sheet can belong to only one page group.

2. You cannot define supplemental pages for pages in a page group that is created as a fixed-length
page group.

To create page groups of fixed length:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Click Tools→ Other Page Groups→ Create Fixed-Length Page Groups.
You might see a message that says the page groups and indexes might change or be invalid and
asks if you want to continue. Click Yes. You see the Create Fixed-Length Page Groups window.
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3. Select the number of pages in each page group in the Pages in each page group field.

4. Click Header/Trailer Definition to specify which pages are header and trailer pages and then
click OK.

5. Click OK.
In the left pane and in the bottom pane, you see the page groups that have been defined based
on the number of pages you specified. You also see the pages that are included in each page
group.

If you defined header and trailer pages and decided to keep the pages in the output, you see
header pages preceding the page groups in the left pane and trailer pages following the page
groups. If you decided not to keep the header and trailer pages in the output, you do not see
those pages in the left pane.

6. Verify that the correct page groups have been created:

1. Check that the number of pages is correct in each page group.

2. Select page groups in the left pane to see the first page in a few of the page groups and
verify that the correct boundaries were created.

3. If the page groups are incorrect, either repeat the steps to recreate the fixed-length page
groups, or use triggers to create page groups of variable length.

When you create page groups using triggers, the page groups of fixed length are removed.

Creating page groups with triggers

You can create page groups by defining one or more triggers. A trigger is a block of text that occurs in
a consistent location on the first or last page of all page groups.

You define the start of each page group with a trigger. As an option, you can also define the last page
of a page group with a trigger.

Look through the sample AFP file to determine what text you want to use as the trigger to define page
groups. The text must be in the same location on each page that you want to identify as a boundary for
the page groups. The text can also have the same value on each page. For example, you might select
the customer's name, which appears in the same location on the first page of all customer statements.
The name can be used as a trigger to define the boundary of the page group if the next pages of the
customer statements do not contain any text in the selected text block location. Keep in mind that the
boundary is defined only when the text block cannot be found in the selected location, or the exact text
block string cannot be found in the selected location.

You can create one or more triggers. AFP Indexer creates a page group if it finds all the triggers.

1. Some AFP files might be formatted so that two pages print side-by-side on the same physical sheet
and are later cut into two separate stacks. You cannot use AFP Indexer to define page groups in
files such as these because a single sheet can belong to only one page group. You cannot define
two triggers that cause the left and right sides of the sheet to belong to different page groups.

2. In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.
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To create page groups with triggers:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Click the text that you want to use to mark the page group boundaries in the file.
You see a red box around the text you selected.

The text blocks you can select are defined in the AFP file, from one character to the entire line of
text. For example, the text “Account Summary” might be defined as two text blocks. You can click
either the “Account” or “Summary” text block to create a trigger.

3. Right-click the text and click Create Trigger.
You might see a message that says the page groups might change or the index tags might be
invalid and asks if you want to continue. Click Yes.
You see the Create Trigger window with the selected text in the Edited trigger field.

• You might need to use the scroll arrows to see the text in the Edited trigger field.

4. Decide whether you want to use the entire text value as the page-group trigger or only part of the
text. You can edit the text value to reduce the number of characters you use for the trigger value.
To select part of the text as the trigger:

1. Click Edit trigger.

2. Edit the trigger value in the Edit Value window.

For example, if the page number is one text block, Page 1 of 4, you can create a trigger with
the part of the page number that occurs on the first page of each page group, such as Page 1.
You would not use of 4 because not all page groups are 4 pages long–the first page of some
page groups might contain text Page 1 of 2 or Page 1 of 3.

3. Click OK.

5. Select a trigger type:

Start page group
The text block marks the start of the page group boundaries in the file. This trigger type is
required.

End page group
The text block marks the end of the page group boundaries in the file. This trigger type is
optional.

You might see these trigger types; however, they are not used to create page groups:

Page
The text block marks an individual page in a page group. See Creating page-level triggers,
p. 74.

Supplemental page
The text block marks an individual page as a supplemental page. See Creating triggers for
supplemental pages, p. 63.

6. Click the Advanced tab to change the text threshold, the method for matching the trigger, or
both:
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• Select a range from 1/100 to 1 inch or from 1 to 25 millimeters for the text threshold.
Although text might appear to be present in the same location, slight position variations can
occur in the AFP file. You can change the threshold to look for trigger text that is in slightly
different positions on some pages. The threshold defines how far the text can be from the
original location and be considered a trigger. For example, a threshold value of 12 indicates
that the trigger can be located within .12 of an inch or 12 millimeters, either vertically or
horizontally. Usually the default threshold value is sufficient (10 for inches or 2 for
millimeters).

• Select the method used to match the trigger–on the trigger string value and the text block
position, or on the position only:

On string and X,Y position
The trigger string value and horizontal and vertical position of the text block are matched.
This is the default.

On string and X position
The trigger string value and horizontal position of the text block are matched.

On string and Y position
The trigger string value and vertical position of the text block are matched.

On X,Y position only
The horizontal and vertical position of the text block is matched.

1. OOppttiioonnaall:: Select Trigger on string value changing to activate the trigger when the value
changes from the value in the field where the trigger was first defined.

2. OOppttiioonnaall:: After you select Trigger on string value changing, select Trigger on any
change in string to activate the trigger when the value changes from any previous value in
the field.

7. Click OK.
In the left pane and in the bottom pane, you see the page groups that have been defined based
on the trigger value. You also see the pages that are included in each page group.

8. Verify that the correct page groups have been created:

1. Check that the number of pages is correct in each page group.

2. Select page groups in the left pane to see the first page in a few of the page groups and
verify that the correct boundaries were created.

3. If the page groups are incorrect, click Tools→Modify Definitions to modify or delete the
trigger.
The trigger is listed as a Page Group Definition under Start Page Group Triggers or End
Page Group Triggers.

9. OOppttiioonnaall:: To create an additional trigger, repeat the steps.

Make sure you select the text for the trigger from the same page group as the initial trigger.
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Creating page groups when white space is found

You can create page groups when white space is found in an area. White space does not contain
IOCA (Image Object Content Architecture) image data. As an alternative, you can create page groups
when IOCA image data is found in an area.

A white space trigger is white space that occurs in a consistent location on the first page of all page
groups. You define the start of each page group with the trigger.

If you create page groups using triggers, all existing page groups that are defined in the AFP file itself
are ignored.

To create page groups when white space is found:

1. In AFP Visual Environment, open a sample AFP file that contains the white space that you want to
use to trigger page groups. Then clickMode→ AFP Indexer.

2. To create the area, position your cursor at a corner of the area that contains the white space that
you want to use to trigger page groups. While pressing the left mouse button, draw a box that
includes the white space.

3. Right-click anywhere on the page and click Create White Space Trigger..

You see the Trigger on White Space window.

4. Type a descriptive name for the white space trigger in theWS Trigger definition name field.

5. Choose when to start a page group:

• The pels found option starts a new page group when the bounded area contains IOCA
image data.

• The pels not found option starts a new page group when the bounded area does not
contain IOCA image data.

Text is not IOCA image data.

6. OOppttiioonnaall:: Change the origin (top-left corner) and size of the bounded area in these fields.
Decimal values (such as 2.5) are allowed. Specify the origin and size in inches or millimeters.

X position
The horizontal distance of the left side of the area measured from the left side of the logical
page (not the physical sheet of paper).

Y position
The vertical distance of the top of the area measured from the top of the logical page (not the
physical sheet of paper).

Width
The horizontal width of the area.

Height
The vertical height of the area.
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If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

7. Click OK.

In the left pane and in the bottom pane, you see the page groups that have been defined based
on the trigger. You also see the pages that are included in each page group.

8. Verify that the correct page groups have been created:

1. Check that the number of pages is correct in each page group.

2. Select page groups in the left pane to see the first page in a few of the page groups and
verify that the correct boundaries were created.

3. If the page groups are incorrect, click Tools→Modify Definitions to modify or delete the
trigger.
The trigger is listed as a Page Group Definition under Start Page Group Triggers .

Defining header and trailer pages

After you create fixed-length page groups or page groups with triggers, you can define header and
trailer pages and decide if the pages are kept in the final output for viewing and printing.

When you define header pages, AFP Indexer skips the defined number of header pages at the
beginning of the AFP file before creating the first page group.

The header and trailer pages are supplemental pages, so you can index any text in those pages.

To define header and trailer pages:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. If the AFP file does not contain page groups, create page groups.

3. Click Tools→ Header and Trailer Pages.
You see the Header and Trailer Pages window.

4. If the page groups are created with triggers, do one of these:

• Click All pages before the first page group to define all pages before the first page group
as header pages.

• Click Fixed length header to define a certain number of pages as header pages.

5. If displayed, select the number of header pages in Pages in header.

6. If displayed, select the number of trailer pages in Pages in trailer.

7. Clear the boxes if you do not want to keep the header or trailer pages in the output. The pages
will not be viewable or printable.

8. Click OK.
If you defined header and trailer pages and decided to keep the pages in the output, you see
header pages preceding the page groups in the left pane and trailer pages following the page
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groups; if you want, you can create index tags on those pages. If you decided not to keep the
header and trailer pages in the output, you do not see those pages in the left pane.

DDeeffiinniinngg ssuupppplleemmeennttaall ppaaggeess
You can define pages in an AFP file as supplemental pages when you do not want to include them in
page groups. For example, header and trailer pages, separator pages, and any page that should be
excluded from a customer statement can be defined as supplemental pages.

You can define supplemental pages with one or more triggers or index tags to uniquely identify a page
that is outside a page group. When you define a supplemental page, you give it a page definition
name. This lets you define multiple supplemental pages.

The term “page definition” in AFP Indexer refers to a supplemental page definition, a page-level
trigger, or a page-level index, not the AFP page definition resource.

Creating triggers for supplemental pages

You can define supplemental pages by creating one or more triggers. A trigger is a block of text that
occurs in a consistent location and uniquely identifies a page.

If you create a supplemental page trigger on a page that is in a page group, the supplemental page is
removed from the page groups in the control file, unless the page group is an existing page group or
created as a fixed-length page group.

Look through the sample AFP file to determine what pages should be supplemental pages and not
included in a page group. You select one or more triggers to define a supplemental page with a page
definition name. For example, a banner page that is defined with a supplemental page trigger can have
a page definition name of “Banner”. AFP Indexer creates a supplemental page if it finds all the triggers.

Notes:

1. Some AFP files might be formatted so that two pages print side-by-side on the same physical sheet
and are later cut into two separate stacks. You cannot use AFP Indexer to define supplemental
pages in files such as these because a single sheet cannot belong to a page group and a
supplemental page. You cannot create two triggers that cause the left side of the sheet to belong to
a page group and the right side to belong to a supplemental page.

2. In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create triggers that define supplemental pages:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Click the text that you want to use to mark the supplemental page in the file.
You see a red box around the text you selected.

The text blocks you can select are defined in the AFP file, from one character to the entire line of
text. For example, the text “Banner Page” might be defined as two text blocks. You can click
either the “Banner” or “Page” text block to create a trigger.

3. Right-click the text and click Create Trigger.
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You might see a message that says the page groups might change or the index tags might be
invalid and asks if you want to continue. Click Yes.
You see the Create Trigger window with the selected text in the Edited trigger field.

You might need to use the scroll arrows to see the text in the Edited trigger field.

4. Decide whether you want to use the entire text value as the supplemental page trigger or only
part of the text. You can edit the text value to reduce the number of characters you use for the
trigger value. To select part of the text as the trigger:

1. Click Edit trigger.

2. Edit the trigger value in the Edit Value window.

3. Click OK.

5. Click Supplemental page for the trigger type.
You see the Select supplemental page definition field.

6. Type a name to identify the supplemental page or select a name from the drop-down list.

7. Click the Advanced tab to change the text threshold, the method for matching the trigger, or
both:

• Select a range from 1/100 to 1 inch for the text threshold. Although text might appear to be
present in the same location, slight position variations can occur in the AFP file. You can
change the threshold to look for trigger text that is in slightly different positions on some
pages. The threshold defines how far the text can be from the original location and be
considered a trigger. For example, a threshold value of 12 indicates that the trigger can be
located within .12 of an inch either vertically or horizontally. Usually the default threshold
value of 10 is sufficient.

• Select the method used to match the trigger–on the trigger string value and the text block
position, or on the position only:

On string and X,Y position
The trigger string value and horizontal and vertical position of the text block are matched.
This is the default.

On string and X position
The trigger string value and horizontal position of the text block are matched.

On string and Y position
The trigger string value and vertical position of the text block are matched.

On X,Y position only
The horizontal and vertical position of the text block is matched.

8. Click OK.
If you created a supplemental page trigger on a page that was in a page group (unless the page
group is an existing page group or created as a fixed-length page group), the supplemental
page is removed from the page group.

9. To modify or delete the supplemental page trigger, click Tools→Modify Definitions.
The trigger is listed as a Supplemental Page Definition under Page Triggers.
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10. Optional: To create an additional trigger for the supplemental page or to define a different
supplemental page, repeat the steps.

Creating index tags on supplemental pages

You can create one or more index tags on pages that are not included in page groups.

To create an index tag on a supplemental page:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Select a page that is outside a page group.

3. Click a text block or draw a box around a text area or address area that you want to index. The
text blocks you can select are defined in the AFP file, from one character to the entire line of text.
You see a red box around the data you selected.

4. Right-click anywhere on the page and then click Create Index Tag or Create Index Tags for
an Address.
You see the Create Supplemental Page Index Tag window, Create Index Tags in an Area
window, or Create Index Tags in an Address Area window.

5. Follow the procedure in Creating index tags for text blocks, p. 65, Creating index tags in areas,
p. 67, or Creating index tags in address areas, p. 69 and select an existing supplemental page
definition from the drop-down list or type a new supplemental page definition name.

6. Click OK when you are done creating the index tag.

7. Verify that the correct index tag has been created:

1. Right-click on the page in the left pane and click Properties.
The name of the index tag and its value are listed in the TLE field.

2. To close the Properties window, click X in the upper right corner.

3. If the index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
The index tag is listed as a Supplemental Page Definition under Page Indexes, Index
areas, or Address Indexes.

8. Optional: To create an additional index tag on the supplemental page or to define an index tag
on a different supplemental page, repeat the steps.

CCrreeaattiinngg iinnddeexx ttaaggss
You can create index tags in AFP files. When a file contains index tags, you can use an AFP viewer to
navigate in the file to find specific data. You can also use the index tag values in barcode data.

Creating index tags for text blocks

You can create an index tag for text in an AFP text block. You can edit the text in the block to remove
unwanted characters, such as blanks or special characters.

Notes:
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1. If the AFP file does not contain page groups, create page groups. Otherwise, to create an index tag
on a page outside a page group, see Creating index tags on supplemental pages, p. 65.

2. In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create an index tag for a text block:

1. In AFP Visual Environment, open a sample AFP file that contains the text you want to index. Then
clickMode→ AFP Indexer.

2. Click the text that you want to use to mark specific data in each page group. The text blocks you
can select are defined in the AFP file, from one character to the entire line of text. You see a red
box around the text you selected.

3. Right-click anywhere on the page and click Create Index Tag. You see the Create Index Tag
window with the text to index in the Edited index value field.

4. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

5. Type a descriptive name for the index tag in the Index tag name field. For example, if you
select “Joe Smith” for the index tag, the name could be “Customer name”.

6. Decide whether you want to use the entire text value to create the index tag or specify part of the
text. You can edit the text block to reduce the number of characters you use for the index value
(you cannot increase the characters in a text block). To select part of the text as the index tag:

1. Click Edit index value.

2. Edit the index value in the Edit Value window.

For example, if the account number is one text block, 01-345678, you can create an index
value with part of the account number, such as 345678.

3. Click OK.

7. Make sure Page group is selected as the index type.
You also see the index type Page within page group, which is used to create an index tag on
an individual page in a page group. See Creating page-level indexes, p. 75.

8. Click the Advanced tab to change the threshold to look for a text value that is in slightly different
positions on some pages. You can select a range from 1/100 to 1 inch or from 1 to 25
millimeters.

Although text might appear to be present in the same location on each statement, slight position
variations can occur in the AFP file. The threshold defines how far the text can be from the original
location and be considered an index tag. For example, a threshold value of 12 indicates that the
index tag can be located within .12 of an inch or 12 millimeters, either vertically or horizontally.
Usually the default threshold value of 10 is sufficient (10 for inches or 2 for millimeters).

Keep in mind that if you increase the threshold above the default value, you might create an
index tag you did not expect because the match is only done on location, so the first text block
found in the threshold range is used as the index tag.

9. Click OK. You see the index tags listed in the bottom pane for each page group.

10. Verify that the correct index tag has been created:

1. Double-click the index tag in the bottom pane and verify that the correct page in the page
group is displayed.
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2. If the index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
The index tag is listed as a Page Group Definition under Page Group Indexes.

Creating index tags in areas

You can create index tags for text in an area.

The area must occur in a consistent location in each page group; however, it can consist of a variable
number of lines. In the index area, you can create an index tag with text from more than one AFP text
block on a line. You can concatenate the text in the text blocks, or separate the text with a blank or any
other character. You can also edit the text to remove unwanted characters.

For example, a customer account number might occur on the first page of each page group in three
separate AFP text blocks on the same line. To create an index tag that contains the entire account
number, first you identify the account number area by drawing a box around all three text blocks. Then
you create one index tag with text from all three text blocks, and you specify the character to use to
separate the text in each text block. If the text blocks contain account number “123”, “45”, and “678”,
the index tag can contain: “12345678”, “123 45 678”, or “123-45-678”.

Notes:

1. If the AFP file does not contain page groups, create page groups. Otherwise, to create an index tag
for an area on a page outside a page group, see Creating index tags on supplemental pages, p.
65.

2. In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create index tags in an area:

1. In AFP Visual Environment, open a sample AFP file that contains the text you want to index. Then
clickMode→ AFP Indexer.

2. To create the index area, position your cursor at a corner of the area that contains text you want
to index. While pressing the left mouse button, draw a box that includes the text you want to
index.

The index area must include the first character in each AFP text block that you want to index;
however, the area does not need to include all the characters in the AFP text blocks.

3. Right-click anywhere on the page and click Create Index Tags.
You see the Create Index Tags in an Area window.

4. Check that the text you want to index is shown in the Lines in the area field. If the text is not
shown, click Cancel and redraw the area on the page, or click the Position tab to adjust the
origin and size of the index area.

If the text displays correctly in the AFP file but incorrectly in the Lines in the area field, try
changing the default code page (Resources→Modify Default Encoding). If the text still does
not display correctly, this usually indicates that the code page does not use standard Unicode
mapping. In this case, use the SampleCodePointMap.cp font-mapping file to create a code
point map file before proceeding.
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5. Optional: On the Position tab, change the origin (top-left corner) and size of the index area in
these fields. Decimal values (such as 2.5) are allowed. Specify the origin and size in inches or
millimeters.

X position
The horizontal distance of the left side of the area measured from the left side of the logical
page (not the physical sheet of paper).

Y position
The vertical distance of the top of the area measured from the top of the logical page (not the
physical sheet of paper).

Width
The horizontal width of the area.

Height
The vertical height of the area.

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

6. On the Index Tags tab, type a descriptive name for the area in the Index area name field.
For example, if the area contains an account number, the name could be “Account number
area”.

7. Specify the character or characters that you want to use to separate text blocks in the Character
between text blocks field.
The default character that separates text blocks is one blank. If you want to concatenate the text
in multiple text blocks, delete the blank from the field.
In the Lines in the area field you see the text with the character that you specified (if any) shown
between the text blocks.

8. To create an index tag for the text shown in a line in the area:

1. Click Add.

2. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

3. Type a descriptive name for the index tag.

For example, if the index tag contains an account number, the name could be “Account
number”.

4. Select the line that contains the text you want to index:

• To select the first line or a line relative to the first line, click First line. Then use the drop-
down list for this field to select a relative line. For example, select First line plus 1.

• To select the last line or a line relative to the last line, click Last line. Then use the drop-
down list for this field to select a relative line. For example, select Last line minus 1.

You see the value of the index tag in the Edited value field.
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5. Decide whether you want to use the entire text value to create the index tag or only part of
the text. To select part of the text as the index tag, click Edit index value. Edit the index
value in the Edit Value window and click OK.

6. Clear the Create tag for an empty value field if you do not want AFP Indexer to create
index tags with null values.

Otherwise, an index tag contains the value “null” if the text that you indexed does not exist in
a particular page group. For example, if a page group has an address that does not contain
a country name, the index tag for country name is “null” for that page group.

7. Click OK.
You see the index tag and the index tag value in the Index tags for specific lines field.

9. Optional: To create another index tag with text on the same line or on a different line, click Add
again.

You can create as many index tags as you want in the area.

10. Click OK.
You see the index tags listed in the bottom pane for each page group.

11. Verify that the correct index tags have been created:

1. Double-click the index tags in the bottom pane and verify that the correct pages in the page
groups are displayed.

2. If an index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
The index tag is listed under Page Group Definition→ Page Group Indexes→ Index
areas.

Creating index tags in address areas

You can create index tags for mailing addresses in an address area.

The area must occur in a consistent location in each page group; however, it can consist of a variable
number of lines. In the area, you can create an index tag for a ZIP Code that is in the U.S. Postal
Service format.

For example, a customer address might consist of either 3 or 4 lines, with the ZIP Code always on the
last line. First you identify the location and size of the address area by drawing a box around an
address that contains the maximum lines in the address: in this example, 4 lines. If the sample AFP file
does not have an address with the maximum number of lines, draw a box large enough to include all
possible lines in the address area. If you know the exact position and size of the address area, you can
adjust the size of the box you drew by specifying the exact X offset, Y offset, height, and width of the
address area. (X and Y offsets are from the origin of the logical page, not the physical sheet of paper.)
Notes:

1. If the AFP file does not contain page groups, create page groups. Otherwise, to create an index tag
for an address area on a page outside a page group, see Creating index tags on supplemental
pages, p. 65.

2. In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.
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Next you can create index tags for text on specific lines: the customer name on the first line, the city on
the last line, and the state on the last line. Then you can create multiple index tags for the intermediate
lines that contain the street address. Intermediate lines are the lines between the specific lines that you
indexed. The address area can contain a variable number of intermediate lines, as shown:

JOHN SMITH <-- first line
123 MAIN STREET <-- intermediate line 1
SUITE 100 <-- intermediate line 2 (optional line)
DENVER, CO 12345-6789 <-- last line

If the ZIP Code is in the U.S. Postal Service format (nnnnn or nnnnn-nnnn), AFP Indexer can automatically
extract the ZIP Code on a line and create an index tag for it.

In an address area, you can create one or more index tags. For example, you can create an index tag
for the ZIP Code without creating index tags for any other text in the address area.

To create index tags in an address area:

1. In AFP Visual Environment, open a sample AFP file that contains the addresses that you want to
index in the format that you want to index. Then clickMode→ AFP Indexer.

2. Navigate to an address that contains the maximum number of lines.

If you cannot find an address with the maximum number of lines, in the next steps either draw a
larger area or specify the exact size of the address area on the Position tab to include the
maximum number of lines.

3. To create the address area, position your cursor at a corner of the area that contains the entire
address. While pressing the left mouse button, draw a box that includes all the lines in the
address.

The address area must include the first character in the AFP text blocks that you want to index;
however, it does not need to include all the text because text blocks can contain text of variable
length in different page groups. For example, a text block that contains a customer name might
contain a short name in one page group and a long name in another page group.

4. Right-click anywhere on the page and click Create Index Tags for an Address.
You see the Create Index Tags in an Address Area window.

5. Check that the text you want to index is shown in the Index tags for intermediate lines field. If
the text is not shown, click Cancel and redraw the area on the page, or click the Position tab to
adjust the origin and size of the address area.

If the text displays correctly in the AFP file but incorrectly in the Index tags for intermediate
lines field, try changing the default code page (Resources→Modify Default Encoding). If the
text still does not display correctly, this usually indicates that the code page does not use
standard Unicode mapping. In this case, use the SampleCodePointMap.cp font-mapping file to
create a code point map file before proceeding.

6. Optional: On the Position tab, change the origin (top-left corner) and size of the address area in
these fields. Decimal values (such as 2.5) are allowed. Specify the values in inches or millimeters.

X position
The horizontal distance of the left side of the area measured from the left side of the logical
page (not the physical sheet of paper).
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Y position
The vertical distance of the top of the area measured from the top of the logical page (not the
physical sheet of paper).

Width
The horizontal width of the area.

Height
The vertical height of the area.

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

7. On the Index Tags tab, type a descriptive name for the area in the Index area name field.
For example, if the area contains the customer's address, the name could be “Customer address
area”.

8. Specify the character or characters that you want to use to separate text blocks in the Character
between text blocks field.
The default character that separates text blocks is one blank. If you want to concatenate the text
in multiple text blocks, delete the blank from the field.
In the Index tags for intermediate lines field you see the text with the character that you
specified, if any, shown between the text blocks.

9. Optional: To create an index tag for a specific line in the area:

1. Click Add.

2. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

3. Type a descriptive name for the index tag.

For example, if the line contains the customer name, the name could be “Customer”.

4. Select the line that contains the text you want to index:

• To select the first line or a line relative to the first line, click First line. Then use the drop-
down list for this field to select a relative line. For example, select First line plus 1.

• To select the last line or a line relative to the last line, click Last line. Then use the drop-
down list for this field to select a relative line. For example, select Last line minus 1.

5. Decide whether you want to use the entire text value to create the index tag or only part of
the text. To select part of the text as the index tag, click Edit index value. Edit the index
value in the Edit Value window and click OK.
You see the value of the index tag in the Edited value field.

6. Clear the Create tag for an empty value field if you do not want AFP Indexer to create
index tags with null values.

Otherwise, an index tag contains the value “null” if the text that you indexed does not exist in
a particular page group. For example, if a page group has an address that does not contain
a country name, the index tag for country name is “null” for that page group.

7. Click OK.
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You see the index tag and the index tag value in the Index tags for specific lines field.

10. Optional: To create another index tag with text on the same line or on a different line, click Add
again.

You can create as many index tags for specific lines as you want in the area.

11. Optional: To create index tags for the lines that are shown in the Index tags for intermediate
lines field:

1. Click Index intermediate lines.

2. Specify the name for the index tags in the Index tag name field. For example, the name
could be “Street”.

3. Use the drop-down box next to the Index tag name field to select the number to append to
the index tag for the first intermediate line.

4. Use the default code page encoding or select an encoding from the drop-down list.

AFP Indexer creates index tags for each intermediate line in the area; for example: “Street1” and
“Street2”. AFP Indexer does not create index tags for intermediate lines that do not exist in a
page group. For example, if the address in a particular page group does not contain the second
intermediate line in the street address, AFP Indexer only creates index tag “Street1”.

12. Optional: To create an index tag for a ZIP Code in the U.S. Postal Service format (nnnnn or
nnnnn-nnnn):

1. Click the ZIP Code tab.
You see the ZIP Code in the ZIP Code field.

2. Type a descriptive name for the index tag.

For example, the name could be “ZIP Code”.

3. Use the default code page encoding or select an encoding from the drop-down list.

4. Clear the Create tag for an empty value field if you do not want AFP Indexer to create an
index tag with a “null” value. Otherwise, if the ZIP Code does not exist in a particular page
group, the index tag for that page group contains the value “null”.

13. Click OK.
You see the index tags listed in the bottom pane for each page group.

14. Verify that the correct index tags have been created:

1. Double-click the index tags in the bottom pane and verify that the correct pages in the page
groups are displayed.

2. If an index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
The index tag is listed under Page Group Definition→ Page Group Indexes→ Address
Indexes.

Creating index tags from NOP records

You can create index tags from No Operation (NOP) records.

NOP records can be found anywhere in a page group–either on a page in the page group or outside
the logical AFP pages. You can create index tags for NOP records that are in the same position in all
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page groups, but outside a page, or you can create index tags for specific NOP records that are in any
location in the page groups–on a page or outside a page.

A NOP record causes an application to move to the next instruction for processing without taking any
other action. Some applications put information about individual documents in NOP records so that the
information is not printed, but it can be worked with. Though NOP records in the AFP file are not
viewable or printable, you can create index tags from them as long as they are associated with a page
group or a page in a page group.

To create index tags from page group NOPs:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. If the AFP file does not contain page groups, create page groups.

3. Click Tools→ Index Tools→ Create Indexes from NOPs.

You see the Select NOP by String window. This option lets you use selection criteria to search
for NOP records in any location in the page groups and create index tags from the specified
NOP record. Do these:

1. Optional: If the text in the NOP record does not look correct, click ASCII to change the NOP
encoding; EBCDIC is the default.

2. From the drop-down list, view the NOPs available for selection.

3. Type a string in the Search String field to identify the NOP you want to use to create an
index tag. The field is case-sensitive. For example, if you want to index a NOP record that
contains an account number, specify a string of characters that uniquely identify the NOP
record.

4. Select a number in the Select first character position field until the NOP record you want is
displayed in theMatching NOP field.

5. Click OK. You see the Create Index Tag window with the NOP text to index in the Edited
value field.

4. Create the index tag:

1. Type a descriptive name for the index tag in the Index tag name field.

2. Optional: To edit the text value and select part of the text as the index tag, click Edit index
value. Edit the index value in the Edit Value window and click OK.

5. Click OK.
In the bottom pane, you see the index tag listed if the NOP record is on a page in the page
group.

6. Optional: To create additional index tags, repeat the steps.

7. If an index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
The NOP index tag is listed under Page Group Definition→ Page Group Indexes→ NOP
Index tags.

WWoorrkkiinngg wwiitthh ppaaggee--lleevveell iinnddeexxeess
Page-level index tags are defined on individual pages in a page group rather than within the page
group.
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To create page-level indexes, you first create triggers that define individual pages in a page group.
Then you create indexes on the defined pages. AFP Indexer also lets you copy or move page-level
index tags to a page group.

The term “page definition” in AFP Indexer refers to a page-level trigger, a page-level index, or a
supplemental page definition, not the AFP page definition resource.

Creating page-level triggers

In an AFP file with existing page groups or after you create page groups in a file, you can create
triggers to define individual pages in page groups.

You can create one or more triggers on an individual page, with the same or different page definition
names. AFP Indexer defines a page if it finds all the triggers with the same page definition name.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create page-level triggers:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Select a page in a page group.

3. Click the text that you want to use as a trigger.
You see a red box around the text you selected.

The text blocks you can select are defined in the AFP file, from one character to the entire line of
text. For example, the text “Account Summary” might be defined as two text blocks. You can click
either the “Account” or “Summary” text block to create a trigger.

4. Right-click the text and click Create Trigger.
You might see a message that says the page groups might change or the index tags might be
invalid and asks if you want to continue. Click Yes.
You see the Create Trigger window with the selected text in the Edited trigger field.

You might need to use the scroll arrows to see the text in the Edited trigger field.

5. Decide whether you want to use the entire text value as the page-level trigger or only part of the
text. You can edit the text value to reduce the number of characters you use for the trigger value.
To select part of the text as the trigger:

1. Click Edit trigger.

2. Edit the trigger value in the Edit Value window.

3. Click OK.

6. Click Page for the trigger type.
You see the Select page definition field.
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7. Type a name to identify the page or select a name from the drop-down list.

8. Click the Advanced tab to change the text threshold, the method for matching the trigger, or
both:

• Select a range from 1/100 to 1 inch for the text threshold. Although text might appear to be
present in the same location, slight position variations can occur in the AFP file. You can
change the threshold to look for trigger text that is in slightly different positions on some
pages. The threshold defines how far the text can be from the original location and be
considered a trigger. For example, a threshold value of 12 indicates that the trigger can be
located within .12 of an inch either vertically or horizontally. Usually the default threshold
value of 10 is sufficient.

• Select the method used to match the trigger–on the trigger string value and the text block
position, or on the position only:

On string and X,Y position
The trigger string value and horizontal and vertical position of the text block are matched.
This is the default.

On string and X position
The trigger string value and horizontal position of the text block are matched.

On string and Y position
The trigger string value and vertical position of the text block are matched.

On X,Y position only
The horizontal and vertical position of the text block is matched.

9. Click OK.

10. Click Tools→Modify Definitions to modify or delete the trigger.
The trigger is listed under Page Group Definition→ Page Definition→ Page Triggers.

11. Optional: To create an additional trigger, repeat the steps.

Creating page-level indexes

After you create triggers to define individual pages in page groups, you can create index tags on the
individual pages.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create an index tag for a text block:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. If the AFP file does not contain page definitions in page groups, create one or more page-level
triggers.

3. Select a page in a page group.
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4. Click the text that you want to index. The text blocks you can select are defined in the AFP file,
from one character to the entire line of text. You see a red box around the text you selected.

5. Right-click the text and click Create Index Tag. You see the Create Index Tag window with the
text to index in the Edited index value field.

6. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

7. Type a descriptive name for the index tag in the Index tag name field. For example, if you
select “Joe Smith” for the index tag, the name could be “Customer name”.

8. Click Page within page group for the index type.
You see the Select index value type and Select page definition fields.

9. Select the index value type:

AFP file
The index value is displayed in the Edited index value field. Decide whether you want to
use the entire text value as the page-level index or only part of the text. You can edit the text
block to reduce the number of characters you use for the index value (you cannot increase
the characters in a text block). To select part of the text as the index tag:

1. Click Edit index value.

2. Edit the index value in the Edit Value window. For example, if the account number is one
text block, “01-345678”, you can create an index value with part of the account
number, such as “345678”.

3. Click OK.

User defined
The User defined value field is displayed. Type the text you want for the index tag.

10. Select an existing page definition from the drop-down list.

11. Click the Advanced tab to change the threshold to look for a text value that is in slightly different
positions on some pages. You can select a range from 1/100 to 1 inch or from 1 to 25
millimeters. Although text might appear to be present in the same location on each page, slight
position variations can occur in the AFP file. The threshold defines how far the text can be from
the original location and be considered an index tag. For example, a threshold value of 12
indicates that the index tag can be located within .12 of an inch or 12 millimeters, either vertically
or horizontally. Usually the default threshold value is sufficient (10 for inches or 2 for millimeters).

Keep in mind that if you increase the threshold above the default value, you might create an
index tag you did not expect because the match is only done on location, so the first text block
found in the threshold range is used as the index tag.

12. Click OK.

13. Verify that the correct index tag has been created:

1. Right-click on the page in the left pane and click Properties.
The name of the index tag and its value are listed in the TLE field.

2. To close the Properties window, click X in the upper right corner.

3. If the index tag is incorrect, click Tools→Modify Definitions to modify or delete the tag.
Page-level indexes are listed under Page Group Definition→ Page Definition→ Page
Indexes.
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Copying or moving page-level indexes to page groups

You can copy or move all page-level index tags to a page group. Page-level index tags are found on a
page in the AFP file, but at the page level instead of the page-group level.

You can see what index tags are on a page by displaying the properties for the page. The name of an
index tag and its value are listed in the TLE field.

To copy or move page-level index tags so they are added to the page group:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Select a page that is within a page group.

3. Click Tools→ Index Tools→ Relocate Page Indexes to Page Groups.
You see the Copy Page Indexes to Page Group window. The Current Page field displays the
page you selected in the page group.

4. From the drop-down list, select which page-level index tags you want to add to the page group:

This page
Adds all the page-level index tags from the current page to the page group. For example, if
"5" is the current page, adds all the index tags from page 5 to the page group for each page
group in the file that contains a page 5.

This and following pages
Adds all the page-level index tags from the current page, and all pages that follow the
current page, to the page group. For example, if "3" is the current page and "5" is the last
page in the page group, all the index tags on page 3, page 4, and page 5 are added to the
page group for each page group in the file that contains those pages.

Last page
Adds all the page-level index tags from the last page to the page group.

5. To move the page-level index tags to the page group, clear the Keep indexes in page field.
Otherwise, the page-level index tags are copied to the page group.

6. Click OK.
In the bottom pane, you see the index tags that have been added to the page groups.

7. Optional: To remove the index tags that you added to a page group:

1. Click Tools→ Index Tools→ Relocate Page Indexes to Page Groups.
You see the Copy Page Indexes to Page Group window with the selections you previously
made.

2. Click Delete.
The index tags are removed from the page group.

MMooddiiffyyiinngg oorr ddeelleettiinngg AAFFPP IInnddeexxeerr ddeeffiinniittiioonnss
After you create triggers and index tags for page groups, pages in page groups, and supplemental
pages, you can modify or delete any of them.
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Modifying triggers

You can modify page group, supplemental page, and page-level trigger definitions. When you modify
a trigger, the boundaries of the page groups might change.

• Be careful modifying triggers if you have made other enhancements to the sample AFP file. For
example, if you have created index tags and you modify the page group triggers, the index tags
might become invalid. In addition, other types of definitions in the control file (for example,
barcodes created with AFP Editor) might not work properly if they are based on the page groups or
index tags created with AFP Indexer.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify a trigger definition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the triggers. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window.

3. Select the name of the trigger that you want to modify.

4. ClickModify, or double-click.
You see the Modify Trigger window.

5. To edit the trigger value, click Edit trigger. Edit the trigger value in the Edit Value window and
click OK.

6. Click the Advanced tab to change the text threshold, the method for matching the trigger, or
both:

• Select a range from 1/100 to 1 inch or from 1 to 25 millimeters for the text threshold.

• Select the method used to match the trigger–on the trigger string value and the text block
position, or on the position only.

7. Click OK.
In the left pane and in the bottom pane, you see the page groups that have been defined based
on the trigger value. You also see the pages that are included in each page group.

8. To close the Modify and Delete Definitions window, click X in the upper right corner.

Deleting triggers

You can delete page group, supplemental page, and page-level trigger definitions. When you delete a
trigger, the boundaries of the page groups might change.
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Be careful deleting triggers if you have made other enhancements to the sample AFP file. For example,
if you have created index tags and you delete the page group triggers, the index tags might become
invalid. In addition, other types of definitions in the control file (for example, barcodes created with AFP
Editor) might not work properly if they are based on the page groups or index tags created with AFP
Indexer. If you delete the last trigger defined in the control file, any page groups that are defined in the
AFP file itself are displayed in the left pane.

To delete a trigger definition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the triggers. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with trigger and index tag definitions.

You can only delete trigger definitions that exist in the control file. If page groups are displayed in
the left pane but no trigger definitions are listed in the Modify and Delete Definitions window, the
page groups are defined in the AFP file itself. To remove page groups that are defined in the AFP
file, create a new page-group trigger or create fixed-length page groups. This automatically
removes any page groups defined in the AFP file. To remove nested page groups that are
defined in the AFP file, click Tools→ Other Page Groups→ Use Existing Page Groups.

3. Select the trigger that you want to delete.

4. Click Delete, or press the Delete key on your keyboard.
You see a message that asks if you want to continue.

5. Click Yes.
The trigger is removed from the definitions list.

6. To close the Modify and Delete Definitions window, click X in the upper right corner.

Modifying index tags for text blocks

You can modify the index tags for AFP text blocks that were created with AFP Indexer, including page
group indexes, page-level indexes, NOP indexes, and supplemental page indexes.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify an index tag for a text block:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the index tags. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with index tags.
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You can only modify index tags that exist in the control file. If index tags are displayed in the
bottom pane but not in the Modify and Delete Definitions window, the index tags exist in the AFP
file itself and you cannot modify them.

3. Select the index tag that you want to modify.

4. ClickModify, or double-click.
You see the Modify Index Tag window, Modify Page Index Tag window, or Modify
Supplemental Page Index Tag window, depending on which type of index tag you are
modifying.

5. To change the name of the index tag, type a new name in the Index tag name field.

6. To change the code page encoding, select an encoding from the drop-down list.

This field is not displayed for NOP index tags.

7. To edit the index value, click Edit index value. Edit the index value in the Edit Value window and
click OK.

8. Click the Advanced tab, if present, to change the text threshold to look for a text value that is in
slightly different positions on some pages.

You can select a range from 1/100 to 1 inch or from 1 to 25 millimeters.

Keep in mind that if you increase the threshold above the default value, you might create an
index tag you did not expect because the match is only done on location, so the first text block
found in the threshold range is used as the index tag.

9. Click OK. You see the index tags listed in the bottom pane for each page group.

10. To close the Modify and Delete Definitions window, click X in the upper right corner.

Modifying index tags in areas

You can modify the index tags that you created for page group or supplemental page areas.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify index tags in an area:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the index tags. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with index areas.

3. Select the index area that you want to modify.

4. ClickModify, or double-click.
You see the Modify Index Tags in an Area window.

5. To change the characters that separate the text blocks, specify the new character or characters in
the Character between text blocks field.
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The default character that separates text blocks is one blank. If you want to concatenate the text
in multiple text blocks, delete the blank from the field.
In the Lines in the area field you see the text with the character that you specified (if any) shown
between the text blocks.

6. To add an index tag for a specific line in the area:

1. Click Add.
You see the Create Index Tag window.

2. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

3. Type a descriptive name for the index tag.

4. Select the line that contains the text you want to index:

• To select the first line or a line relative to the first line, click First line. Then use the drop-
down list for this field to select a relative line. For example, select First line plus 1.

• To select the last line or a line relative to the last line, click Last line. Then use the drop-
down list for this field to select a relative line. For example, select Last line minus 1.

You see the value of the index tag in the Edited value field.

5. Decide whether you want to use the entire text value to create the index tag or only part of
the text. To select part of the text as the index tag, click Edit index value. Edit the index
value in the Edit Value window and click OK.

6. Clear the Create tag for an empty value field if you do not want AFP Indexer to create
index tags with null values.

Otherwise, an index tag contains the value “null” if the text that you indexed does not exist in
a particular page group or supplemental page. For example, if a page group has an address
that does not contain a country name, the index tag for country name is “null” for that page
group.

7. Click OK.
You see the index tag and the index tag value in the Index tags for specific lines field.

7. To change or delete an existing index tag for a specific line in the area, click the index tag in the
Index tags for specific lines section (use the CTRL key to select more than one index tag) and
do one of these:

• ClickModify. Make changes to the index tag in the Modify Index Tag window and then
click OK.

• Click Delete to remove all index tags you selected.

8. To adjust the origin and size of the address area, click the Position tab.
Decimal values (such as 2.5) are allowed.

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

9. Click OK. You see the index tags listed in the bottom pane for each page group.

10. To close the Modify and Delete Definitions window, click X in the upper right corner.
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Modifying index tags in address areas

You can modify the index tags that you created for page group or supplemental page address areas.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify index tags in an address area:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the index tags. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with address indexes.

3. Select the address index that you want to modify.

4. ClickModify, or double-click.
You see the Modify Index Tags in an Address Area window.

5. To change the characters that separate the text blocks, specify the new character or characters in
the Character between text blocks field.
The default character that separates text blocks is one blank. If you want to concatenate the text
in multiple text blocks, delete the blank from the field.
In the Index tags for intermediate lines field you see the text with the character that you
specified (if any) shown between the text blocks.

6. To add an index tag for a specific line in the address area:

1. Click Add.
You see the Create Index Tag window.

2. Use the default code page encoding or select an encoding from the drop-down list if the text
displays incorrectly.

3. Type a descriptive name for the index tag.

4. Select the line that contains the text you want to index:

• To select the first line or a line relative to the first line, click First line. Then use the drop-
down list for this field to select a relative line. For example, select First line plus 1.

• To select the last line or a line relative to the last line, click Last line. Then use the drop-
down list for this field to select a relative line. For example, select Last line minus 1.

5. Decide whether you want to use the entire text value to create the index tag or only part of
the text. To select part of the text as the index tag, click Edit index value. Edit the index
value in the Edit Value window and click OK.
You see the value of the index tag in the Edited value field.

6. Clear the Create tag for an empty value field if you do not want AFP Indexer to create
index tags with null values.

Otherwise, an index tag contains the value “null” if the text that you indexed does not exist in
a particular page group or supplemental page. For example, if a page group has an address
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that does not contain a country name, the index tag for country name is “null” for that page
group.

7. Click OK.
You see the index tag and the index tag value in the Index tags for specific lines field.

7. To change or delete an existing index tag for a specific line in the address area, click the index
tag in the Index tags for specific lines section (use the CTRL key to select more than one index
tag) and do one of these:

• ClickModify. Make changes to the index tag on the Modify Index Tag window and then
click OK.

• Click Delete to remove all index tags you selected.

8. Do one of these to specify whether lines in the Index tags for intermediate lines field are
indexed:

• Click Index intermediate lines and specify an index tag name to create index tags for
intermediate lines.

• Clear Index intermediate lines to delete the index tags for intermediate lines.

9. To specify whether an index tag is created for a ZIP Code in the U.S. Postal Service format (nnnnn
or nnnnn-nnnn), click the ZIP Code tab and do one of these:

• Type an index tag name or update the existing name to create an index for the ZIP Code.
Clear the Create tag for an empty value field if you do not want AFP Indexer to create an
index tag with a “null” value.

• Delete the name of the index tag in the Name field to delete the ZIP Code index.

10. Click the Position tab to adjust the origin and size of the address area. Decimal values (such as
2.5) are allowed. Specify the values in inches or millimeters.

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

11. Click OK. You see the index tags listed in the bottom pane for each page group.

12. To close the Modify and Delete Definitions window, click X in the upper right corner.

Deleting index tags

You can delete all index tags that were created with AFP Indexer, including page group, supplemental
page, page-level, and NOP index definitions. You can also delete index tags that were created for
specific lines in index areas and address areas, and intermediate lines and ZIP Codes in address areas.

Be careful deleting index tags if you have made other enhancements to the sample AFP file that depend
on the index tags. For example, do not delete an index tag if you used AFP Editor to create a barcode
that contains the index tag value.

To delete an index tag:
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1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the index tags. Then clickMode→ AFP Indexer.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with index tags.

You can only delete an index tag that is defined in the control file. If index tags are displayed in
the bottom pane but not in the Modify and Delete Definitions window, the index tags are defined
in the AFP file itself. To delete all the index tags that are defined in the AFP file, click
Tools→ Other Page Groups→ Use Existing Page Groups.

3. To delete an index tag that was created for a line in an index area or address area, or a ZIP
Code in an address area:

1. Select the index name for an index area or address area, and then clickModify.
You see the Modify Index Tags in an Area window or Modify Index Tags in an Address Area
window. Do one or more of these:

• To delete the index tags for specific lines, select the index tag in the Index tags for
specific lines section (use the CTRL key to select more than one index tag) and click
Delete. The index tag is removed from the list.

• To delete the index tags for intermediate lines in an address area, clear the Index
intermediate lines field.

• To delete the index tag for a ZIP Code in an address area, click the ZIP Code tab and
remove the name of the index tag in the Name field.

2. Click OK.
The index tags are removed from the list in the bottom pane.

4. To delete an index tag definition, including all index tags created for an index area or address
area:

1. Select the index definition you want to delete.

2. Click Delete or press the Delete key on your keyboard.
The index tag definition is removed from the definitions list and, if it was a page group index,
from the bottom pane.

5. To close the Modify and Delete Definitions window, click X in the upper right corner.

UUssiinngg eexxiissttiinngg ppaaggee ggrroouuppss aanndd iinnddeexx ttaaggss
If page groups and index tags are defined in the AFP file instead of a AFP Visual Environment control
file, you can choose whether to use the existing page groups in the AFP file and, if the page groups are
nested, which level of page groups to use.

You can also choose whether to use the existing index tags. If you do not tell AFP Indexer whether to
use existing page groups and index tags, all existing page groups and index tags are used unless you
create new page groups.

In most cases, if an AFP file contains page groups, you should use them. If you use the existing page
groups, you cannot change the page group boundaries. However, you can create additional index
tags and modify existing tag values.
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Be cautious about changing which level of existing page groups to use if you have made enhancements
to the sample AFP file. For example, if you have created page groups or index tags, the page groups
might change or the index tags might be invalid. In addition, other types of definitions in the control file
(for example, barcodes created with AFP Editor) might not work properly if they are based on the page
groups or index tags created with AFP Indexer.

To use existing page groups and index tags:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Click Tools→ Other Page Groups→ Use Existing Page Groups.
You might see a message that says the page groups and indexes might change or be invalid and
asks if you want to continue. Click Yes. You see the Use Existing Page Groups window.

3. In the Use page group level field, select a number, 0 to 20, for the levels in the page group
structure that you want to keep.

To keep all page groups, select 0. Select a number greater than 0 only if you have nested page
groups.

For example, the first figure shows a page group structure with two levels. To keep the page
groups in all of the levels, select 0. However, to keep only the page groups in the second level
(and any levels below it), select 1. The second figure shows the new page structure after you
select 1.

4. To remove the index tags that are defined in the AFP file, clear the Use index tags box.

5. Click OK.
You see the page groups and index tags that you chose to use in the AFP file.
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EEddiittiinngg tteexxtt ffoorr ttrriiggggeerrss aanndd iinnddeexx ttaaggss
When you create or modify a trigger or an index tag, you can edit the text value. You can also edit the
text value for existing index tags that are defined in the AFP file or the AFP Visual Environment control
file.

You might want to edit the text value to remove any leading or trailing blanks, or to remove unwanted
special characters. When you edit a text value, make sure that you edit it so that it is appropriate for all
page groups because the text values can be different in each page group.

To edit the text for a trigger or index tag:

1. In AFP Visual Environment, open a sample AFP file. Then clickMode→ AFP Indexer.

2. Do one of these to open the Edit Value window:

• Click Tools→ Index Tools→ Edit Existing Indexes. Select an index tag from the drop-
down list and click Edit.

• When creating or modifying a trigger or index tag, click one of these: Edit index value, Edit
trigger, or Edit value.

3. Select On for one or more of these options:
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Edit by stripping
characters

Type one character or a blank that you want to remove from the value.
Remember that the character is case-sensitive. Then, select one of these
buttons:

Strip leading characters
The specified character is removed from the beginning of the value. For
example, if you type a blank character, all blanks are removed from the
beginning of the value.

Strip trailing characters
The specified character is removed from the end of the value. For
example, if you type a blank character, all blanks are removed from the
end of the value.

Strip leading and trailing characters
The specified character is removed from the beginning and end of the
value. For example, if you type a blank character, all blanks are
removed from the beginning and end of the value.

Strip all characters
The specified character is removed from all positions in the value. For
example, an account number is: 324-1443255-11. You can type a -
to strip all - characters from the value.

Edit on delimiter Type a text string of one or more characters or blanks in the Specify
delimiter string field to indicate where the text value is split into separate
strings. Remember that the text is case-sensitive. Then select numbers for
Select first string and Select number of strings to mark the beginning
and end of the edited text.

For example, an account number is: 324-1443255-11. You can use - as
the delimiter to split the value into these three strings: 324, 1443255, and
11. To select the second and third strings, 1443255-11, select 2 for both
Select first string and Select number of strings.

Edit on character Select numbers for Select first character position and Select number of
characters to indicate the first character in the text value and how many
characters are included.

When you select the options in the window, the text value for the current page group, page in a
page group, or supplemental page is edited based on your selections and the new value is
displayed in the Edited text field.

The edit options are done in this order:

1. Edit by stripping characters

2. Edit on delimiter

3. Edit on character

4. Click OK.
You see one of these:
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• If you are creating or modifying a trigger or index tag, the new value is displayed in one of
these fields: Edited index value, Edited trigger, or Edited value.

• If you are editing an existing index tag, you see an asterisk (*) next to the index tag that you
edited. You also see that Delete is now displayed in the window.
Do this:

1. Optional: To undo the edit you did to the index tag, click Delete. The index tag reverts to
the original text and the asterisk (*) is removed from the drop-down list. Delete is not
displayed in the window if the drop-down list does not have any asterisks.

2. Click OK.

MMaannaaggiinngg ccoommmmeennttss
You can manage comments in the AFP Indexer portion of the AFP Visual Environment control file.

To manage comments:

1. In AFP Visual Environment, open a sample AFP file.

2. ClickMode→ AFP Indexer.

3. Click Tools→Manage Comments.

You see a list of comments, if any, in the AFP Indexer portion of the AFP Visual Environment
control file.

4. To add a comment:

1. Click Add Comment.

2. Type the text of the comment.

3. Click OK.

5. To delete a comment:

1. Click the text of the comment.

2. Press the Delete key on your keyboard.

6. When you finish managing comments, click OK.

7. Save the control file.

AFP Visual Environment puts each comment inside <Comment></Comment> tags near the top of
the AFP Indexer portion of the control file.
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55.. Editing AFP files

•Creating barcodes
•Replacing POSTNET barcodes with IMBs
•Creating IMB serial number files
•Creating conditions between barcode definitions
•Creating hidden areas
•Creating text with AFP Editor
•Defining text masks
•Modifying or deleting AFP Editor definitions

AFP Editor can create barcodes and text, hide areas, and mask text in AFP files. In addition, AFP Editor
can replace existing POSTNET barcodes with Intelligent Mail barcodes (IMBs). If you want AFP Editor
to use sequential serial numbers in IMBs, you must create an IMB serial number file.

CCrreeaattiinngg bbaarrccooddeess
AFP Editor lets you create barcodes in AFP files.

The barcode must be in a consistent position on every page and must be a consistent size. If text, an
image, or another barcode already exists in the area where you want to create a barcode, first hide the
area so that the existing text, image, or barcode does not print.

To determine the exact origin and size of the barcode area, work from a copy of the sample AFP file
printed on the production printer. Measure where you want to place the top-left corner of the barcode
area (X and Y positions) on the printed page from the top-left corner of the logical page. For BCOCA
barcode objects, also measure the width and height of the area.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create a barcode:

1. In AFP Visual Environment, open a sample AFP file.

2. If the file does not contain page groups or index tags for variable values (such as ZIP Codes) that
you want to use in barcode data, use AFP Indexer to create page groups and index tags.

3. ClickMode→ AFP Editor.

4. Navigate to the page where you want to create the barcode:

• To place a barcode on the same page in every page group, navigate to that page in any
page group.

• To place a barcode on multiple pages (for example, on even pages in every page group),
navigate to one of the pages in any page group.

5. Position your cursor at a corner of the barcode area. While pressing the left mouse button, draw
a box the approximate size of the barcode area. You can draw a horizontal, vertical, or square
box.

In a later step, you can specify the exact position and size of the barcode area.

6. Right-click anywhere in the AFP file and click Create barcode.

You see the Create Barcode window.
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7. On the Type tab, type a name for the area, select the type, and specify other properties.

For a description of the fields, see the information center topic about the Type tab.

8. On the Data tab, specify the data to be encoded in the barcode symbol.

For a description of the fields, see the information center topic about:

• Data tab for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code
barcodes

• Data tab for IMBs

9. On the Position tab, specify the exact origin and size of the barcode area, the orientation of the
barcode symbol within the area, and on which pages to place the barcode in each page group.

For a description of the fields, see the information center topic about the Position tab.

10. Click OK.

If you have more than one barcode defined, you might see the Create Conditions between
Definitions window. Click Yes if you want to create a condition for determining which barcode is
used, and then click OK.

If you created an Intelligent Mail barcode (IMB), POSTNET, or QR Code barcode, you see the
barcode symbol in the AFP file. If you created a Code 39, Data Matrix, Interleaved 2-of-5, or
PDF417 barcode, you see a box surrounding the barcode area with the title of the barcode area
in the orientation that you selected for the barcode symbol.

If you created a text IMB but do not see the barcode symbol, identify the resource directory that
contains the AFP IMB font to AFP Visual Environment (Resources→ Specify Resource
Directories). The AFP IMB font (character set C0XMUS23) is installed in the install_
directory/resources directory.

11. If you see an error message, the barcode is not created in any page group. In addition, no other
barcodes, hidden areas, or text masks are created. If the Create Barcode window is open,
correct the barcode properties. If the Create Barcode window is already closed, click
Tools→Modify Definitions to correct the properties.

(In the Modify and Delete Definitions window, identifies the barcode with the error.)

If you included index tag values in the barcode data and the error message indicates that
barcode data is too long or contains characters that are not valid, you might need to modify the
index tag to correct the problem.

Type tab

On the Type tab, you specify the name of the barcode area, the type of barcode that you want to
create, and the properties of the barcode.
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FFiieellddss oonn tthhee Type ttaabb

Field Value Description

Barcode name Any combination
of a-z, A-Z, 0–9,
special
characters, and
blanks.

The name of the barcode area. For example, if the barcode
is an Intelligent Mail barcode (IMB), you could name the
barcode “IMB”.

Barcode type Code 39 (3-of-9
Code)

A low-density barcode that can encode uppercase letters,
numbers, and some special characters.

Data Matrix A two-dimensional (2D) barcode consisting of black and
white square modules arranged in either a square or
rectangular pattern. This barcode uses the Solomon-Reed
error correction algorithm (ECC 200) to ensure data
reliability.

Intelligent Mail
(IMB)

A barcode defined by the United States Postal Service
(USPS) that is used to direct and track mail. This barcode
was previously called a USPS Four-State barcode.

Interleaved 2-of-5 A high-density barcode that can encode numbers.

PDF417 A two-dimensional (2D) barcode that consists of several
rows, each of which is like a small linear barcode. The
barcode can detect and correct errors.

POSTNET A barcode defined by the USPS that is used to direct mail.

QR Code A two-dimensional (2D) matrix barcode that consists of
black and white square modules arranged in a square
pattern. The contents of this “Quick Response” code can be
decoded at high speed. This barcode uses the Solomon-
Reed error correction algorithm (ECC 200) to ensure data
reliability.

Barcode
representation

Output type

BCOCA object AFP Editor creates barcode objects using Bar Code Object
Content Architecture (BCOCA) structured fields. In general,
BCOCA barcodes are preferred to text barcodes.
However, some older printers cannot process newer
barcode types. For example, IBM 3900 printers cannot
process IMBs. In this case, text barcodes are required.

This is the default.

Text barcode AFP Editor creates text barcodes that use the AFP barcode
font.

Notes:

1. This option is currently available only for IMBs.

2. AFP Editor uses the 300 dpi AFP IMB font (US23),
which produces a standard height barcode: character
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Field Value Description

set C0XMUS23 and code page T100USPS. If you
create text barcodes, you must install the IMB font in the
AFP resource directories that AFP Visual Environment
uses. Otherwise, AFP Visual Environment cannot display
the barcode symbol.

Output size

Optimal Size AFP Editor creates BCOCA barcodes so they are displayed
in the best size for viewing and printing. This is the default.

This option is currently available only for IMBs.

Compact Size AFP Editor creates BCOCA barcodes so they are displayed
in a compact size.

This option is currently available only for IMBs.

This table describes the fields on the Type tab that let you specify barcode properties. The fields differ
for each barcode type.

FFiieellddss oonn tthhee Type ttaabb ffoorr bbaarrccooddee pprrooppeerrttiieess

Barcode type Field Description

Code 39 (3-of-9
Code)

Include check
digit

A check digit ensures data integrity during the bar coding
reading process. If you select Yes, a check digit is included
in the barcode symbol.

Data Matrix Number of rows The number of rows in the barcode including the finder
pattern. If you select Auto, an appropriate number of rows
is used for the amount of data in the barcode symbol.

Row size The number of modules in each row including the finder
pattern. The row sizes you can select depend on the number
of rows. If you select Auto, an appropriate row size is used
for the amount of data in the barcode symbol.

Intelligent Mail
(IMB)

None None

Interleaved 2-of-5 Include check
digit

A check digit ensures data integrity during the bar coding
reading process. If you select Yes, check digit is included in
the barcode symbol.

PDF417 Row size The number of data symbol characters in each row. The
printer creates the minimum number of rows necessary for
the amount of data in the barcode symbol.
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Barcode type Field Description

POSTNET ZIP Code barcode The barcode symbol consists of a leading frame bar, the
encoded ZIP Code data, a correction digit, and a trailing
frame bar. The ZIP Code data is a 5-digit number.

ZIP Code+4
barcode

The barcode symbol consists of a leading frame bar, the
encoded ZIP+4 data, a correction digit, and a trailing frame
bar. The ZIP+4 data is a 9-digit number.

Advanced Bar
Code (ABC)

The barcode symbol consists of a leading frame bar, the
encoded ABC data, a correction digit, and a trailing frame
bar. The ABC data is an 11-digit number.

Variable-length
barcode

The barcode symbol consists of a leading frame bar, the
encoded data, a correction digit, and a trailing frame bar.
The encoded data is variable length.

QR Code Size The size of the barcode symbol, represented by the number
of modules in each row and column. The values are 21x21
to 177x177, or “smallest”, which indicates the smallest size
that can include all data.

Data tab for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and
QR Code barcodes

On the Data tab, you specify the data that AFP Editor encodes in the barcode symbol for Code 39,
Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code barcodes.

FFiieellddss oonn DDaattaa ttaabb

Field Value Description

Text Any valid
characters for the
barcode type (see
next table)

The text that you want to encode in the barcode symbol. For
example, you could use a blank character to separate
multiple index tags. (A blank is not a valid character in all
barcode types.) This value is the same in all page groups.

Index tag An index tag
name

The index tag whose value you want to encode in the
barcode. For example, you might want to encode a routing
code that you previously indexed. The barcodes will contain
the value of the index tag in the page group. This value can
be different in each page group, but is the same for all
pages in a page group.

Property A property name
The property you want to encode in the barcode. The
barcodes will contain the value of the property. This value is
the same in all page groups.

Include HRI Above barcode
symbol

Indicates that human-readable interpretation (HRI) is to be
printed above the barcode symbol. This field is visible only
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Field Value Description

for barcode types that support HRI: Code 39 and
Interleaved 2-of-5.

Below barcode
symbol

Indicates that human-readable interpretation (HRI) is to be
printed below the barcode symbol. This field is visible only
for barcode types that support HRI: Code 39 and
Interleaved 2-of-5.

Code page
encoding

A defined code
page encoding

The code page used to encode the barcode. You can only
select an encoding from the drop-down list for QR Code
barcodes.

This table shows the characters that are valid for each type of barcode.

VVaalliidd cchhaarraacctteerrss ffoorr bbaarrccooddeess

Barcode type Valid characters Total number of characters

Code 39 (3-of-9
Code)

0123456789
ABCDEFGHIJKLM
NOPQRSTUVWXYZ
- . $ / + %

space character

0 to 50 characters

Data Matrix Any one-byte
character, or
binary data

0 to 3116 characters

Interleaved 2-of-5 0123456789 0 to 50 characters

PDF417 Any one-byte
character, or
binary data

0 to 2710 characters

POSTNET 0123456789 The number of digits depends on the barcode property
selected on the Type tab:
• ZIP Code: 5 digits
• ZIP Code + 4: 9 digits
• Advanced Bar Code (ABC): 11 digits
• Variable-length barcode: 0 to n digits (barcode

receivers support at least 50 digits)

QR Code Any one-byte
character, or
binary data

0 to 3116 characters

Data tab for IMBs

On the Data tab, you specify the data that AFP Editor encodes in the barcode symbol for Intelligent
Mail barcodes (IMBs).
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FFiieellddss oonn tthhee Data ttaabb ffoorr IIMMBBss

Field Value Description

Barcode ID* 00 - 50 Optional Endorsement Line (OEL) sort level and exception
handling.

Service type ID* 040 - 782 Type of mail and any mail services requested.

Mailer ID* 0, 6, or 9 digits A 6 or 9-digit mailer ID obtained from the United States
Postal Service (USPS).

You can use the Mailer ID field for other purposes in an
IMB used for reply mail.

Serial number* A 6 or 9-digit serial number that identifies the mailpiece. The length depends on
the number of digits specified for mailer ID. The mailer ID and serial number
together can contain 15 digits.

AFP Editor adds leading zeroes to the value in this field so that the value in the
Mailer ID and Serial number fields together contain 15 digits.

Zeroes AFP Editor creates a serial number that contains zeroes.
Mailers who use only the USPS “Basic services” option can
use serial numbers with zeroes.

Index tag The name of an index tag that contains the serial number.

File name The full path name of an IMB serial number file that contains
the serial number to be encoded in the first barcode in the
AFP file. AFP Editor increments the serial number in the file
by 1 for each barcode.

Routing code* The routing code (also called routing ZIP Code and delivery point ZIP Code)
of the recipient of the mailpiece. The routing code, if one is specified, can
contain 5, 9, or 11 digits.

Index tag The name of an index tag that contains the routing code. If
blank, AFP Editor does not include a routing code in the
barcode.

AFP Editor removes any non-numeric characters from the
value in the index tag before encoding it in the barcode
symbol. For example, if the value of the index tag in a page
group is “12345–6789”, the value in the barcode symbol
is “123456789”.

Create index tag Save Indicates that AFP Editor is to create an index tag that
contains the data encoded in the IMB in the page group.
This option provides a record of the IMB data that you can
use to retrieve a mailpiece if, for example, the USPS reports
an address change for the mailpiece.
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Field Value Description

Index tag name The name to assign to the index tag that contains the IMB
data. Any combination of a-z, A-Z, 0–9, special
characters, and blanks.

*For more information about the values for these fields, see the Intelligent Mail® Barcode Technical
Resource Guide.

Position tab

On the Position tab, you specify the exact origin (top-left corner) and size (width and height) of the
barcode area, and the orientation of the barcode symbol within the barcode area. You can also specify
on which pages in each page group to place the barcode.

This figure shows four barcode areas with different orientations (0, 90, 180, 270 degrees) of the
barcode symbol. It also shows the barcode area origin, width, and height that you specify on the
Position tab for each area.

Barcode areas with four orientations of barcode symbol

In the figure, the asterisk (*) indicates the origin of the barcode symbol. AFP Editor automatically
determines the origin of the barcode symbol. The barcode symbol origin is different for each orientation:
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Orientation of symbol Origin of symbol

0 degrees Top-left corner of barcode area

90 degrees Top-right corner of barcode area

180 degrees Bottom-right corner of barcode area

270 degrees Bottom-left corner of barcode area

When you create BCOCA objects, the barcode area must be large enough to contain the largest
barcode symbol and human-readable interpretation (HRI), if any, in each page group. If any part of the
barcode symbol or HRI extends outside of the barcode area, the printer reports an exception and does
not print the barcode correctly. When you create text IMBs, the size of the barcode area is ignored.

FFiieellddss oonn tthhee Position ttaabb

Field Value Description

Origin of area: X
position

Any decimal
value, such as
2.5. The X
position cannot be
greater than the
width of the page.

The horizontal distance (in inches or millimeters) of the left
side of the barcode area measured from the left side of the
logical page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the X position from the top-left
corner of the logical page in the unrotated view.

Origin of area: Y
position

Any decimal
value, such as
2.5. The Y
position cannot be
greater than the
height of the
page.

The vertical distance (in inches or millimeters) of the top of
the barcode area measured from the top of the logical
page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the Y position from the top-left
corner of the logical page in the unrotated view.

Size of area:
Width

Any decimal
value, such as
2.5. The width of
the area cannot
be greater than
the width of the
page.

The horizontal width (in inches or millimeters) of the
barcode area measured in the unrotated view.

This field applies only to BCOCA objects. It is ignored for
text barcodes.

Size of area:
Height

Any decimal
value, such as
2.5. The height of
the area cannot
be greater than
the height of the
page.

The vertical height (in inches or millimeters) of the barcode
area measured in the unrotated view.

This field applies only to BCOCA objects. It is ignored for
text barcodes.
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Field Value Description

Orientation 0 degrees The barcode symbol is not rotated in the barcode area.

90 degrees The barcode symbol is rotated 90 degrees in the barcode
area.

180 degrees The barcode symbol is rotated 180 degrees in the barcode
area.

270 degrees The barcode symbol is rotated 270 degrees in the barcode
area.

Origin of barcode
symbol: X position

A decimal value. The horizontal distance (in inches or millimeters) of the
origin of the barcode symbol measured from the left side of
the logical page (not the physical sheet of paper). AFP
Editor automatically calculates this value.

Origin of barcode
symbol: Y position

A decimal value. The vertical distance (in inches or millimeters) of the origin of
the barcode symbol measured from the top of the page.
AFP Editor automatically calculates this value.

Placement of area Page n The barcode is placed on page n of each page group. n is
the number of the page where you drew the barcode area.

Multiple pages:
All pages

The barcode is placed on all pages in each page group.

Multiple pages:
Even pages

The barcode is placed on the even pages in each page
group (pages 2, 4, 6,...).

Multiple pages:
Odd pages

The barcode is placed on the odd pages in each page
group (pages 1, 3, 5,...).

RReeppllaacciinngg PPOOSSTTNNEETT bbaarrccooddeess wwiitthh IIMMBBss
You can replace POSTNET barcodes in AFP files with Intelligent Mail barcodes (IMBs). When you
replace POSTNET barcodes, AFP Editor deletes the POSTNET barcodes and creates IMBs that contain
the same routing codes as the POSTNET barcodes.

POSTNET barcodes can be in a fixed location in the AFP file or, in the case of a multiple line address,
they might float between lines. You can select the actual location of the POSTNET barcode that you
want replaced, or you can select an area in which you think the barcode is located.

AFP Editor can automatically place the IMBs in exactly the same position as the POSTNET barcodes
they replace. The position of the POSTNET barcodes can vary slightly in different page groups. The
position of any POSTNET barcode can be up to .4 inches or 10 millimeters higher or lower than the
position of the particular POSTNET barcode that you replaced in the sample AFP file. (This allows for
variations in the position of the POSTNET barcode in different page groups because of variable length
addresses.)

If you do not want to place the IMBs in the same position as the POSTNET barcodes they replace, you
can specify a new position for the IMBs. If you specify a new position, AFP Editor places all IMBs in the
exact position that you specify.
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To determine the new position of the IMBs, work from a copy of the sample AFP file printed on the
production printer. Measure where you want to place the top-left corner of the barcode area (X and Y
positions) on the printed page from the top-left corner of the logical page.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To place the IMB in the same position as the Address Change Service (ACS) data and PLANET
barcode, use AFP Editor to create a hidden area to cover the ACS data and PLANET barcode before
you replace the POSTNET barcode.

• You can replace POSTNET barcodes that are on logical pages in the AFP file. However, you cannot
replace POSTNET barcodes that are part of page segments or overlays.

To replace a POSTNET barcode with an IMB:

1. In AFP Visual Environment, open a sample AFP file.

2. If the file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→ AFP Editor.

4. Navigate to the page that contains one of the POSTNET barcodes.

5. OOppttiioonnaall:: To place the IMB in the same position as a PLANET barcode, create a hidden area
that covers the PLANET barcode and any other data that you do not want to print, such as ACS
data.

6. Do one of these:

• Select the POSTNET barcode.

• Position your cursor at a corner of the area that contains the POSTNET barcode. While
pressing the left mouse button, draw a box that includes the barcode.

7. Right-click anywhere in the AFP file and then click Replace POSTNET with IMB.

• If you do not see the Replace POSTNET with IMB option and the POSTNET barcode is a
text barcode, identify the directory that contains the POSTNET font to AFP Visual Environment
(Resources→ Specify Resource Directories). If you still do not see the Replace POSTNET
with IMB option, try changing the default code page to another code page
(Resources→Modify Default Encoding).

• If you see an error message instead of the Replace Barcode window, AFP Editor could not
find any POSTNET data in the area you selected.

8. On the Type tab, type a descriptive name for the IMB and specify the representation of the IMB.

See Type tab for IMBs, p. 100 for a description of the fields.

9. On the Data tab, specify the data to be encoded in the IMB symbol.

See Data tab for IMBs, p. 101 for a description of the fields.
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10. OOppttiioonnaall:: On the Position tab, change the origin of the barcode area or the orientation of the
barcode symbol within the area. You can also change on which pages to place the barcode in
each page group.

See Position tab for IMBs, p. 102 for a description of the fields.

11. Click OK.
If you have more than one barcode defined, you might see the Create Conditions between
Definitions window. Click Yes if you want to create a condition for determining which barcode is
used, and then click OK.

You see the IMB in the AFP file.

• If the IMB is a text barcode and you do not see the barcode symbol, identify the resource
directory that contains the AFP IMB font to AFP Visual Environment (Resources→ Specify
Resource Directories). The AFP IMB font (character set C0XMUS23) is installed in the
install_directory/resources directory.

12. If you see an error message, the barcode is not created in any page group. In addition, no other
barcodes, hidden areas, or text masks are created. If the Replace Barcode window is open,
correct the barcode properties. If the Replace Barcode window is already closed, click
Tools→Modify Definitions to correct the properties. (In the Modify and Delete Definitions
window, identifies the barcode with the error.)

If you included index tag values in the barcode data and the error message indicates that
barcode data is too long or contains characters that are not valid, you might need to modify the
index tag to correct the problem.

Type tab for IMBs

On the Type tab, you specify the name of the Intelligent Mail barcode (IMB) area and whether to
create a BCOCA or text barcode.

FFiieellddss oonn tthhee Type ttaabb

Field Value Description

Barcode name Any combination
of a-z, A-Z, 0–9,
special
characters, and
blanks.

The name of the barcode area. For example, you could
name the barcode “IMB”.

Barcode
representation

Output type

BCOCA object AFP Editor creates barcode objects using Bar Code Object
Content Architecture (BCOCA) structured fields. In general,
BCOCA barcodes are preferred to text barcodes.
However, some older printers cannot process newer
barcode types. For example, IBM 3900 printers cannot
process IMBs. In this case, text barcodes are required.
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Field Value Description

This is the default.

Text barcode AFP Editor creates text barcodes that use the AFP barcode
font.

AFP Editor uses the 300 dpi AFP IMB font (US23), which
produces a standard height barcode: character set
C0XMUS23 and code page T100USPS. If you create text
barcodes, you must install the IMB font in the AFP resource
directories that AFP Visual Environment uses. Otherwise,
AFP Visual Environment cannot display the barcode symbol.

Output size

Optimal Size AFP Editor creates BCOCA barcodes so they are displayed
in the best size for viewing and printing. This is the default.

Compact Size AFP Editor creates BCOCA barcodes so they are displayed
in a compact size.

Data tab for IMBs

On the Data tab, you specify the data that AFP Editor encodes in the barcode symbol for Intelligent
Mail barcodes (IMBs).

FFiieellddss oonn tthhee Data ttaabb ffoorr IIMMBBss

Field Value Description

Barcode ID* 00 - 50 Optional Endorsement Line (OEL) sort level and exception
handling.

Service type ID* 040 - 782 Type of mail and any mail services requested.

Mailer ID* 0, 6, or 9 digits A 6 or 9-digit mailer ID obtained from the United States
Postal Service (USPS).

You can use the Mailer ID field for other purposes in an
IMB used for reply mail.

Serial number* A 6- or 9-digit serial number that identifies the mailpiece. The length depends on
the number of digits specified for mailer ID. The mailer ID and serial number
together can contain 15 digits.

AFP Editor adds leading zeroes to the value in this field so that the value in the
Mailer ID and Serial number fields together contain 15 digits.
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Field Value Description

Zeroes AFP Editor creates a serial number that contains zeroes.
Mailers who use only the USPS “Basic services” option can
use serial numbers with zeroes.

Index tag The name of an index tag that contains the serial number.

File name The full path name of an IMB serial number file that contains
the serial number to be encoded in the first barcode in the
AFP file. AFP Editor increments the serial number in the file
by 1 for each barcode.

Routing code* The routing code (also called routing ZIP Code and delivery point ZIP Code)
of the recipient. The routing code, if one is specified, can contain 5, 9, or 11
digits.

Index tag The name of an index tag that contains the routing code. If
no index tag name is specified, AFP Editor does not encode
a routing code in the IMB.

AFP Editor removes any non-numeric characters from the
value in the index tag before encoding it in the barcode
symbol. For example, if the value of the index tag in a page
group is “12345–6789”, the value in the barcode symbol
is “123456789”.

POSTNET data AFP Editor includes the same routing code as in the
POSTNET barcode. The routing code in the POSTNET
barcode on the current page in the AFP file is displayed.

Create index tag Save Indicates that AFP Editor is to create an index tag that
contains the data encoded in the IMB in the page group.
This option provides a record of the IMB data that you can
use to retrieve a mailpiece if, for example, the USPS reports
an address change for the mailpiece.

Index tag name The name to assign to the index tag that contains the IMB
data. Any combination of a-z, A-Z, 0–9, special
characters, and blanks.

*For more information about the values for these fields, see the Intelligent Mail® Barcode Technical
Resource Guide.

Position tab for IMBs

On the Position tab, you can change the origin (top-left corner) of the Intelligent Mail barcode (IMB),
the size of the barcode area, and the orientation of the barcode symbol.

When you create BCOCA IMBs, the barcode area must be large enough to contain the largest
barcode symbol in each page group. If any part of the barcode symbol extends outside of the barcode
area, the printer reports an exception and does not print the barcode correctly.
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AFP Editor automatically creates IMBs with the same orientation as the POSTNET barcodes. However,
you can select a different orientation for the barcode symbol (0, 90, 180, 270 degrees).

FFiieellddss oonn tthhee Position ttaabb

Field Value Description

Origin of area: X
position

Any decimal
value, such as
2.5. The X
position cannot be
greater than the
width of the page.

The horizontal distance (in inches or millimeters) of the left
side of the barcode area measured from the left side of the
logical page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the X position from the top-left
corner of the page in the unrotated view.

Origin of area: Y
position

Any decimal
value, such as
2.5. The Y
position cannot be
greater than the
height of the
page.

The vertical distance (in inches or millimeters) of the top of
the barcode area measured from the top of the logical
page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the Y position from the top-left
corner of the page in the unrotated view.

Size of area:
Width

Any decimal
value, such as
2.5. The width of
the area cannot
be greater than
the width of the
page.

The horizontal width (in inches or millimeters) of the
barcode area measured in the unrotated view. If the
POSTNET barcode is a BCOCA object, the initial width is
the width of the POSTNET barcode area. If the POSTNET
barcode is a text barcode, the initial width is the maximum
width for IMBs.

This field applies only to BCOCA barcodes. It is ignored for
text barcodes.

Size of area:
Height

Any decimal
value, such as
2.5. The height of
the area cannot
be greater than
the height of the
page.

The vertical height (in inches or millimeters) of the barcode
area measured in the unrotated view. If the POSTNET
barcode is a BCOCA object, the initial height is the height
of the POSTNET barcode area. If the POSTNET barcode is
a text barcode, the initial height is the maximum height for
IMBs.

This field applies only to BCOCA barcodes. It is ignored for
text barcodes.

Orientation 0 degrees The barcode symbol is not rotated in the barcode area.

90 degrees The barcode symbol is rotated 90 degrees in the barcode
area.

180 degrees The barcode symbol is rotated 180 degrees in the barcode
area.
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Field Value Description

270 degrees The barcode symbol is rotated 270 degrees in the barcode
area.

Origin of barcode
symbol: X position

A decimal value. The horizontal distance (in inches or millimeters) of the
origin of the barcode symbol measured from the left side of
the logical page (not the physical sheet of paper). AFP
Editor automatically calculates this value.

Origin of barcode
symbol: Y position

A decimal value. The vertical distance (in inches or millimeters) of the origin of
the barcode symbol measured from the top of the logical
page (not the physical sheet of paper). AFP Editor
automatically calculates this value.

Placement of area Page n The barcode is placed on page n of each page group. n is
the number of the page where you drew the barcode area.

Multiple pages:
All pages

The barcode is placed on all pages in each page group.

Multiple pages:
Even pages

The barcode is placed on the even pages in each page
group (pages 2, 4, 6,...).

Multiple pages:
Odd pages

The barcode is placed on the odd pages in each page
group (pages 1, 3, 5,...).

CCrreeaattiinngg IIMMBB sseerriiaall nnuummbbeerr ffiilleess
If you want Intelligent Mail barcodes (IMBs) to contain a sequential serial number that identifies each
mailpiece, you must create a serial number file.

The IMB serial number file contains the serial number that you want to encode in the first IMB that AFP
Editor creates in a production AFP file. AFP Editor increments the serial number by 1 in each subsequent
IMB so that the serial number is unique.

You can use different IMB serial number files when you create IMBs in a sample AFP file and when you
run the EditAFP command to create the IMBs in production AFP files. To use a different serial number
file for the production AFP files, you specify the name of the serial number file to use for the IMB
definition in the -snf option of the EditAFP command.

You can create a different IMB serial number file for each barcode that has a unique barcode definition
name. For example, if one IMB contains the customer's routing ZIP Code and another IMB contains
your company's routing ZIP Code (in a reply address), you can create a separate IMB serial number
file for each barcode definition.

To create an IMB serial number file:

1. On the preparation system, create an IMB serial number file.

2. Identify the serial number file with a name of the barcode that the file applies to. For example, if
the barcode contains the customer's routing code, you might name the barcode “to-imb” and the
serial number file “to-imb-serial”.

3. If the production system is different than the preparation system, use the File Transfer Program
(ftp) to send the serial number file to the production system. Use the ftp binary option.
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CCrreeaattiinngg ccoonnddiittiioonnss bbeettwweeeenn bbaarrccooddee ddeeffiinniittiioonnss
When you define more than one barcode, you can create a condition between two barcodes that AFP
Editor uses to determine which barcode is created in the AFP file.

You can use conditions to control when a barcode is added to a page group. For example, if some
page groups contain POSTNET barcodes and some page groups do not, you might want to add a new
barcode to the page groups that do not have one. You can define a new barcode and create a
condition so that whenever the POSTNET barcode is not found, the new barcode is added to the page
group. Similarly, if you want to replace an existing barcode in all page groups with a new barcode,
you can define a condition so that whenever the old barcode is found, it is replaced with the new
barcode.

To create a condition between barcode definitions:

1. In AFP Visual Environment, open a sample AFP file.

2. ClickMode→ AFP Editor.

3. Create two barcodes if you do not already have two defined.

4. Do one of these:

• After the second barcode is defined, click Yes when you are asked if you want to create a
condition for this definition.

• Click Tools→Modify Definitions and then click Conditions on the Modify and Delete
Definitions window.

You see the Create Conditions between Definitions window.

5. From the drop-down list, select a barcode in the Select Definition 1 field.

6. From the drop-down list, select one of these conditions in the Select Condition field:

• fails, run: If the first barcode definition cannot be created, use the second definition.

• succeeds, run: If the first barcode definition can be created, use the second definition.

7. From the drop-down list, select a barcode in the Select Definition 2 field.

8. Click OK.
The condition is created and is listed on the Modify and Delete Definitions window, if it is open. If
the Modify and Delete Definitions window is closed, click Tools→Modify Definitions to see
the condition you just defined.

9. To close the Modify and Delete Definitions window, click X in the upper right corner.

CCrreeaattiinngg hhiiddddeenn aarreeaass
You can hide areas in AFP files that you do not want to print and that you do not want an AFP viewer to
display. For example, you might hide an area that contains a barcode before you create a new
barcode in the same place.

The hidden area must be in a consistent position on every page and must be a consistent size. To
determine the exact position and size of the hidden area, first print the sample AFP file on the production
printer and measure where you want to place the top-left corner of the hidden area on the printed
page.
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In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create a hidden area:

1. In AFP Visual Environment, open a sample AFP file.

2. If the sample AFP file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→ AFP Editor.

4. Navigate to the page where you want to create the hidden area:

• To place a hidden area on the same page in every page group, navigate to that page in any
page group.

• To place a hidden area on multiple pages, navigate to one of the pages in any page group.

5. Position your cursor at a corner of the hidden area. While pressing the left mouse button, draw a
box the approximate size of the hidden area.

In a later step, you can specify the exact position and size of the hidden area.

6. Right-click anywhere in the AFP file and click Hide area.

7. Type a descriptive name for the area in the Hidden area name field.
For example, if the hidden area contains a barcode for a ZIP Code, the name could be “ZIP
Code”.

8. Select the color of the area in the Color field.

9. Specify the exact origin (top-left corner) of the hidden area in these fields. Specify the values in
inches or millimeters.

X position
The horizontal distance of the left side of the hidden area measured from the left side of the
logical page (not the physical sheet of paper). Decimal values (such as 2.5) are allowed. The
X position cannot be greater than the width of the page.

Y position
The vertical distance of the top of the hidden area measured from the top of the logical page
(not the physical sheet of paper). Decimal values (such as 2.5) are allowed. The Y position
cannot be greater than the height of the page.

The initial values of these fields are the X and Y positions of the top-left corner of the box that you
drew.

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the page in the unrotated view.

10. Specify the exact size of the hidden area in these fields. Specify the values in inches or
millimeters.

Width
The horizontal width of the hidden area. Decimal values (such as 2.5) are allowed. The width
of the area cannot be greater than the width of the page.
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Height
The vertical height of the hidden area. Decimal values (such as 2.5) are allowed. The height
of the area cannot be greater than the height of the page.

The initial values for these fields are the width and height of the box that you drew.

Measure the width and height from the origin of the hidden area in the unrotated view.

11. Select one of these options to place the hidden area:

• Page nn: Place the hidden area on page n of each page group (n is the page where you
drew the box for the hidden area). You cannot change this page number. If the page number
is incorrect, click Cancel and draw the box for the hidden area on the correct page.

• Multiple pages: Place the hidden area on:

All pages
All pages in each page group

Even pages
The even pages in each page group (pages 2, 4, 6,...)

Odd pages
The odd pages in each page group (pages 1, 3, 5,...)

12. Click OK.
You do not see any text or image data in the hidden area in each page group.

CCrreeaattiinngg tteexxtt wwiitthh AAFFPP EEddiittoorr
You can create a string of text on a specified page of each page group in an AFP file and specify its
color, font, and size.

For example, you can add page numbers or you can add text so that the information in a barcode is
also printed as readable text.

You can create text in an AFP file from:

• Text you enter from the keyboard

• Index tags defined in each page group

• Page number or page count property values

To determine the position of the new text, work from a copy of the sample AFP file printed on the
production printer. Measure where you want to place the top-left corner of the text area (X and Y
positions) on the printed page from the top-left corner of the logical page.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create text in an AFP file:

1. In AFP Visual Environment, open a sample AFP file.
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2. If the file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→ AFP Editor.

4. To create an area for the text, position your cursor at a corner of the area you want to create.
While pressing the left mouse button, draw a box the size you want.

5. Right-click anywhere in the AFP file and then click Create Text.
You see the Create Text String window.

6. On the Text tab, type a descriptive name for the text area in the Text definition name field.

7. In the Text string data section, create a text string.
For example, to add the page number, such as "Page 1 of 10", to the first page of each page
group:

1. Type Page in the Text field and click Add.

2. Select Page in Page Group from the Property drop-down list and click Add. Page in
Page Group is the number of the page in the page group.

3. Type of in the Text field and click Add.

4. Select Page Group Page Count from the Property drop-down list and click Add. Page
Group Page Count is the total number of pages in the page group.

You see the text string value in the field below the data fields.

8. OOppttiioonnaall:: To edit the text string, select a line of data and use Up or Down to change the order
of the line or Remove to delete the line.
Remember to add blank characters between words if you need to.

9. OOppttiioonnaall:: Select a color for the text from the Color drop-down list.

10. OOppttiioonnaall:: On the Font tab, select one of these:

Core Fonts
From the drop-down lists, select the character set and code page, and, if the font is an outline
font, the point size in the Font Information section.

External Fonts
Type a character set and code page pair, a coded font name, or all three. For double-byte
character set (DBCS) fonts, use the coded font name only.

• If you enter a code page that is part of a DBCS-coded font, you see an error message
that suggests you use the coded font name instead.

You see the Character Set Description and Font Resource fields change for the font you
selected. Font Resource is "Outline" for core fonts and "Raster" for external fonts.

• On your workstation, if the font size does not exist for the color you selected, your display
defaults to 12 black, even though the final AFP file will have the correct font and color.

11. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner), size, and orientation of the
text area. Specify the origin and size in inches or millimeters. Decimal values (such as 2.5) are
allowed. The fields are:
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X position
The horizontal distance of the left side of the area measured from the left side of the logical
page (not the physical sheet of paper).

Y position
The vertical distance of the top of the area measured from the top of the logical page (not the
physical sheet of paper).

Width
The horizontal width of the area.

Height
The vertical height of the area.

Orientation
The number of degrees the text is rotated in the defined area: 0o, 90o , 180o, 270o

If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X and
Y positions from the top-left corner of the logical page in the unrotated view.

12. Click OK.
You see the text in the AFP file.

13. Repeat steps 4 to 12 to add text to another page in each page group. For example, select the
second page to add "Page 2 of 10" to the second page of each page group.

DDeeffiinniinngg tteexxtt mmaasskkss
You can define text masks to replace specific data with another character. For example, you might need
to block out (or mask) sensitive information, such as customer names and social security numbers.

The text you want to mask must occur in a consistent location on every page group in the file.

To define a text mask:

1. In AFP Visual Environment, open a sample AFP file that contains the text you want to mask.

2. If the sample AFP file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→ AFP Editor.

4. Click the text you want to mask.

The text blocks you can select are defined in the AFP file, from one character to the entire line of
text.
You see a red box around the text you selected.

5. Right-click the text and select Create text mask.
You see the Create Text Mask window with the default character “x” in theMask character
field. In theMasked value field, you also see how the selected text is masked with the mask
character.

6. Type another mask character if you do not want to use the default character. The value in the
Masked value field changes to the character you selected.

7. Decide whether you want to mask the entire text value or part of the text.
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You can edit the text to reduce the number of characters you mask. For example, if the account
number is one text block, 01-345678, you can mask part of the account number, such as 345678.

To edit the text mask value, click Edit mask value. Edit the value in the Edit Value window and
click OK.

8. Although text might appear to be present in the same location on each statement, slight position
variations can occur in the AFP file. To change the threshold to look for a text value that is in
slightly different positions on some pages, click the Advanced tab. You can select a range from
1/100 to 1 inch.

The threshold defines how far the text can be from the original location and be considered a
mask value. For example, a threshold value of 12 indicates that the mask value can be located
within .12 of an inch either vertically or horizontally. Usually the default threshold value of 10 is
sufficient.

Keep in mind that if you increase the threshold above the default value, you might mask text you
did not expect because the match is only done on location, so the first text block found in the
threshold range is used as the text mask.

9. Click OK.

10. Verify that the correct text has been masked in all page groups:

1. Double-click the page groups in the bottom pane and verify that the correct text has been
marked.

2. If the text mask is incorrect, modify or delete the text mask (Tools→ Definitions→Modify
and Delete).

MMooddiiffyyiinngg oorr ddeelleettiinngg AAFFPP EEddiittoorr ddeeffiinniittiioonnss
After you create barcodes, text, hidden areas, definition conditions, or text masks, you can modify or
delete any of them. You can also create and modify conditions if you have defined at least two
barcodes.

Modifying barcodes

You can modify the barcodes that were created with AFP Editor. You cannot modify barcodes that are
defined in the AFP file itself.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify a barcode:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the barcodes. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.

3. Do one of these:

• Select the barcode that you want to modify and then clickModify.
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• Double-click the barcode that you want to modify.

You see the Modify Barcode window.

identifies barcodes that were not created because of an error. To see the error message, click
Modify and then click OK on the Modify Barcode window.

4. Optional: On the Type tab, type a new name or change the type of barcode.

See Type tab, p. 90 for a description of the fields.

5. Optional: On the Data tab, change the data to be encoded in the barcode symbol.
See Data tab for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code
barcodes, p. 93 or Data tab for IMBs, p. 94 for a description of the fields.

6. Optional: On the Position tab, change the exact origin and size of the barcode area, the
orientation of the barcode symbol within the area, and on which pages to place the barcode in
each page group.

See Position tab, p. 96 for a description of the fields.

7. Click OK.
If the barcode is an IMB, POSTNET, or QR Code barcode, you see the barcode symbol in the
AFP file. If the barcode is a Code 39, Data Matrix, Interleaved 2-of-5, or PDF417 barcode, you
see a box surrounding the barcode area with the title of the barcode area in the orientation that
you selected for the barcode symbol.

If the IMB is a text IMB and you do not see the barcode symbol, identify the resource directory
that contains the AFP IMB font to AFP Visual Environment (Resources→ Specify Resource
Directories).

• The AFP IMB font (character set C0XMUS23) is installed in the plugins/EditAFP directory.

8. To close the Modify and Delete Definitions window, click X in the upper right corner.

Type tab

On the Type tab, you specify the name of the barcode area, the type of barcode that you want to
create, and the properties of the barcode.

FFiieellddss oonn tthhee Type ttaabb

Field Value Description

Barcode name Any combination
of a-z, A-Z, 0–9,
special
characters, and
blanks.

The name of the barcode area. For example, if the barcode
is an Intelligent Mail barcode (IMB), you could name the
barcode “IMB”.

Barcode type Code 39 (3-of-9
Code)

A low-density barcode that can encode uppercase letters,
numbers, and some special characters.
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Field Value Description

Data Matrix A two-dimensional (2D) barcode consisting of black and
white square modules arranged in either a square or
rectangular pattern. This barcode uses the Solomon-Reed
error correction algorithm (ECC 200) to ensure data
reliability.

Intelligent Mail
(IMB)

A barcode defined by the United States Postal Service
(USPS) that is used to direct and track mail. This barcode
was previously called a USPS Four-State barcode.

Interleaved 2-of-5 A high-density barcode that can encode numbers.

PDF417 A two-dimensional (2D) barcode that consists of several
rows, each of which is like a small linear barcode. The
barcode can detect and correct errors.

POSTNET A barcode defined by the USPS that is used to direct mail.

QR Code A two-dimensional (2D) matrix barcode that consists of
black and white square modules arranged in a square
pattern. The contents of this “Quick Response” code can be
decoded at high speed. This barcode uses the Solomon-
Reed error correction algorithm (ECC 200) to ensure data
reliability.

Barcode
representation

Output type

BCOCA object AFP Editor creates barcode objects using Bar Code Object
Content Architecture (BCOCA) structured fields. In general,
BCOCA barcodes are preferred to text barcodes.
However, some older printers cannot process newer
barcode types. For example, IBM 3900 printers cannot
process IMBs. In this case, text barcodes are required.

This is the default.

Text barcode AFP Editor creates text barcodes that use the AFP barcode
font.

Notes:

1. This option is currently available only for IMBs.

2. AFP Editor uses the 300 dpi AFP IMB font (US23),
which produces a standard height barcode: character
set C0XMUS23 and code page T100USPS. If you
create text barcodes, you must install the IMB font in the
AFP resource directories that AFP Visual Environment
uses. Otherwise, AFP Visual Environment cannot display
the barcode symbol.

Output size
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Field Value Description

Optimal Size AFP Editor creates BCOCA barcodes so they are displayed
in the best size for viewing and printing. This is the default.

This option is currently available only for IMBs.

Compact Size AFP Editor creates BCOCA barcodes so they are displayed
in a compact size.

This option is currently available only for IMBs.

This table describes the fields on the Type tab that let you specify barcode properties. The fields differ
for each barcode type.

FFiieellddss oonn tthhee Type ttaabb ffoorr bbaarrccooddee pprrooppeerrttiieess

Barcode type Field Description

Code 39 (3-of-9
Code)

Include check
digit

A check digit ensures data integrity during the bar coding
reading process. If you select Yes, a check digit is included
in the barcode symbol.

Data Matrix Number of rows The number of rows in the barcode including the finder
pattern. If you select Auto, an appropriate number of rows
is used for the amount of data in the barcode symbol.

Row size The number of modules in each row including the finder
pattern. The row sizes you can select depend on the number
of rows. If you select Auto, an appropriate row size is used
for the amount of data in the barcode symbol.

Intelligent Mail
(IMB)

None None

Interleaved 2-of-5 Include check
digit

A check digit ensures data integrity during the bar coding
reading process. If you select Yes, check digit is included in
the barcode symbol.

PDF417 Row size The number of data symbol characters in each row. The
printer creates the minimum number of rows necessary for
the amount of data in the barcode symbol.

POSTNET ZIP Code barcode The barcode symbol consists of a leading frame bar, the
encoded ZIP Code data, a correction digit, and a trailing
frame bar. The ZIP Code data is a 5-digit number.

ZIP Code+4
barcode

The barcode symbol consists of a leading frame bar, the
encoded ZIP+4 data, a correction digit, and a trailing frame
bar. The ZIP+4 data is a 9-digit number.
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Barcode type Field Description

Advanced Bar
Code (ABC)

The barcode symbol consists of a leading frame bar, the
encoded ABC data, a correction digit, and a trailing frame
bar. The ABC data is an 11-digit number.

Variable-length
barcode

The barcode symbol consists of a leading frame bar, the
encoded data, a correction digit, and a trailing frame bar.
The encoded data is variable length.

QR Code Size The size of the barcode symbol, represented by the number
of modules in each row and column. The values are 21x21
to 177x177, or “smallest”, which indicates the smallest size
that can include all data.

Data tab for Code 39, Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and
QR Code barcodes

On the Data tab, you specify the data that AFP Editor encodes in the barcode symbol for Code 39,
Data Matrix, Interleaved 2-of-5, PDF417, POSTNET, and QR Code barcodes.

FFiieellddss oonn DDaattaa ttaabb

Field Value Description

Text Any valid
characters for the
barcode type (see
next table)

The text that you want to encode in the barcode symbol. For
example, you could use a blank character to separate
multiple index tags. (A blank is not a valid character in all
barcode types.) This value is the same in all page groups.

Index tag An index tag
name

The index tag whose value you want to encode in the
barcode. For example, you might want to encode a routing
code that you previously indexed. The barcodes will contain
the value of the index tag in the page group. This value can
be different in each page group, but is the same for all
pages in a page group.

Property A property name
The property you want to encode in the barcode. The
barcodes will contain the value of the property. This value is
the same in all page groups.

5 Editing AFP files



5

115

Field Value Description

Include HRI Above barcode
symbol

Indicates that human-readable interpretation (HRI) is to be
printed above the barcode symbol. This field is visible only
for barcode types that support HRI: Code 39 and
Interleaved 2-of-5.

Below barcode
symbol

Indicates that human-readable interpretation (HRI) is to be
printed below the barcode symbol. This field is visible only
for barcode types that support HRI: Code 39 and
Interleaved 2-of-5.

Code page
encoding

A defined code
page encoding

The code page used to encode the barcode. You can only
select an encoding from the drop-down list for QR Code
barcodes.

This table shows the characters that are valid for each type of barcode.

VVaalliidd cchhaarraacctteerrss ffoorr bbaarrccooddeess

Barcode type Valid characters Total number of characters

Code 39 (3-of-9
Code)

0123456789
ABCDEFGHIJKLM
NOPQRSTUVWXYZ
- . $ / + %

space character

0 to 50 characters

Data Matrix Any one-byte
character, or
binary data

0 to 3116 characters

Interleaved 2-of-5 0123456789 0 to 50 characters

PDF417 Any one-byte
character, or
binary data

0 to 2710 characters

POSTNET 0123456789 The number of digits depends on the barcode property
selected on the Type tab:
• ZIP Code: 5 digits
• ZIP Code + 4: 9 digits
• Advanced Bar Code (ABC): 11 digits
• Variable-length barcode: 0 to n digits (barcode

receivers support at least 50 digits)

QR Code Any one-byte
character, or
binary data

0 to 3116 characters
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Data tab for IMBs

On the Data tab, you specify the data that AFP Editor encodes in the barcode symbol for Intelligent
Mail barcodes (IMBs).

FFiieellddss oonn tthhee Data ttaabb ffoorr IIMMBBss

Field Value Description

Barcode ID* 00 - 50 Optional Endorsement Line (OEL) sort level and exception
handling.

Service type ID* 040 - 782 Type of mail and any mail services requested.

Mailer ID* 0, 6, or 9 digits A 6 or 9-digit mailer ID obtained from the United States
Postal Service (USPS).

You can use the Mailer ID field for other purposes in an
IMB used for reply mail.

Serial number* A 6 or 9-digit serial number that identifies the mailpiece. The length depends on
the number of digits specified for mailer ID. The mailer ID and serial number
together can contain 15 digits.

AFP Editor adds leading zeroes to the value in this field so that the value in the
Mailer ID and Serial number fields together contain 15 digits.

Zeroes AFP Editor creates a serial number that contains zeroes.
Mailers who use only the USPS “Basic services” option can
use serial numbers with zeroes.

Index tag The name of an index tag that contains the serial number.

File name The full path name of an IMB serial number file that contains
the serial number to be encoded in the first barcode in the
AFP file. AFP Editor increments the serial number in the file
by 1 for each barcode.

Routing code* The routing code (also called routing ZIP Code and delivery point ZIP Code)
of the recipient of the mailpiece. The routing code, if one is specified, can
contain 5, 9, or 11 digits.

Index tag The name of an index tag that contains the routing code. If
blank, AFP Editor does not include a routing code in the
barcode.

AFP Editor removes any non-numeric characters from the
value in the index tag before encoding it in the barcode
symbol. For example, if the value of the index tag in a page
group is “12345–6789”, the value in the barcode symbol
is “123456789”.
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Field Value Description

Create index tag Save Indicates that AFP Editor is to create an index tag that
contains the data encoded in the IMB in the page group.
This option provides a record of the IMB data that you can
use to retrieve a mailpiece if, for example, the USPS reports
an address change for the mailpiece.

Index tag name The name to assign to the index tag that contains the IMB
data. Any combination of a-z, A-Z, 0–9, special
characters, and blanks.

*For more information about the values for these fields, see the Intelligent Mail® Barcode Technical
Resource Guide.

Position tab

On the Position tab, you specify the exact origin (top-left corner) and size (width and height) of the
barcode area, and the orientation of the barcode symbol within the barcode area. You can also specify
on which pages in each page group to place the barcode.

This figure shows four barcode areas with different orientations (0, 90, 180, 270 degrees) of the
barcode symbol. It also shows the barcode area origin, width, and height that you specify on the
Position tab for each area.

Barcode areas with four orientations of barcode symbol

In the figure, the asterisk (*) indicates the origin of the barcode symbol. AFP Editor automatically
determines the origin of the barcode symbol. The barcode symbol origin is different for each orientation:
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Orientation of symbol Origin of symbol

0 degrees Top-left corner of barcode area

90 degrees Top-right corner of barcode area

180 degrees Bottom-right corner of barcode area

270 degrees Bottom-left corner of barcode area

When you create BCOCA objects, the barcode area must be large enough to contain the largest
barcode symbol and human-readable interpretation (HRI), if any, in each page group. If any part of the
barcode symbol or HRI extends outside of the barcode area, the printer reports an exception and does
not print the barcode correctly. When you create text IMBs, the size of the barcode area is ignored.

FFiieellddss oonn tthhee Position ttaabb

Field Value Description

Origin of area: X
position

Any decimal
value, such as
2.5. The X
position cannot be
greater than the
width of the page.

The horizontal distance (in inches or millimeters) of the left
side of the barcode area measured from the left side of the
logical page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the X position from the top-left
corner of the logical page in the unrotated view.

Origin of area: Y
position

Any decimal
value, such as
2.5. The Y
position cannot be
greater than the
height of the
page.

The vertical distance (in inches or millimeters) of the top of
the barcode area measured from the top of the logical
page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o option
on the View menu, specify the Y position from the top-left
corner of the logical page in the unrotated view.

Size of area:
Width

Any decimal
value, such as
2.5. The width of
the area cannot
be greater than
the width of the
page.

The horizontal width (in inches or millimeters) of the
barcode area measured in the unrotated view.

This field applies only to BCOCA objects. It is ignored for
text barcodes.

Size of area:
Height

Any decimal
value, such as
2.5. The height of
the area cannot
be greater than
the height of the
page.

The vertical height (in inches or millimeters) of the barcode
area measured in the unrotated view.

This field applies only to BCOCA objects. It is ignored for
text barcodes.
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Field Value Description

Orientation 0 degrees The barcode symbol is not rotated in the barcode area.

90 degrees The barcode symbol is rotated 90 degrees in the barcode
area.

180 degrees The barcode symbol is rotated 180 degrees in the barcode
area.

270 degrees The barcode symbol is rotated 270 degrees in the barcode
area.

Origin of barcode
symbol: X position

A decimal value. The horizontal distance (in inches or millimeters) of the
origin of the barcode symbol measured from the left side of
the logical page (not the physical sheet of paper). AFP
Editor automatically calculates this value.

Origin of barcode
symbol: Y position

A decimal value. The vertical distance (in inches or millimeters) of the origin of
the barcode symbol measured from the top of the page.
AFP Editor automatically calculates this value.

Placement of area Page n The barcode is placed on page n of each page group. n is
the number of the page where you drew the barcode area.

Multiple pages:
All pages

The barcode is placed on all pages in each page group.

Multiple pages:
Even pages

The barcode is placed on the even pages in each page
group (pages 2, 4, 6,...).

Multiple pages:
Odd pages

The barcode is placed on the odd pages in each page
group (pages 1, 3, 5,...).

Deleting barcodes

You can delete the barcodes that were created with AFP Editor. You cannot delete barcodes that are
defined in the AFP file itself (instead, you can create areas to hide barcodes).

To delete a barcode:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the barcodes. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with a list of the barcodes.

3. Select the barcode that you want to delete.

4. Click Delete, or press the Delete key on your keyboard.
The barcode is removed from the list. Any conditions that are defined for that barcode are also
deleted.

5. To close the Modify and Delete Definitions window, click X in the upper right corner.
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Modifying conditions between barcode definitions

You can modify the conditions that AFP Editor uses to determine which barcode is used.

To modify a definition condition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the condition
definitions for the barcodes. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.

3. Do one of these:

• Select the definition condition that you want to modify and then clickModify.

• Double-click the definition condition that you want to modify.

You see the Modify Conditions between Definitions window.

4. Select the Definition 1, Condition, and Definition 2 that you want to change.

5. Click OK.
The condition is modified in the list.

6. To close the Modify and Delete Definitions window, click X in the upper right corner.

Deleting conditions between barcode definitions

You can delete the conditions that AFP Editor uses to determine which barcode is used.

To delete a definition condition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for conditions. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with a list of the definition conditions.

3. Select the definition condition that you want to delete.

4. Click Delete, or press the Delete key on your keyboard.
The definition condition is removed from the list.

5. To close the Modify and Delete Definitions window, click X in the upper right corner.

Modifying hidden areas

You can modify the hidden areas that were created with AFP Editor.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.
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To modify a hidden area:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the hidden areas. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.

3. Do one of these:

• Select the hidden area that you want to modify and then clickModify.

• Double-click the hidden area that you want to modify.

You see the Modify Hidden Area window.

identifies barcodes that were not created because of an error. To see the error message, click
Modify and then click OK on the Modify Barcode window.

4. To change the descriptive name of the hidden area, type the new name in the Hidden area
name field.

5. To change the origin (top-left corner) of the hidden area, type new values in these fields.

X position
The horizontal distance of the left side of the hidden area measured from the left side of the
logical page (not the physical sheet of paper). Decimal values (such as 2.5) are allowed. The
X position cannot be greater than the width of the page.

Y position
The vertical distance of the top of the hidden area measured from the top of the logical page
(not the physical sheet of paper). Decimal values (such as 2.5) are allowed. The Y position
cannot be greater than the height of the page.

If you rotated the AFP file using the Rotate by 90 o option on the View menu, measure the X and
Y positions from the top-left corner of the page in the unrotated view.

6. To change the size of the hidden area, type new values in these fields.

Width
The horizontal width of the hidden area. Decimal values (such as 2.5) are allowed. The width
of the area cannot be greater than the width of the page.

Height
The vertical height of the hidden area. Decimal values (such as 2.5) are allowed. The height
of the area cannot be greater than the height of the page.

Measure the width and height from the origin of the hidden area in the unrotated view.

7. To change the placement of the hidden area, select one of these options:

• Page nn: Place the hidden area on page n of each page group (n is the page where you
drew the box for the hidden area). You cannot change this page number. If the page number
is incorrect, click Cancel and draw the box for the hidden area on the correct page.
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• Multiple pages: Place the hidden area on:

All pages
All pages in each page group

Even pages
The even pages in each page group (pages 2, 4, 6,...)

Odd pages
The odd pages in each page group (pages 1, 3, 5,...)

8. Click OK.
You do not see any text or image data in the hidden area in each page group.

9. To close the Modify and Delete Definitions window, click X in the upper right corner.

Deleting hidden areas

You can delete the hidden areas that were created with AFP Editor.

To delete a hidden area:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the hidden areas. Then clickMode→ AFP Editor.

2. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with a list of the hidden areas.

3. Select the hidden area that you want to delete.

4. Click Delete, or press the Delete key on your keyboard.
The hidden area is removed from the list. You see any data that the hidden area covered in the
AFP file.

5. To close the Modify and Delete Definitions window, click X in the upper right corner.

Modifying text strings

You can modify a string of text that was created with AFP Editor. You cannot modify text in the AFP file
itself.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify a text string:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for text strings.

2. ClickMode→ AFP Editor.

3. Click Tools→Modify Definitions.
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4. Do one of these:

• Select the text definition that you want to modify and then clickModify.

• Double-click the text definition that you want to modify.

You see the Modify Text String window.

5. OOppttiioonnaall:: On the Text tab, type a new name for the text area in the Text definition name field,
change data in the Text string data section, or change the color in the Color drop-down list.
To edit the text string, select a line of data and use Up or Down to change the order of the line
or Remove to delete the line. You can also add new values. Remember to add blank characters
between words if you need to. For example, to change the text string from "Page 1 of 10" to
"Page 1 for John Doe":

1. Press and hold the CTRL key, and then select of and Page Count.

2. Click Remove.

3. Type for in the Text field and click Add.

4. Select a customer index tag from the Index tag drop-down list and click Add.

You see the edited text string value in the field below the data fields.

6. OOppttiioonnaall:: On the Font tab, select one of these:

Core Fonts
From the drop-down lists, select the character set and code page, and, if the font is an outline
font, the point size in the Font Information section.

External Fonts
Type a character set and code page pair, a coded font name, or all three. For double-byte
character set (DBCS) fonts, use the coded font name only.

• If you enter a code page that is part of a DBCS-coded font, you see an error message
that suggests you use the coded font name instead.

You see the Character Set Description and Font Resource fields change for the font you
selected. Font Resource is "Outline" for core fonts and "Raster" for external fonts.

• On your workstation, if the font size does not exist for the color you selected, your display
defaults to 12 black, even though the final AFP file will have the correct font and color.

7. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner), size, and orientation of the
text area. Specify the origin and size in inches or millimeters. Decimal values (such as 2.5) are
allowed.

• If you rotated the AFP file using the Rotate by 90o option on the View menu, measure the X
and Y positions from the top-left corner of the logical page in the unrotated view.

8. Click OK.
You see the edited text in the AFP file.
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Deleting text strings

You can delete a string of text that was created with AFP Editor. You cannot delete text in the AFP file
itself (instead, you can create areas to hide text).

To delete a text string:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for text strings.

2. ClickMode→ AFP Editor.

3. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with a list of text strings.

4. Select the text string that you want to delete.

5. Click Delete, or press the Delete key on your keyboard.
The text string is removed from the list.

6. To close the Modify and Delete Definitions window, click X in the upper right corner.

Modifying text masks

You can modify any of the text mask definitions that were created with AFP Editor.

To modify a text mask:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the text masks. Then clickMode→ AFP Editor.

2. Click Tools→ Definitions→Modify and Delete.

3. Select the text mask that you want to modify.

4. ClickModify, or double-click.
You see the Modify Text Mask window.

5. Optional: Type another mask character if you do not want to use the default character. The value
in theMasked value field changes to the character you selected.

6. Optional: To edit the text mask value, click Edit text mask. Edit the value in the Edit Value
window and click OK.

7. Optional: Although text might appear to be present in the same location on each statement, slight
position variations can occur in the AFP file. To change the threshold to look for a text value that
is in slightly different positions on some pages, click the Advanced tab. You can select a range
from 1/100 to 1 inch.

The threshold defines how far the text can be from the original location and be considered a
mask value. For example, a threshold value of 12 indicates that the mask value can be located
within .12 of an inch either vertically or horizontally. Usually the default threshold value of 10 is
sufficient.
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Keep in mind that if you increase the threshold above the default value, you might mask text you
did not expect because the match is only done on location, so the first text block found in the
threshold range is used as the text mask.

8. Click OK.

9. To close the Modify and Delete Definitions window, click X in the upper right corner.

Deleting text masks

You can delete the text masks that were created with AFP Editor.

To delete a text mask:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the text masks. Then clickMode→ AFP Editor.

2. Click Tools→ Definitions.
You see the Modify and Delete Definitions window with a list of the text masks.

3. Select the text mask that you want to delete.

4. Click Delete, or press the Delete key on your keyboard.
The text mask is removed from the list.

5. To close the Modify and Delete Definitions window, click X in the upper right corner.

Editing text for text masks

When you create or modify a text mask, you can edit the text value.

When you edit a text value, make sure that you edit it so that it is appropriate for all page groups
because the text values can be different in each page group.

To edit the text for a text mask:

1. On the Edit Value window, select On for one or more of these options:
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Edit by stripping
characters

Type one character or a blank that you want to remove from the value.
Remember that the character is case-sensitive. Then, select one of these
buttons:

Strip leading characters
The specified character is removed from the beginning of the value. For
example, if you type a blank character, all blanks are removed from the
beginning of the value.

Strip trailing characters
The specified character is removed from the end of the value. For
example, if you type a blank character, all blanks are removed from the
end of the value.

Strip leading and trailing characters
The specified character is removed from the beginning and end of the
value. For example, if you type a blank character, all blanks are
removed from the beginning and end of the value.

Strip all characters
The specified character is removed from all positions in the value. For
example, an account number is: 324-1443255-11. You can type a -
to strip all - characters from the value.

Edit on delimiter Type a text string of one or more characters or blanks in the Specify
delimiter string field to indicate where the text value is split into separate
strings. Remember that the text is case-sensitive. Then select numbers for
Select first string and Select number of strings to mark the beginning
and end of the edited text.

For example, an account number is: 324-1443255-11. You can use - as
the delimiter to split the value into these three strings: 324, 1443255, and
11. To select the second and third strings, 1443255-11, select 2 for both
Select first string and Select number of strings.

Edit on character Select numbers for Select first character position and Select number of
characters to indicate the first character in the text value and how many
characters are included.

When you select the options in the window, the text value for the current page group is edited
based on your selections and the new value is displayed in the Edited text field.

2. Click OK.
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66.. Adding content to white space in AFP files

•Creating definitions for known white space
•Creating definitions by searching for white space
•Modifying or deleting white space definitions
•Assigning content to white space

Whitespace Manager can find areas of available white space in AFP files and then fill the white space
with content, such as images or text.

You can define white space in AFP files by choosing known white space on a page or by searching for
the first available white space in a page group. You can also modify or delete any white space
definitions you have created. After white space is defined, you can assign image and text content to the
white space areas by creating rules that determine what content is assigned and under what conditions
it is assigned.

CCrreeaattiinngg ddeeffiinniittiioonnss ffoorr kknnoowwnn wwhhiittee ssppaaccee
You can create a definition for white space that you know exists on the same page in all page groups.

Areas with overlays, page segments, barcodes, and images are considered available white space and
you can create a white space definition over them. However, this is not recommended unless you want
the content to merge with the existing content.

The white space area is only defined on the current page of the page group.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create a known white space definition:

1. In AFP Visual Environment, open a sample AFP file.

2. If the file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→Whitespace Manager.

4. Select the page in the page group where you want to define white space.

5. Position your cursor at a corner of the area where you want to define white space. While
pressing the left mouse button, draw a box the approximate size of the white space area. You
can draw a horizontal, vertical, or square box.

In a later step, you can specify the exact position and size of the white space area.

6. Right-click anywhere on the page and click Using known white space.
If a white space area is already defined on the page, you see an error message. Otherwise, you
see theWhite space tab in the Using known white space window with the page you selected
displayed in the Current Page field.

7. Type a name for the white space definition.

Give the definition a descriptive name to distinguish it from other definitions.

8. From the drop-down list, select which page you want the white space area added to:

This page
Adds the white space area to the current page.
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Last page
Adds the white space area to the last page. You can only select this option if the current page
is the last page in the page group. You might want to create a Last page definition instead of
This page when the page groups contain a variable number of pages and you want the
white space to always be on the last page.

If a selection is grayed-out, it is the only one available.

9. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) and size (width and height) of
the white space area in inches or millimeters. Decimal values (such as 2.5) are allowed.

Fields on the Position tab, p. 128 shows the fields on the Position tab.

FFiieellddss oonn tthhee Position ttaabb

Field Value Description

Origin of area: X
position

Any decimal
value, such as
2.5. The X
position cannot
be greater than
the width of the
page.

The horizontal distance (in inches or millimeters) of the
left side of the white space area measured from the left
side of the logical page (not the physical sheet of
paper).

If you rotated the AFP file using the Rotate by 90o
option on the View menu, specify the X position from
the top-left corner of the logical page in the unrotated
view.

Origin of area: Y
position

Any decimal
value, such as
2.5. The Y
position cannot
be greater than
the height of the
page.

The vertical distance (in inches or millimeters) of the top
of the white space area measured from the top of the
logical page (not the physical sheet of paper).

If you rotated the AFP file using the Rotate by 90o
option on the View menu, specify the Y position from
the top-left corner of the logical page in the unrotated
view.

Size of area:
Width

Any decimal
value, such as
2.5. The width of
the area cannot
be greater than
the width of the
page.

The horizontal width (in inches or millimeters) of the
white space area measured in the unrotated view.

Size of area:
Height

Any decimal
value, such as
2.5. The height
of the area
cannot be
greater than the
height of the
page.

The vertical height (in inches or millimeters) of the white
space area measured in the unrotated view.
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10. Click OK.
You see the defined white space area displayed as a colored box.

11. Verify that the correct white space area has been defined:

1. In the bottom pane, click theWhite spaces tab.

2. Expand a page group and double-click the white space definition.
You see a rectangle box highlighting the white space area on the page you selected.

3. If the white space area is incorrect, modify or delete it (Tools→Modify Definitions).

12. OOppttiioonnaall:: To create another white space definition, go to step and repeat the steps.

CCrreeaattiinngg ddeeffiinniittiioonnss bbyy sseeaarrcchhiinngg ffoorr wwhhiittee ssppaaccee
When you do not know where white space exists, you can search for the first available white space in a
page group and create a definition. Whitespace Manager searches for the largest white space area on
a page that meets the minimum dimensions specified.

When Whitespace Manager finds white space that meets the specifications on that page, it stops the
search.

Areas with overlays, page segments, barcodes, and images are considered available white space and
you can create a white space definition over them. However, this is not recommended unless you want
the content to merge with the existing content.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create a definition for the first available white space in a page group:

1. In AFP Visual Environment, open a sample AFP file.

2. If the file does not contain page groups, use AFP Indexer to create page groups.

3. ClickMode→Whitespace Manager.

4. Select a page in the page group.

5. Position your cursor at a corner of the area where you want to define white space. While
pressing the left mouse button, draw a box the approximate size of the white space area. You
can draw a horizontal, vertical, or square box.

In a later step, you can specify the exact position and size of the white space area.

6. Right-click anywhere on the page and click Searching for white space.
If the maximum number of white space areas are defined, you see an error message. Otherwise,
you see theWhite space tab in the Searching for white space window with the page you
selected displayed in the Current Page field.

7. Type a name for the white space definition.

Make sure you give the definition a descriptive name to distinguish it from other definitions.

8. Specify the minimum width and height for the white space area.

Whitespace Manager searches for the first available white space that meets the minimum
specified dimensions. The fields are:
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Width
Any decimal value, such as 0.75, for the horizontal width (in inches or millimeters) of the
white space area. The minimum width of the area can be equal to or greater than 0.5 inches
or 12.7 millimeters.

Height
Any decimal value, such as 0.75, for the vertical height (in inches or millimeters) of the white
space area. The minimum height of the area can be equal to or greater than 0.5 inches or
12.7 millimeters.

9. From the drop-down list in the Select Pages in the Page Group section, select which page or
pages you want the white space area added to:

This page
Adds the white space area to the current page unless a known white space area is defined or
no white space area meets the specified dimensions.

This and following pages
Searches the current page and all pages that follow in the page group and adds the white
space area on the first page where it finds white space that meets the specified dimensions.

Last page
Adds the white space area to the last page unless a known white space area is defined or no
white space area meets the specified dimensions. You can only select this option if the current
page is the last page in the page group. You might want to create a Last page definition
instead of This page when the page groups contain a variable number of pages and you
want the white space to always be on the last page.

If a selection is grayed-out, it is the only one available.

10. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) and size (width and height) of
the white space area.

Fields on the Position tab, p. 130 shows the fields on the Position tab.

FFiieellddss oonn tthhee Position ttaabb

Field Value Description

Origin of area: X
position

Any decimal
value, such as
2.5. The X
position cannot
be greater than
the width of the
page.

The horizontal distance (in inches or millimeters) of the
left side of the white space area measured from the left
side of the logical page (not the physical sheet of
paper).

If you rotated the AFP file using the Rotate by 90o
option on the View menu, specify the X position from
the top-left corner of the logical page in the unrotated
view.

Origin of area: Y
position

Any decimal
value, such as
2.5. The Y
position cannot

The vertical distance (in inches or millimeters) of the top
of the white space area measured from the top of the
logical page (not the physical sheet of paper).
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Field Value Description

be greater than
the height of the
page. If you rotated the AFP file using the Rotate by 90o

option on the View menu, specify the Y position from
the top-left corner of the logical page in the unrotated
view.

Size of area:
Width

Any decimal
value, such as
2.5. The width of
the area cannot
be greater than
the width of the
page.

The horizontal width (in inches or millimeters) of the
white space area measured in the unrotated view.

Size of area:
Height

Any decimal
value, such as
2.5. The height
of the area
cannot be
greater than the
height of the
page.

The vertical height (in inches or millimeters) of the white
space area measured in the unrotated view.

11. Click OK.
You see the defined white space area displayed as a colored box.

12. Verify that the correct white space area has been defined:

1. In the bottom pane, click theWhite spaces tab.

2. Expand a page group and double-click the white space definition.
You see a rectangle box highlighting the white space area on the page you selected.

3. If the white space area is incorrect, modify or delete it (Tools→Modify Definitions).

13. OOppttiioonnaall:: Optional: To create another white space definition, go to Step 4 and repeat the steps.

MMooddiiffyyiinngg oorr ddeelleettiinngg wwhhiittee ssppaaccee ddeeffiinniittiioonnss
After you define white space areas in an AFP file, you can modify or delete any of the definitions.

Modifying known white space definitions

You can modify a definition for white space that you know exists on a page.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

Modifying or deleting white space definitions
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To modify a known white space definition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for white space.

2. ClickMode→Whitespace Manager.

3. Click Tools→Modify Definitions.

4. Do one of these:

• Select a known white space definition and then clickModify.

• Double-click the known white space definition that you want to modify.

You see the Using known white space window. The Current Page field displays the page in the
page group where the white space was created. If theWhich Page field is grayed-out, you
cannot change it.

5. OOppttiioonnaall:: On theWhite space tab, type a new name for the white space area in the Definition
name field and select a page option from theWhich Page drop-down list if it is available.

6. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) and size (width and height) of
the white space area.

7. Click OK.

Modifying white space defined from a search

You can modify white space that you defined from a search.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify white space defined from a search:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for white space.

2. ClickMode→Whitespace Manager.

3. Click Tools→Modify Definitions.

4. Do one of these:

• Select a white space definition created from a search and then clickModify.

• Double-click the white space definition from a search that you want to modify.

You see the Searching for white space window. The Current Page field displays the page in the
page group where the white space was created. If theWhich Page field is grayed-out, you
cannot change it.

5. OOppttiioonnaall:: On theWhite space tab:

• Type a new name for the white space area in the Definition name field.
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• Change the minimum width and height for the white space area. Whitespace Manager
searches for the first available white space that meets the minimum specified dimensions.

• Select a page option from theWhich Page drop-down list if it is available.

6. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) and size (width and height) of
the white space area.

7. Click OK.

Deleting white space definitions

You can delete the white space definitions that were created with Whitespace Manager.

Deleting a white space definition also deletes any rules created for the definition in the Manage
Campaigns window. Make sure you no longer need the rules before deleting a white space definition.

To delete a white space definition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the definitions
for the white space.

2. ClickMode→Whitespace Manager.

3. Click Tools→Modify Definitions.
You see the Modify and Delete Definitions window with definitions of white space from a search
and known white space.

4. Select the white space definition that you want to delete.

5. Click Delete, or press the Delete key on your keyboard.
The white space definition is removed from the list. Any rules created for the white space
definition are also deleted.

6. To close the Modify and Delete Definitions window, click X in the upper right corner.

AAssssiiggnniinngg ccoonntteenntt ttoo wwhhiittee ssppaaccee
You can assign image and text content to defined white space areas by creating rules that determine
what content is assigned and under what conditions it is assigned.

You must create one or more white space definitions before you can assign content.

Creating rules for assigning content

You create one or more rules for assigning content to white space so you can target the content for
specific customers or for the best use of available space.

You must create one or more white space definitions before you can assign content. Also, index tags
you want to use as conditions in rules must exist in page groups. You can use AFP Indexer to create
index tags.

Assigning content to white space
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• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To create rules for assigning content to white space:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains white space
definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Select a white space definition from the list in the top pane of the window.

5. Click Create rules/content.
The default rule Always is displayed and highlighted below the white space definition. Always
means that the content is assigned to the white space with no restrictions.

6. Optional: Specify one or more conditions if you want a rule other than Always:

1. Click Create in the Conditions section.
You see the Create Condition window.

2. Select an index tag and operator from the drop-down lists, type a value, and then click OK.
The Always rule is replaced with the condition you created.

3. Optional: Click Create to create another condition for the rule.
You see the Create Condition window.

1) Select an index tag and operator from the drop-down lists, type a value, and then click
OK. The condition you created is added to the rule with the And operator between
conditions.

2) Optional: Click Or in the Combine conditions section to change the operator from the
default And. The rule is displayed with Or as the operator between conditions.

7. Specify the content that is assigned when the rule is true:

1. Click Insert text to assign text. You see the Insert Text window.

1) Define the text string data and the text color on the Text tab.

2) Optional: Change the text font on the Font tab.

3) Optional: Adjust the text position in the white space area on the Position tab.

4) Click OK.

5) Optional: Repeat the steps to add more text.

2. Click Insert image to assign an image. You see the Insert Image window.

1) On the Image tab, specify the image type, file name, and whether the image is added
inline. If the file type is JPEG or GIF, specify the width and height of the image.

2) Optional: Adjust the image position in the white space area on the Position tab.

3) Click OK.

4) Optional: Repeat the steps to add another image.
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3. OOppttiioonnaall:: Click Preview to view how the text and images you created are displayed in the
defined white space.

You see the If Content Preview window. To close the window, click the X in the upper right
corner.

8. OOppttiioonnaall:: Specify the content that is assigned when the rule is false.

This section is not available when the rule is Always.

1. Click Insert text to assign text. You see the Insert Text window.

1) Define the text string data and the text color on the Text tab.

2) Optional: Change the text font on the Font tab.

3) Optional: Adjust the text position in the white space area on the Position tab.

4) Click OK.

5) Optional: Repeat the steps to add more text.

2. Click Insert image to assign an image. You see the Insert Image window.

1) On the Image tab, specify the image type, file name, and whether the image is added
inline. If the file type is JPEG or GIF, specify the width and height of the image.

2) Optional: Adjust the image position in the white space area on the Position tab.

3) Click OK.

4) Optional: Repeat the steps to add another image.

3. OOppttiioonnaall:: Click Preview to view how the text and images you specified are displayed in the
defined white space.

You see the Else Content Preview window. To close the window, click the X in the upper right
corner.

9. OOppttiioonnaall:: To create another rule, go to Step 4 and repeat the steps.

10. Click OK.

Inserting content text

You can define the text you want inserted as white space content.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To define the text you want inserted as content:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.
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4. Do one of these:

• Select an existing rule from the list in the top pane of the window.

• Select a white space definition from the list in the top pane of the window and then click
Create rules/content to create a new rule.

5. Click Insert text in the Content section.
You see the Insert Text window.

6. On the Text tab, create a text string.
Remember to add blank characters between words if you need to. For example, to add the page
number, such as "Page 1 of 10", to the first page of each page group:

1. Type Page and a space in the Text field and click Add.

2. Select Page in Page Group from the Property drop-down list and click Add. Page in
Page Group is the number of the page in the page group.

3. Type a space, of, and another space in the Text field and click Add.

4. Select Page Group Page Count from the Property drop-down list and click Add. Page
Group Page Count is the total number of pages in the page group.

You see the text string value in the field below the data fields.

7. OOppttiioonnaall:: To edit the text string, select a line of data and use Up or Down to change the order
of the line or Remove to delete the line.
Remember to add blank characters between words if you need to.

8. Optional: Select a color for the text from the Color drop-down list.

9. Optional: On the Font tab, select one of these:

Core Fonts
From the drop-down lists, select the character set and code page, and, if the font is an outline
font, the point size in the Font Information section.

External Fonts
Type a character set and code page pair, a coded font name, or all three. For double-byte
character set (DBCS) fonts, use the coded font name only.

• If you enter a code page that is part of a DBCS-coded font, you see an error message
that suggests you use the coded font name instead.

You see the Character Set Description and Font Resource fields change for the font you
selected. Font Resource is "Outline" for core fonts and "Raster" for external fonts.

• On your workstation, if the font size does not exist for the color you selected, your display
defaults to 12 black, even though the final AFP file will have the correct font and color.

10. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) of the text area. Specify the
origin in inches or millimeters. Decimal values (such as 2.5) are allowed. The fields are:

X position
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The horizontal distance of the left side of the area measured from the left side of the text area.

Y position
The vertical distance of the top of the area measured from the top of the text area.

11. Click OK.
The text is added to the rule and the list in the drop-down box.

12. OOppttiioonnaall:: Click Preview to view how the text you specified is displayed in the defined white
space.

To close the window, click the X in the upper right corner.

Inserting content images

You can define the images you want inserted as white space content.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To define the images you want inserted as content:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Do one of these:

• Select an existing rule from the list in the top pane of the window.

• Select a white space definition from the list in the top pane of the window and then click
Create rules/content to create a new rule.

5. Click Insert image in the Content section.
You see the Insert Image window.

6. On the Image tab, do these:

• Select the file type in the Type drop-down list. If the file type is JPEG or GIF, you must specify
the size of the image in these fields:

Width
Any positive decimal value, such as 0.75, for the horizontal width (in inches or
millimeters) of the image. The default width is 0.5 inches or 12.7 millimeters.

Height
Any positive decimal value, such as 0.75, for the vertical height (in inches or millimeters)
of the image. The default height is 0.5 inches or 12.7 millimeters.

• Type a file name in the Image file name field, or click Browse to select a file.
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• Optional: Click Add image inline to add the image to the resource group in the AFP file.

7. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) of the image area. Specify the
origin in inches or millimeters. Decimal values (such as 2.5) are allowed. The fields are:

X position
The horizontal distance of the left side of the area measured from the left side of the image
area.

Y position
The vertical distance of the top of the area measured from the top of the image area.

8. Click OK.
The image is added to the rule and the list in the drop-down box.

9. OOppttiioonnaall:: Click Preview to view how the image you specified is displayed in the defined white
space.

To close the window, click the X in the upper right corner.

10. Click OK.
If you added the image inline, you see the image listed in the inline resource group in the left
pane.

Modifying content text

You can modify the text you have defined for white space content.

In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify text you have defined in content:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Select a rule from the list in the top pane of the window.

5. Select text content from the drop-down list.

6. Click Edit in the Content section.
You see the Modify Text window.

7. Optional: On the Text tab, change data in the Text string data section, change the color in the
Color drop-down list, or both.
To edit the text string, select a line of data and use Up or Down to change the order of the line
or Remove to delete the line. You can also add new values. Remember to add blank characters
between words if you need to. For example, to change the text string from "Page 1 of 10" to
"Page 1 for John Doe":
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1. Press and hold the CTRL key, and then select of and Page Count.

2. Click Remove.

3. Type for in the Text field and click Add.

4. Select an index tag that contains the customer name (such as John Doe) from the Index tag
drop-down list and click Add.

You see the edited text string value in the field below the data fields.

8. OOppttiioonnaall:: On the Font tab, select one of these:

Core Fonts
From the drop-down lists, select the character set and code page, and, if the font is an outline
font, the point size in the Font Information section.

External Fonts
Type a character set and code page pair, a coded font name, or all three. For double-byte
character set (DBCS) fonts, use the coded font name only.

• If you enter a code page that is part of a DBCS-coded font, you see an error message
that suggests you use the coded font name instead.

You see the Character Set Description and Font Resource fields change for the font you
selected. Font Resource is "Outline" for core fonts and "Raster" for external fonts.

• On your workstation, if the font size does not exist for the color you selected, your display
defaults to 12 black, even though the final AFP file will have the correct font and color.

9. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) of the text area. Specify the
origin in inches or millimeters. Decimal values (such as 2.5) are allowed.

10. Click OK.
You see the edited text.

11. OOppttiioonnaall:: Click Preview to view how the text you specified is displayed in the defined white
space.

To close the window, click the X in the upper right corner.

Modifying content images

You can modify the images you have defined for white space content.

• In AFP Visual Environment you can display measurement units in inches or millimeters. To change the
measurement unit, click View→ Units.

To modify images you have defined in content:
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1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Select a rule from the list in the top pane of the window.

5. Select image content from the drop-down list.

6. Click Edit in the Content section.
You see the Modify Image window.

7. Optional: On the Image tab, you can do these:

• Change the file type in the Type drop-down list. If the file type is JPEG or GIF, you must
specify the size of the image in these fields:

Width
Any positive decimal value, such as 0.75, for the horizontal width (in inches or
millimeters) of the image. The default width is 0.5 inches or 12.7 millimeters.

Height
Any positive decimal value, such as 0.75, for the vertical height (in inches or millimeters)
of the image. The default height is 0.5 inches or 12.7 millimeters.

• Type a file name in the Image file name field, or click Browse to select a file.

• Click Add image inline to add the image to the resource group in the AFP file.

8. OOppttiioonnaall:: On the Position tab, change the origin (top-left corner) of the image. Specify the
origin in inches or millimeters. Decimal values (such as 2.5) are allowed.

9. Click OK.

10. OOppttiioonnaall:: Click Preview to view how the image you specified is displayed in the defined white
space.

To close the window, click the X in the upper right corner.

Creating rule conditions for content

You can create rule conditions that determine when content is assigned to white space.

To create a rule condition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Do one of these:

• Select an existing rule from the list in the top pane of the window.
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• Select a white space definition from the list in the top pane of the window and then click
Create rules/content to create a new rule.

5. Click Create in the Conditions section.
You see the Create Condition window.

6. Use the drop-down list to select an index tag in the Index tags field.

7. Use the drop-down list to select one of these in the Operator field:

• greater than

• less than

• equals

• contains

8. Type a value in the Value field.

9. Click OK.
The condition you created is added to the rule.

10. Optional: Click Create to create another condition for the rule.
The condition you created is added to the rule with the And operator between conditions.

11. Optional: Click Or in the Combine conditions section to change the operator from the default
And. The rule is displayed with Or as the operator between conditions.

12. Click OK.

Modifying rule conditions for content

You can modify rule conditions that determine when content is assigned to white space.

To modify a rule condition:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Select an existing rule from the list in the top pane of the window.

5. Click Edit in the Conditions section.
You see the Edit Condition window.

6. OOppttiioonnaall:: Use the drop-down list to change the index tag in the Index tags field.

7. OOppttiioonnaall:: Use the drop-down list to change to one of these in the Operator field:

• greater than

• less than

• equals

• contains
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8. OOppttiioonnaall:: Change the value in the Value field.

9. Click OK.
The condition you edited is modified in the rule.

10. Optional: Click Or or And in the Combine conditions section to change the operator between
conditions. The rule is displayed with the operator you selected.

11. Click OK.

Deleting content from white space

You can delete rules, conditions, and content that you have assigned to white space definitions.

To delete rules, conditions, or content:

1. In AFP Visual Environment, open a sample AFP file and the control file that contains the white
space definitions.

2. ClickMode→Whitespace Manager.

3. Click Tools→Manage Campaigns.
You see the Manage Campaigns window.

4. Select a rule from the list in the top pane of the window.

5. Optional: To delete conditions:

1. Select a condition from the drop-down list.

2. Click Delete in the Conditions section.
You see that the condition has been removed from the rule.

3. Repeat the steps to delete another condition in the rule.
If you delete all the conditions, the rule defaults to Always.

6. Optional: To delete content:

1. Select content from the drop-down list.

2. Click Delete in the Content section.
You see that the content has been removed from the rule.

3. Repeat the steps to delete more content from the rule.

7. Optional: To delete a rule and all its conditions and content, click Delete in the top pane.
You see that the rule has been removed from the list.

8. Optional: To delete another rule or the conditions or content for a rule, go to Step 4 and repeat
the steps.

9. Click OK.
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77.. Enhancing production AFP files

•Sending AFP Visual Environment files to the production system
•Creating page groups and indexes in production AFP files
•Creating hidden areas, bar codes, and text masks in production AFP files

After you enhance a sample AFP file, run an AFP Visual Environment command to enhance production
AFP files in the same way.

The AFP Visual Environment commands use the control file that the AFP Visual Environment user interface
created when you enhanced the sample AFP file. If the commands run on a different system than the
preparation system, you must first send the control file and other optional AFP Visual Environment files to
the production system.

SSeennddiinngg AAFFPP VViissuuaall EEnnvviirroonnmmeenntt ffiilleess ttoo tthhee pprroodduuccttiioonn ssyysstteemm
If the production AFP files are on a different system from the preparation system, send the AFP Visual
Environment control file and other optional AFP Visual Environment files to the production system.

To send AFP Visual Environment files to the production system:

1. On the preparation system, use the File Transfer Program (ftp) to send the AFP Visual Environment
control files to the production system. Use the ftp binary option.

2. Optional: If you created AFP Visual Environment font-mapping files, on the preparation system
use ftp to send the font-mapping files to a directory on the production system. Use the ftp binary
option.

3. Optional: If you created IMB serial number files, use ftp to send the serial number files to the
production system. Use the ftp binary option.

CCrreeaattiinngg ppaaggee ggrroouuppss aanndd iinnddeexxeess iinn pprroodduuccttiioonn AAFFPP ffiilleess
The IndexAFP command creates page groups and index tags in production AFP files. It uses the AFP
Visual Environment control file that contains the definitions for the page groups and index tags.

IndexAFP applies the definitions that create page groups and index tags to an AFP file that contains
MO:DCA-P data and writes the result to another AFP file. You can run IndexAFP directly, or you can use
the PluginMgr command to run IndexAFP. If the control file also contains definitions to create hidden
areas and bar codes, it is more efficient to run PluginMgr because it can run IndexAFP and EditAFP at
the same time.

To create page groups and indexes in production AFP files:

1. Do one of these:

• Run the IndexAFP command. For example:

– AIX:

java -jar /install_directory/plugins/IndexAFP/IndexAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

– Windows:

java -jar C:\install_directory\plugins\IndexAFP\IndexAFP.jar
-i C:\directory\infile.afp -o C:\directory\outfile.afp
-c C:\directory\infile.ctl
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– z/OS UNIX:

java -jar /install_directory/plugins/IndexAFP/IndexAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

• Run the PluginMgr command. For example:

– AIX:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

– Windows:

java -jar C:\install_directory\PluginMgr.jar
-i C:\directory\infile.afp -o C:\directory\outfile.afp
-c C:\directory\infile.ctl

– z/OS UNIX:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

For install_directory, use the directory where you installed AFP Visual Environment.

For directory, use the directory where the file is located.

2. If the return code from IndexAFP or PluginMgr is <0, look in stderr or the log for error messages.

3. Repeat the command for each production AFP file.

CCrreeaattiinngg hhiiddddeenn aarreeaass,, bbaarr ccooddeess,, aanndd tteexxtt mmaasskkss iinn pprroodduuccttiioonn
AAFFPP ffiilleess
The EditAFP command hides areas, creates bar codes, and masks text in production AFP files. It uses the
AFP Visual Environment control file that contains definitions for the hidden areas, bar codes, and text
masks.

EditAFP applies the definitions for hidden areas, bar code, and text masks to an AFP file and writes the
result to another AFP file. You can run EditAFP directly, or you can use the PluginMgr command to run
EditAFP. If the control file also contains definitions to create page groups and index tags, it is more
efficient to run PluginMgr because it can run IndexAFP and EditAFP at the same time.

To create hidden areas and bar codes in production AFP files:

1. Optional: If the production system is different from the preparation system, use the File Transfer
Program (ftp) to send the control file, font-mapping files (if any), and IMB serial number file (if
any) to the production system.

Use the ftp binary option.

2. Do one of these:

• Run the EditAFP command. For example:

– AIX:
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java -jar /install_directory/plugins/EditAFP/EditAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

– Windows:

java -jar \install_directory\plugins\EditAFP\EditAFP.jar
-i \directory\infile.afp -o \directory\outfile.afp
-c \directory\infile.ctl

– z/OS UNIX:

java -jar /install_directory/plugins/EditAFP/EditAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

• Run the PluginMgr command. For example:

– AIX:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

– Windows:

java -jar \install_directory\PluginMgr.jar
-i \directory\infile.afp -o \directory\outfile.afp
-c \directory\infile.ctl

– z/OS UNIX:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

For install_directory, use the directory where you installed AFP Visual Environment.

For directory, use the directory where the file is located.

3. If the return code from EditAFP or PluginMgr is <0, look in stderr or the log for error messages.

4. Run the command again for each production AFP file.
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88.. AFP Visual Environment commands

•EditAFP command
•IndexAFP command
•PluginMgr command

AFP Visual Environment commands apply the definitions in an AFP Visual Environment control file to
production AFP files. These commands can run on IBM AIX, IBM z/OS, and Microsoft Windows
systems.

EEddiittAAFFPP ccoommmmaanndd
EditAFP hides areas, creates bar codes, and masks text in a production AFP file and writes the output to
another file. The bar codes, hidden areas, and text masks must be defined in an AFP Visual Environment
control file. This command is available only if AFP Editor is installed.

Format

EEddiittAAFFPP -c controlfile [-cp codepage] [-fontMapDir fontmapdirectory]
-i inputfile [-log] -o outputfile [-resDir resourcedirectories]
[-snf serialfile[ :barcodedefinition] [-threads nn][-tracetracefile]
[-trclvl level][-ue userexit] [-version]

Brackets indicate that the option is not required. Do not type any brackets when you enter the
command.

Options

-c ccoonnttrroollffiillee
The full path name of the AFP Visual Environment control file that contains the page group and index
tag definitions. This option is required.

-cp ccooddeeppaaggee
The default code page. This option is not required.

Values for codepage are:

IB-
M500

An EBCDIC code page (default).

IB-
M850

An ASCII code page.

-fontMapDir ffoonnttmmaappddiirreeccttoorryy
The full path name of the directory that contains customized font-mapping files, which override the
default font-mapping files. This option is not required. If it is not specified, only the default font-
mapping files are used.

-i iinnppuuttffiillee
The full path name of the input AFP file that you want to process. The input file must contain MO:
DCA-P data with no line data. This option is required.

-log



8

148

EditAFP writes messages to the edit.log file in the directory where the EditAFP.jar file is
located. If the file exists, EditAFP appends messages to it. This option is not required. If it is not
specified, EditAFP writes messages only to the terminal.

-o oouuttppuuttffiillee
The full path name of the file where the output AFP file is written. Any existing data in the file is
overwritten. This option is required.

-resDir rreessoouurrcceeddiirreeccttoorryy ;...
The full path names of one or more AFP resource directories that contain AFP resources. EditAFP
looks for AFP resources in these resource directories before the resource directories identified to AFP
Visual Environment when the control file was created. This option is not required.

Specify this option if AFP resources are not inline and are not in the same directories that you
identified to AFP Visual Environment when the control file was created.

Separate multiple directories with a semicolon. If a resource directory path name contains a blank,
enclose the path name in double quotation marks.

-snf sseerriiaallffiillee[ :bbaarrccooddeeddeeffiinniittiioonn] ;...
The name of the Intelligent Mail bar code (IMB) serial number file and the name of the bar code
definition in the control file that the serial number file applies to. This option is not required. If it is not
specified, EditAFP uses the serial number file that was specified in the bar code definition when the
control file was created. If you specify more than one serial number file and bar code definition
name, separate them with a semicolon as shown in “Examples”.

sseerriiaallffiillee

The full path name of the serial number file.

bbaarrccooddeeddeeffiinniittiioonn

The name of the bar code definition. This name is optional. If no bar code definition name is
specified, the serial number file is used for all IMBs in the AFP file. If the bar code definition
name contains blanks or other special characters, enclose the name in double quotation
marks.

Examples:
AIX or Linux:
-snf /directory/serialfile
-snf /directory/tofile:"to IMB"
-snf /directory/tofile:"to IMB";/directory/replyfile:"reply IMB"Windows:
-snf C:\directory\serialfile
-snf C:\directory\tofile:"to IMB"
-snf C:\directory\tofile:"to IMB";\directory\replyfile:"reply IMB"

-threads nnnn
The number of threads that EditAFP starts. This option is not required. The default is five threads.
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If the control file contains bar code definitions for IMBs that use a serial number file and you want
the serial numbers in the IMBs to be in sequential order by page group (for example, the serial
number in the first page group is 000001, the serial number in the second page group is 000002,
and so on) specify one thread. If you specify more than one thread, the serial numbers might not be
in sequential order by page group. No matter how many threads you specify, the serial number in
each IMB is unique.

Example: -threads 1

-trace ttrraacceeffiillee
The full path name of the file where EditAFP writes trace information. If the file already exists,
EditAFP appends to it. Otherwise, EditAFP creates the file. Use this option for diagnostic purposes
only. This option is not required.

-trclvl lleevveell
The level of tracing. This option is not required.

Values for level are:

debug
Trace at a higher level.

normal
Trace at a lower level (default).

-ue uusseerreexxiitt
The user exit class name. This option is not required.

-version

Displays the version number of EditAFP. This option is not required.

Examples–EditAFP
AIX: This example creates the hidden areas and bar codes defined in the infile.ctl control file and
writes the output to the outfile.afp file:

java -jar /install_directory/plugins/EditAFP/EditAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

Windows: This example creates the hidden areas and bar codes defined in the infile.ctl control
file and writes the output to the outfile.afp file:

java -jar \install_directory\plugins\EditAFP\EditAFP.jar
-i \directory\infile.afp -o \directory\outfile.afp
-c \directory\infile.ctl

z/OS: This example creates the hidden areas and bar codes defined in the infile.ctl control file
and writes the output to the outfile.afp file. Enter this command on the z/OS UNIX command line:

java -jar /install_directory/plugins/EditAFP/EditAFP.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

EditAFP command
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For install_directory, use the directory where you installed AFP Visual Environment.

For directory, use the directory where the file is located.

Exit codes

0
EditAFP was successful.

<0
EditAFP was not successful. No output file was created, or the output file is incomplete. EditAFP
writes error messages to stderr and in the log file.

IInnddeexxAAFFPP ccoommmmaanndd
IndexAFP creates page groups and index tags in a production AFP file and writes the output to another
file. The page groups and index tags must be defined in an AFP Visual Environment control file. This
command is available only if AFP Indexer is installed.

Format

IInnddeexxAAFFPP --cc controlfile [--ccpp codepage] [--ddooccIIddxx indexfile][--ffoonnttMMaappDDiirr fontmapdirectory] [--ffoorrmmDDeeff formdefinition] --ii inputfile [--lloogg]--oo outputfile [--rreessDDiirr resourcedirectories] [--rreessGGrrpp resourcegroupfile]
[--ssttaattss][--ttee triggerexit] [--tthhrreeaaddss nn] [--ttrraaccee tracefile] [--ttrrccllvvll level]
[--uuee userexit][--vveerrssiioonn]

• Brackets indicate that the option is not required. Do not type any brackets when you enter the
command.

Options

-c ccoonnttrroollffiillee
The full path name of the AFP Visual Environment control file that contains the page group and index
tag definitions. This option is required unless the -te option is specified.

-cp ccooddeeppaaggee

The default code page. This option is not required.

Values for codepage are:

IBM500
An EBCDIC code page (default).

IBM850
An ASCII code page.

-docIdx iinnddeexxffiillee

The full path name of the document index file that you want AFP Visual Environment to create. Any
existing data in the file is overwritten.

This option is not required. If it is not specified, the document index file is not created.

-fontMapDir ffoonnttmmaappddiirreeccttoorryy
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The full path name of the directory that contains customized font-mapping files, which override the
default font-mapping files.

This option is not required. If it is not specified, only the default font-mapping files are used.

-formDef ffoorrmmddeeffiinniittiioonn
The full path name of the form definition that contains the active medium map for the first page in
each page group. IndexAFP writes the name of the active medium map in the document index file,
and IndexAFP includes the form definition in the resource group file.

This option is not required. If this option is not specified, IndexAFP uses the medium map name in the
first inline form definition or, if no inline form definitions exist, in the first Invoke Medium Map (IMM)
structured field. If no inline form definitions or IMM structured fields exist, IndexAFP uses a null name
to indicate that the first medium map in the form definition is the active medium map for the first
page.

Example: -formDef F1USER10

-i iinnppuuttffiillee
The full path name of the input AFP file that you want to process. The input file must contain MO:
DCA-P data with no line data.

This option is required.

-log
IndexAFP writes messages to the index.log file in the directory where the IndexAFP.jar file is located.
If the file exists, IndexAFP appends messages to it.

This option is not required. If it is not specified, IndexAFP writes messages only to the terminal.

-o oouuttppuuttffiillee

The full path name of the file where the output AFP file is written. Any existing data in the file is
overwritten.

This option is required.

-resDir rreessoouurrcceeddiirreeccttoorryy;...
The full path names of one or more AFP resource directories that contain AFP resources. IndexAFP
looks for AFP resources in these resource directories before the resource directories identified to AFP
Visual Environment when the control file was created. This option is not required.

Specify this option if AFP resources are not inline and are not in the same directories that you
identified to AFP Visual Environment when the control file was created.

Separate multiple directories with a semicolon. If a resource directory path name contains a blank,
enclose the path name in double quotation marks.

-resGrp rreessoouurrcceeggrroouuppffiillee

The full path name of the resource group file that you want IndexAFP to create. Any existing data in
the file is overwritten. This option is not required. If it is not specified, IndexAFP does not create a
resource group file.

If IndexAFP cannot find a resource, it creates the resource file without the missing resource and
writes a message identifying the missing resource to stderr and in the log file.

-stats

IndexAFP command
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IndexAFP writes statistics to the terminal.

This option is not required.

-te ttrriiggggeerreexxiitt

The trigger exit class name.

This option is not required.

-threads nnnn
The number of threads that IndexAFP starts. The default is 5 threads.

This option is not required.

-trace ttrraacceeffiillee

The full path name of the file where IndexAFP writes trace information. If the file already exists,
IndexAFP appends to it. Otherwise, IndexAFP creates the file. Use this option for diagnostic
purposes only.

-trclvl lleevveell
The level of tracing. This option is not required.

Values for level are:

debug
Trace at a higher level.

normal
Trace at a lower level (default).

-ue uusseerreexxiitt

The user exit class name.

This option is not required.

-version
Displays the version number of IndexAFP.

This option is not required.

Examples–IndexAFP

AIX: This example creates page groups and index tags defined in the infile.ctl control file and
writes the output to the outfile.afp file:

java -jar /install_directory/plugins/IndexAFP/IndexAFP.jar-i /directory/infile.afp -o /directory/outfile.afp-c /directory/infile.ctl

Windows: This example creates page groups and index tags defined in the infile.ctl control file
and writes the output to the outfile.afp file:

java -jar \install_directory\plugins\IndexAFP\IndexAFP.jar-i \directory\infile.afp -o \directory\outfile.afp-c \directory\infile.ctl

z/OS: This example creates page groups and index tags defined in the infile.ctl control file and
writes the output to the outfile.afp file. Enter this command on the z/OS UNIX command line:

java -jar /install_directory/plugins/IndexAFP/IndexAFP.jar-i /directory/infile.afp -o /directory/outfile.afp-c /directory/infile.ctl
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For install_directory, use the directory where you installed AFP Visual Environment.

For directory, use the directory where the file is located.

Exit codes

0
IndexAFP was successful.

<0
IndexAFP was not successful. No output file was created, or the output file is incomplete. IndexAFP
writes error messages to stderr and in the log file.

PPlluuggiinnMMggrr ccoommmmaanndd
PluginMgr can run both the EditAFP and IndexAFP commands and write the output to an AFP file. Or,
PluginMgr can run only the command that you specify.

It is more efficient to use PluginMgr to run the EditAFP and IndexAFP commands at the same time than to
run them separately. However, if you want IndexAFP to create a resource group file, you must run the
IndexAFP command.

Format

PPlluuggiinnMMggrr -c controlfile [ -docIdx indexfile ] [-edit [ :options ;]]
[-fontMapDir fontmapdirectory] [-formDef formdefinition]
-i inputfile [ -index [ : options ; ] ] -o outputfile[-pluginDir plugindirectory ] [ -resDir resourcedirectories ] [-trace tracefile] [ -trclvl level ] [ -version ]

Brackets indicate that the option is not required. Do not type any brackets when you enter the
command.

Options

-c ccoonnttrroollffiillee
The full path name of the AFP Visual Environment control file that contains the page group and index
tag definitions. This option is required.

-docIdx iinnddeexxffiillee
The full path name of the document index file that you want AFP Visual Environment to create. Any
existing data in the file is overwritten. This option is not required. If it is not specified, the document
index file is not created.

-edit [ :ooppttiioonnss ;]
Indicates that PluginMgr is to run the EditAFP command, and specifies EditAFP options. Valid
EditAFP options are:

-snf sseerriiaallffiillee [ :bbaarrccooddeeddeeffiinniittiioonn] ;...
The name of the Intelligent Mail bar code (IMB) serial number file and the name of the bar code
definition in the control file that the serial number file applies to. If -snf is not specified, EditAFP
uses the serial number file that was specified in the bar code definition when the control file was
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created. If you specify more than one serial number file and bar code definition name, separate
them with a semicolon as shown in “Examples”.

sseerriiaallffiillee

The full path name of the serial number file.

bbaarrccooddeeddeeffiinniittiioonn

The name of the bar code definition. If no bar code definition name is specified, the serial
number file is used for all IMBs in the AFP file. If the bar code definition name contains
blanks or other special characters, enclose the name in double quotation marks.

-ue

The user exit class name.

If you specify EditAFP options, type a colon before the options and a semi-colon after the
options, as shown in “Examples”. If you do not specify any EditAFP options, do not type the
colon and semi-colon.

The -edit and -index options interract in this way:

• If neither -edit nor -index is specified, PluginMgr can run both IndexAFP and EditAFP,
depending on which definitions are in the control file. If the control file contains definitions
that AFP Indexer created, PluginMgr runs AFPIndex first because definitions that AFP Editor
created might depend on page groups and index tags that AFP Indexer created.

• If -edit is specified but not -index, PluginMgr runs only EditAFP.

• If -index is specified but not -edit, PluginMgr runs only IndexAFP.

Examples:
-edit
-edit:-snf /directory/serialfile;
-edit:-snf /directory/tofile:"to IMB";/directory/replyfile:"reply IMB";

-fontMapDir ffoonnttmmaappddiirreeccttoorryy
The full path name of the directory that contains customized font-mapping files, which override the
default font-mapping files. This option is not required. If it is not specified, only the default font-
mapping files are used.

-formDef ffoorrmmddeeffiinniittiioonn
The full path name of the form definition that contains the active medium map for the first page in
each page group. PluginMgr writes the name of the active medium map in the document index file
and includes the form definition in the resource group file.

This option is not required. If this option is not specified, PluginMgr uses the medium map name in
the first inline form definition or, if no inline form definitions exist, in the first Invoke Medium Map
(IMM) structured field. If no inline form definitions or IMM structured fields exist, PluginMgr uses a
null name to indicate that the first medium map in the form definition is the active medium map for
the first page.

Example: -formDef F1USER10

-i iinnppuuttffiillee
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The full path name of the input AFP file that you want to process. The input file must contain MO:
DCA-P data with no line data. This option is required.

-index [ :ooppttiioonnss ;]
Indicates that PluginMgr is to run the IndexAFP command, and specifies IndexAFP options. Valid
IndexAFP options are:

-te

The trigger exit class name.

-ue

The user exit class name.

If you specify IndexAFP options, type a colon before the options and a semi-colon after the options,
as shown in “Examples”. If you do not specify any IndexAFP options, do not type the colon and
semi-colon.

The -edit and -index options interract in this way:

• If neither -edit nor -index is specified, PluginMgr can run both IndexAFP and EditAFP,
depending on the definitions in the control file. If the control file contains definitions that AFP
Indexer created, PluginMgr runs AFPIndex first because definitions that AFP Editor created might
depend on page groups and index tags that AFP Indexer created.

• If -edit is specified but not -index, PluginMgr runs only EditAFP.

• If -index is specified but not -edit, PluginMgr runs only IndexAFP.

Examples:
-index
-index:-ue /directory/userexit;
-index:-ue /directory/userexit; -edit

-o oouuttppuuttffiillee
The full path name of the file where the output AFP file is written. Any existing data in the file is
overwritten. This option is required.

-pluginDir pplluuggiinnddiirreeccttoorryy
The full path name of the directory that contains the IndexAFP and EditAFP directories. Specify this
option only if you moved the IndexAFP and EditAFP directories to a different directory after
installation. This option is not required. If it is not specified, the default directory is ./plugins.

-resDir rreessoouurrcceeddiirreeccttoorryy ;...
The full path names of one or more AFP resource directories that contain AFP resources. PluginMgr
looks for AFP resources in these resource directories before the resource directories identified to AFP
Visual Environment when the control file was created. This option is not required.

Specify this option if AFP resources are not inline and are not in the same directories that you
identified to AFP Visual Environment when the control file was created.

Separate multiple directories with a semicolon. If a resource directory path name contains a blank,
enclose the path name in double quotation marks.

-trace ttrraacceeffiillee

PluginMgr command



8

156

The full path name of the file where PluginMgr writes trace information. If the file already exists,
PluginMgr appends to it. Otherwise, PluginMgr creates the file. Use this option for diagnostic
purposes only.

-trclvl lleevveell
The level of tracing. This option is not required.

Values for level are:

debug
Trace at a higher level.

normal
Trace at a lower level (default).

-version

Displays the version number of PluginMgr. This option is not required.

Examples–PluginMgr

AIX: This example applies all the definitions in the infile.ctl control file and writes the output to file
outfile.afp:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

Windows: This example applies all the definitions in the infile.ctl control file and writes the output
to file outfile.afp:

java -jar \install_directory\PluginMgr.jar
-i \directory\infile.afp -o \directory\outfile.afp
-c \directory\infile.ctl

z/OS: This example applies all the definitions in the infile.ctl control file and writes the output to
file outfile.afp. Enter this command on the z/OS UNIX command line:

java -jar /install_directory/PluginMgr.jar
-i /directory/infile.afp -o /directory/outfile.afp
-c /directory/infile.ctl

For install_directory, use the directory where you installed AFP Visual Environment.

For directory, use the directory where the file is located.

Exit codes

0 PluginMgr was successful.

<0 PluginMgr was not successful. No output file was created, or the output file is incomplete.
Error messages are written to stderr.
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99.. Configuration files

•Font mapping files
•IMB serial number file
•Document index file
•Resource group file

AFP Visual Environment configuration files let you customize font-mapping and specify the starting serial
number for Intelligent Mail bar codes (IMBs).

FFoonntt mmaappppiinngg ffiilleess
AFP Visual Environment lets you customize installation font-mapping files to map custom AFP fonts to
Java fonts. In the font-mapping files, you can also specify the default Java font that is used when an AFP
font is not mapped to a Java font.

AFP Visual Environment provides sample installation font-mapping files that you can edit.

CharacterSets.properties file

The CharacterSets.properties file maps an AFP character set to corresponding font attributes or an
AFP font global identifier (FGID) to a corresponding Java font name and style. You can add custom AFP
character sets to this file.

The sample file that you can edit is (AIX and Linux) or (Windows)CharacterSets.properties.

Purpose

The CharacterSets.properties file lets you specify which font attributes to use for custom AFP font
character sets or which FGIDs to use for Java fonts.

Format

Each line in the file has one of these formats:

•

characterset=fgid,height,width,strikeover,underline

For example:

C?H200A0=2304,110,73,0,0

•

fgid=name,style

For example:

2304=Lucinda Sans Regular,PLAIN

characterset
The 8-character identifier for the AFP character set. The second character in standard AFP character
set names indicates the character rotation. You can use a question mark (?) as a wildcard character
for the second character of the character set name. The ? means that the identifier applies to all
rotations.
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To change which Java font is used when an AFP character set is not mapped to a Java font, specify
DEFAULT for the identifier of the AFP character set. If DEFAULT is specified for more than one entry in
the file, the last entry is used.

fgid
A unique value in this range, 3840 to 4095 or 65260 to 65534, for the AFP font global identifier,
which indicates the type family, typeface, and sometimes the point size of the character set.

height
The vertical size of the character expressed in tenths of a point. For example, a 9-point font has a
height of 90. Valid values are whole numbers from 1 to 990.

name
The name of the corresponding Java font, such as: Lucida Bright, Lucida Sans Regular, or
Lucida Sans Typewriter.

strikeover
A font whose characters all have a line, parallel to the character baseline, placed over the middle
of the character. The values are 0=No and 1=Yes.

style
The style of the Java font. Valid values are: BOLD, BOLD|ITALIC, ITALIC, and PLAIN.

underline
A font whose characters all have a line, parallel to the character baseline, placed under the
character. The values are 0=No and 1=Yes.

width
The average horizontal size of the characters in 1440th of an inch. Valid values are whole numbers
from 1 to 99; however, the value is currently ignored.

Syntax rules

• Start each line in column one.

• A pound sign (#) in column one indicates the line is a comment.

• All values are case-sensitive.

• All parameters are positional.

• Blanks are not allowed unless the font name contains a blank (for example, Lucida Bright).

CodedFonts.properties file

The CodedFonts.properties file maps an AFP coded font to its AFP character set and AFP code
page.
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You can edit this file if you created or modified a code page or a character set and linked them in a
coded font or if you have a different code page and character set pair that you linked in a coded font.
The sample file that you can copy and edit is (AIX and Linux) or (Windows)CodedFonts.properties.

Purpose

The CodedFonts.properties file lets you specify the AFP coded font for custom AFP code pages and
character sets.

Format

Each line in the file has this format:

codedfont=characterset,codepage

For example:

X?H210AC=C?H200A0,T1V10500

codedfont
The identifier for the AFP coded font, which joins the character set and the code page. The second
character in standard AFP coded font names indicates the character rotation. You can use a
question mark (?) as a wildcard character for the second character of the coded font name. The ?
means that the identifier applies to all rotations.

To change which AFP character set and code page is used when an AFP coded font is not mapped
to an AFP character set and code page, specify DEFAULT for the identifier of the AFP coded font. If
DEFAULT is specified for more than one entry in the file, the last entry is used.

characterset
The 8-character identifier for the AFP character set. The second character in standard AFP character
set names indicates the character rotation. You can use a question mark (?) as a wildcard character
for the second character of the character set name. The ? means that the identifier applies to all
rotations.

codepage
The AFP code page name.

Syntax rules

• Start each line in column one.

• A pound sign (#) in column one indicates the line is a comment.

• All values are case-sensitive.

• All parameters are positional.

• Blanks are not allowed.

Font mapping files
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CodePages.properties file

The CodePages.properties file maps an AFP code page or a Java character set encoding to an AFP
code page global identifier (CPGID). You can add custom code pages to this file. The sample file that
you can edit is (AIX and Linux) or (Windows)CodePages.properties.

Purpose

The CodePages.properties file lets you specify which AFP code page global identifier (CPGID) to
use for custom AFP code pages or Java character sets.

Format

Each line in the file has this format:

name=cpgid,[DBCS|SBCS]

For example:

T1000259=259,SBCS

or

IBM500=259,DBCS

cpgid
The code page global identifier (CPGID) for the AFP code page or Java character set.

DBCS|SBCS
Optional indicator for double-byte character set (DBCS) or single-byte character set (SBCS). The
default is SBCS.

name
The AFP code page name or the Java character set name.

Syntax rules

• Start each line in column one.

• A pound sign (#) in column one indicates the line is a comment.

• All values are case-sensitive.

• All parameters are positional.

• Blanks are not allowed.

SampleCodePointMap.cp file

The SampleCodePointMap.cp file maps code points in a custom AFP code page to Unicode code
points. You can use this file to create a code point map file for each AFP code page that does not use
standard Unicode code points.
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The name of the file must contain the name of the code page. For example, if the code page name is
T1000259, name the file T1000259.cp. The sample file that you can edit and rename is (AIX and
Linux) or (Windows)SampleCodePointMap.cp.

Purpose

The SampleCodePointMap.cp file lets you map code points in a custom AFP code page to Unicode
code points so that AFP Visual Environment can display the text correctly. For example, the Unicode
code point for a space is hexadecimal “0020”. If the AFP code page uses a code point for a space,
such as hexadecimal “0040”, map code point “0040” to code point “0020”.

For charts showing Unicode code points, see http://unicode.org/charts/.

Format

Each line in the file has this format:

AFPcodepoint=Unicodecodepoint

For example:

0040 0020

AFPcodepoint
The hexadecimal code point in the custom AFP font.

Unicodecodepoint
The corresponding hexadecimal Unicode code point.

Syntax rules

• Start each line in column one.

• A pound sign (#) in column one indicates the line is a comment.

• Blanks are allowed.

IIMMBB sseerriiaall nnuummbbeerr ffiillee
The Intelligent Mail barcode (IMB) serial number file contains the serial number that you want AFP
Editor to encode in the first IMB that it creates in an AFP file.

Purpose

The IMB serial number file lets you create barcodes that contain sequential serial numbers.

Format

The file contains these lines:

digits=6|9
serial number

For example:

digits=9
000000001

IMB serial number file

http://unicode.org/charts/
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digits=6|9
The number of digits in the serial number. Valid values are:

6
The serial number contains 6 digits. When the serial number reaches 999999, the serial
number wraps to 000001. This is the default if digits is not specified.

9
The serial number contains 9 digits. When the serial number reaches 999999999, the
serial number wraps to 000000001.

sseerriiaall__nnuummbbeerr

The serial number to encode in the first IMB in an AFP file.

Syntax rules

• Start each line in column one.

• The file can contain only 2 lines. The lines can be in any order.

• No comments are allowed.

DDooccuummeenntt iinnddeexx ffiillee
The document index file contains the index tags that are in an AFP file. AFP Visual Environment can
create this file when it processes a production AFP file.

Purpose

The document index file lets you use archival and retrieval applications to retrieve a page group within
the AFP file based on its index values.

Format

The format of this file is similar to the document index file that the AFP Conversion and Indexing Facility
(ACIF) program creates. However, the resource group file that AFP Visual Environment creates contains
only group-level Index Element (IEL) structured fields; it does not contain page-level IELs. The format is:

BDI
IEL
TLE
EDI

BDI Begin Document Index (BDI) structured field.

IEL Index Element (IEL) structured field. The IEL structured field associates the index tags with a
page group in the output AFP file.

TLE Tag Logical Element (TLE) structured field. The TLE structured fields in the document index file
are the same as those in the AFP file.

EDI End Document Index (EDI) structured field.
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RReessoouurrccee ggrroouupp ffiillee
The resource group file contains all the resources that an AFP file references and that AFP Visual
Environment found inline or in an AFP resource directory. AFP Visual Environment can create this file
when it processes a production AFP file.

Purpose

The resource group file lets you print a file on a system that does not contain the AFP resources by
concatenating the AFP file and its resource group file.

Format

The format of this file is similar to the resource group file that the AFP Conversion and Indexing Facility
(ACIF) program creates. However, the resource group file that AFP Visual Environment creates does not
contain the name of the AFP file. The format is:

BRG
BRS
AFP resource
ERS
ERG

BRG Begin Resource Group (BRG) structured field

BRS Begin Resource (BRS) structured field

AAFFPP
rree--
ssoouurr--
ccee

The AFP resource

ERS End Resource (ERS) structured field

ERG End Resource Group (ERG) structured field

Resource group file
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10. Accessibility

Accessibility features help users who have a physical disability, such as restricted mobility or limited
vision, use information technology products successfully.

The accessibility features in AFP Visual Environment let users:

• Operate some features using only the keyboard.

• Customize some display attributes, such as font size.

AFP Visual Environment documentation is accessible using screen readers on the RICOH Software
Information Center at https://help.ricohsoftware.com/swinfocenter/.

https://help.ricohsoftware.com/swinfocenter/
https://help.ricohsoftware.com/swinfocenter/
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